1 Obráběcí funkce jsou, pochopitelně, nejdůležitější částí CAM

Komentáře

Transkript

1 Obráběcí funkce jsou, pochopitelně, nejdůležitější částí CAM
Obráběcí funkce jsou, pochopitelně, nejdůležitější částí CAM systému.
SolidCAM nabízí ucelenou řadu funkcí pro:
- frézování
- vrtání
- soustružení
- drátové řezání
Řada začíná u 2D a 2,5D frézování, které využívá 2D geometrie nebo kontur na 3D
modelu. Vybraná geometrie přitom zůstává asociativně spojena jak s modelem, tak s
vytvořeným NC programem. Stejně tak zadané hloubky obrábění zůstávají propojeny
na tvar modelu. Základní 2D frézování obsahuje funkce pro konturování, kapsování,
drážkování, vrtání včetně automatického vrtání a funkce pro frézování 3D
obecného tvaru pomocí profilové a vodící křivky.
Frézovací funkce v modulu 2D Plus jsou rozšířeny o automatické 3D hrubování a 3D
obrábění stěn a rovného dna. Tyto funkce nesmírně urychlují přípravu programů pro
obrábění prizmatických dílů jak pro hrub tak pro finiš. Uplatňují se výborně v
prototypové výrobě a výrobě komplikovaných, členitých obrobků.
3D funkce umožňují obrobit jakýkoli tvarový díl, snadno a efektivně. Několik strategií
pro hrubování dílu, dále řádkovací funkce, funkce Konstant-Z, směrové řádkování
podle jedné nebo dvou křivek, využití zbytkového materiálu, možnosti odvrtávacího
hrubování, nastavení pro rychlostní obrábění, … to jsou jen některé z možností 3D
frézovacího modulu.
Na soustružení je znát, že SolidCAM byl pionýrem v této oblasti. Programování je
extrémně snadné, přehledné, pracuje s pokročilými možnostmi jako zbytkovým
materiálem, strojními cykly nebo speciálními cykly pro Iscar nástroje.
Soustružení s poháněnými nástroji je rozhodně jednou z nejsilnějších aplikací –
dokonalost a přehlednost prostředí umožňuje řešit tuto nelehkou úlohu velmi
jednoduše. U tohoto programování hraje právě přehlednost velkou roli.Díl je potřeba
obrobit co nejvíce nástroji za všech stran pokud možno bez přepínání. Tuto
kombinaci soustružení a frézování včetně automatického dopočítávání a kontroly
zbytkového materiálu zvládá SolidCAM na výbornou.
Drátořez pak obsahuje i funkce, které v našem výrobním prostředí teprve čekají na
své uplatnění. Jsou to především funkce automatického hrubování, které se uplatňují
na západ od našich hranic, kde cena pracovní síly převyšuje cenu strojového času a
materiálu. Ale rovněž elegantní možnosti výběru a synchronizace geometrie, stejně
jako celková pružnost nastavení úhlů a synchronizačních bodů jsou důvodem pro
konstatování, že drátořez je produktivní nástroj i pro neobtížnější úlohy řezání drátem.
1
K nepřehlédnutí je funkce automatického vrtání. I velice členité díly vrtané ze všech
stran různými otvory, slepými, průchozími nebo různoběžnými, nejsou dost složité
pro zcela automatickou funkci rozpoznání otvorů a tvorbu vrtací technologie.
Topologií díry počínaje, návrhem nástrojů a správným setříděním operací konče.
Vrcholem frézovacích funkcí je souvislé pětiosé obrábění. Zde SolidCAM nabízí
implementovaný balík velice silných, v praxi osvědčených funkcí pětiosého frézování,
s kontrolou tvaru nástroje, geometrie CNC stroje a kompletním simulátorem stroje.
Poháněné nástroje
Soustružení s poháněnými nástroji
Často využívaná možnost volby poháněných nástrojů u soustruhu není již doménou
drahých obráběcích center. SoliCAM podporuje standardní nastavení soustruhu s
nástrojem kolmo k ose a souběžně s osou vřetena soustruhu.
Využitím standardních frézovacích NC-operací v libovolné kombinaci se
soustružením umožňuje lépe využít výkonné soustružnické pracoviště a zkrátí čas
výroby obrobením na jedno upnutí.
Standardně je však na soustruzích možné jen mimo-osé vrtání a jednoduché
frézování po kontuře v ose obrobku, bez možnosti posunutí obráběných prvků po
obvodu obrobku. Další rozšíření možností obrábění je možné s podporou C-osy,
nebo plně 4 a 5-ti osého soustružnického centra. Všechny tyto konfigurace stroje
jsou v SolidCAMu podporovány a navíc je tu i kontrola kinematických možností
daného stroje. Výsledný NC-program je generován jedním postprocesorem a je tak
zaručena kontinuita a spolehlivost celého procesu od zadání po první výrobek.
3D
3D frézování
Tento modul je určen pro programování obecných tvarových dílů, tedy především
forem, lisovacích nástrojů, zápustek a podobně. Neobsahuje v sobě 2D obráběcí
funkce jako konturu, kapsu, drážku či vrtání.
Tříosé funkce lze rozdělit do dvou podkategorií – hrubovací a dokončovací.
Funkce hrubování slouží k automatickému vyhrubování dílu hrubovacím nástrojem
2
nebo sadou nástrojů. Je možno hrubovat postupně stále menším nástrojem, kde
každý následující obrábí pouze zbytkový materiál po předešlých operacích. Rovněž
je možno nastavit pro jeden nástroj dva řezné průjezdy, kde v prvním nástroj s větším
krokem provádí kapsování a odebírá tak účinně velké množství materiálu, ve druhém
tentýž nástroj objíždí kontury a s menším krokem zmenšuje „schody“ po předešlém
průjezdu. Tato metoda šetří čas a je šetrná k obrobku. Obě metody lze, pochopitelně,
kombinovat.
Funkce dokončovací jsou typické kopírovací funkce jako lineární řádkování,
konstant-Z, spirální a paprskové řádkování, řádkování podle kontury (2 kontur),
tužkové obrábění atd.
Každá funkce má celou řadu nastavení pro optimální dokončení tvaru, nájezdy a
odjezdy, nastavení pro rychlostní obrábění atd.
Postprocesory
Postprocesory
SolidCAM je systém univerzální, schopný efektivně podporovat širokou škálu CNC
technologií. Představte si to množství strojů různých značek a s různými řídícími
systémy. Jen obtížně byste hledali stroj, který s pomocí SolidCAM nezvládnete.
V SolidCAM najdeme celou řadu již předdefinovaných postprocesorů, které zajistí
generování správného NC porgramu pro požadovaný CNC stroj. Je samozřejmé, že
lze jakýkoliv postprocesor uživatelsky dále a přesně definovat.
Postprocesor v SolidCAMu není jen nějaký prostý překladač drah nástroje do kódu
srozumitelného pro řídící systém, ale je to vlastně definice možností stroje s
konkrétním řídícím systémem a to včetně např. strojních cyklů, možností max.
otáček, max. posuvů atp.
Nemusí být pravidlem, že dva stroje se stejným řídícím systémem lze nakrmit
stejným programem, mohou tam být malé odlišnosti v možnostech stroje a zde se
ukazuje síla uživatelského komfortu SolidCAM. Z podporovaných sytémů lze
jmenovat např. Sinumerik, Heidenhain, Fanuc, Acramatic atd.Díky této otevřené
možnosti vlastní konfigurace postprocesorů máme možnost přizpůsobit SolidCAM
přesně svým požadavkům.
3
MOŽNOSTI obrábění v SOLID CAMu -Operace
S integrovaným obráběním pro 2,5D frézování a 3D frézování můžete programovat
obrábění různých typů geometrie a náročných tvarů na vašich dílech a modelech v
jedné jediné operaci. SolidCAM podporuje v současné době následující typy
frézování:
Kontura...
Obrábění podél jedné nebo více kontur.
Geometrie kontury může být otevřená nebo uzavřená. Můžete pracovat s funkcemi
G4x-korekce rádiusu nástroje, na levé nebo pravé straně profilu. Toto s výhodou
použijeme pokud neznáme přesný průměr
nástroje nebo předpokládáme, že v paměti
CNC stroje budeme později tento průměr
nástroje
měnit
(nebo
dle
potřeby
korigovat).SolidCAM může obrábět kontury
dvěma základními způsoby:
•
Obrábění jedné nebo více kontur v
různých hloubkách záběru, až do zadané
hloubky.
• Koncentrické profily obráběné až do
zadané hloubky. Zadá se volná
vzdálenost a boční přídavek. Nástroj
dodržuje profil od maximálního volné
vzdálenosti v pravidelných krocích. V
poslední třísce se může začistit (dokončit) profil při plnější hloubce záběru.
Kapsa..
.
Při frézování kapsy je odstraněn vnitřní materiál
uzavřené geometrie. Stěny a dno kapsy mohou být
doplněny přídavky na obrábění nebo obrobeny na
čistý rozměr.
SolidCAM může obrábět kontury kapsy dvěma
základními způsoby:
•
•
Pokud se skládá geometrie kapsy z jedné nebo
více kontur a žádná kontura se s jinou neprotíná
nebo je jinou konturou uzavřená, obrábí se
každá existující kontura zvlášť jako jednotlivá
kapsa bez ostrůvku. Pro každou konturu platí stejné nastavení pro celkovou
hloubku, hloubku záběru, přídavku na opracování atd.
Pokud se skládá geometrie z více kontur, stává se každá geometrie, která je jinou
konturou uzavřena ostrovem kapsy a neobrábí se
4
Vrtání...
Vrtací cykly nebo jiné obráběcí cykly jako je
závit, vystružení, vyhrubování atd. Se mohou
provádět na zadaných pozicích. SolidCAM
podporuje obráběcí cykly všech existujících CNC
- strojů pomocí adaptovaných postprocesorů.
3D model...
S použitím této volby můžete
obrábět objemy i obecné plochy,
souvislým řízením 3-os.Je k
dispozici množství strategií a
možností pro hrubování, předdokončení a dokončování. Tato
zadání se používají při výrobě
forem, nástrojů, prototypů a v
mnoha dalších případech ve
strojírenství a nástrojařské
výrobě.
Drážka...
Tato operace obrábí přesně střed geometrie
jednoho nebo více profilů. K dispozici jsou dva
způsoby:Jedna drážka s konstantní hloubkou obrábí drážku několika záběry až k zadané
hloubce. Drážka s proměnnou hloubkou se
zadává pomocí 2D hloubkového profilu, řezu,
hloubky drážky podél profilu v Z-směru.
Drážka se může obrábět hrubováním a před –
dokončením (je možné použití cyklů).
Dokončovací tříska je odvislá od předvolené
drsnosti povrchu.V závislosti na průměru
5
Použitého nástroje a šířce drážky se propočítá hodnota pro pravé a levé rozšíření
(pokud je drážka širší než průměr nástroje).
Tažená plocha...
Při operaci tažení se geometrie
řezu obrábí (táhne) podél profilu.
Zadá se profil (cesta tažení) a
požadovaný řez přes 2D geometrii.
S pomocí tak zvané hraniční
geometrie se může ohraničit
obrábění
na
jistou
oblast.
Kombinací konturové, řezové a
limitní geometrie se mohou obrobit
tvarově náročné plochy přes
jednoduché 2D řezy (s použitím pouhé 2D geometrie).
3D gravírování..
.
Text nebo jiné libovolné profily se mohou
umístit na 3D geometrii se zadanou hloubkou.
Profil nebo text se přitom promítne (obrobí) na
ploše
3D vrtání...
Tato operace vám umožňuje provádět
vrtání a ostatní vrtací cykly. Na rozdíl
od Operace Vrtání, Operace 3D
Vrtání vám umožňuje vzít v úvahu
geometrii
objemového
modelu.
SolidCAM vám umožňuje použít díry,
které byly vyrobeny touto operací pro
nájezd hrubování 3D modelu. Stejně
jako Operace Vrtání, Operace 3D
Vrtání
podporuje
vrtací
cykly
poskytované vaším CNC strojem jako
jsou
závitování,
vystružování,
vyvrtávání atd...
6
5-Osa...
Touto operací můžete definovat plynulé 5-ti osé frézování. Definice operace se stává
pouze z jednoho dialogového okna se širokou škálou možností obrábění a kontroly
pohybu nástroje.
7
Úvod
Už více než 10 let se tisíce zákazníků spoléhají
na výkon CAM řešení od firmy SolidCAM.
Největší předností SolidCAMu je velmi
jednoduchá obsluha a optimálně nastavené
postprocesory, díky kterým jsou CNC
programy spolehlivě připravené pro okamžité
použití ve výrobním procesu.
SolidCAM byl vyvinut speciálně pro požadavky výroby, proto ve velmi krátkém čase
může programátor vytvořit CNC programy dle zadaných konstrukčních dat.
Díky možnosti ukládání technologických zkušeností do tzv. „Operačních procesů“ lze
celý proces programování ještě více maximálně usnadnit a zautomatizovat.
Solid cam zapneme v prostředí SOLID
WORKS pomocí menu Nástroje Doplňkové
moduly kde zatrhneme okýnko.
8
Základní nastavení
Nastavení SolidCAMu...
V Nastavení SolidCAMu si můžete nastavit cestu k pracovním adresářům,
souborům, dále pracovní tolerance a jednotky, ovládání a používané barevné
schéma.
V horní liště SolidWorksu najdete nabídku SolidCAM.
Z rozbaleného roletového menu vyberte CAM Možnosti
Uživatelské
adresáře
pro
soubory
SolidCAMu.
V tomto adresáři se budou ukládat soubory a
NC programy, které budete zpracovávat.V
dialogu
každého
nového
dílu
můžete
samozřejmě definovat jiný adresář. Při otvírání
souborů hledá SolidCAM vždy nejprve v tomto
adresáři soubory s koncovkou *.prt.
Uživatelské
adresáře
pro
tabulky
SolidCAMu.
Do operačních procesů je možno uložit
kompletní
technologický
postup,
např.
Závitování. Operace předvrtání, vrtání, sražení
hrany a řezání závitu bude uložena jako jeden
operační proces a používána jako jedna
operace dohromady.
9
Jednotky
V tomto panelu můžete nastavit jednotky,
tolerance křivek,
řetězců, zbytkového
materiálu...
Milimetry/Palce
Zvolte si měrnou soustavu, ve které chcete
pracovat.
Aproximace
Pokaždé, když vybíráte křivku (NURBS), to
znamená neanalytický profil, (není to oblouk
nebo úsečka) jako obráběcí geometrii
(profil, hranici obrábění, ... ) spline křivka
aproximována,
tedy
bude
lineárně
nahrazena řetězcem úseček. „Spline
aproximace“ je tolerance nahrazení spline
křivky tímto řetězcem.
Poznámka
Tato tolerance nemá žádný vliv na práci s profily definovanými jako oblouky nebo
úsečky
Příklad:
U importovaného IGES plošného modelu jsou hranice ploch tvořeny ze spline křivek.
Když nyní chcete obrábět vnější obrys nějaké plochy jako 2.5D profil, musí se vnější
hranice plochy definovat jako tento profil.
Pokud tolerance v poli “Spline aproximace” byla nastavena příliš hrubě, dostanete
místo požadovaného profilu hrubý, jakoby nalámaný obrys. Nastaví-li se tolerance
jemněji, obdržíte po obvodě podstatně více čar a výsledný řetězec bude mnohem
přesněji sledovat původní profil.
10
Výběr řetězce
U automatického výběru geometrie řetězce používá SolidCAM více tolerancí, aby se
mohlo rozhodnout, zda jsou dva po sobě následující prvky spojeny nebo jsou na
sobě nezávislé. Přitom je měřena mezera či přesah mezi dvěma nebo více prvky.
Minimální a maximální mezera
Automatický výběr řetězce může rozlišovat
mezi třemi různými případy.Pokud je
mezera mezi dvěma po sobě jdoucími
prvky menší než minimální hodnota,
řetězení automaticky pokračuje jako by byly
prvky spojeny.
Leží–li řetězec mezi minimální a
maximální hodnotou, jste tázán, zda
řetězec má být uzavřen. Když odpovíte
ano, chová se řetězec jako uzavřený a
automatický výběr pokračuje.
Pokud je mezera větší než maximální
hodnota,SolidCAM signalizuje „řetězec
musí být spojitý “a řetězení se ukončí.
Tolerance Konstant-Z
Ve volbě Konstantní-Z tolerance se vybírají
automaticky jen ty prvky, které se nacházejí
ve stejné rovině. Tato tolerance udává, jak
dalece se smí příští prvek odchýlit od
rovinnosti.
Příklad:
Hodnota použité tolerance velmi záleží na velikosti a přesnosti načteného modelu. S
přednastavenými hodnotami se může s většinou modelů bezproblémově pracovat.
Příliš vysoká tolerance řetězení může vést k problémům, protože pokud je hodnota
pro maximální mezeru příliš vysoká, mohou být uzavírány i skutečné a chtěné
mezery mezi prvky. .Abychom se tohoto vyvarovali, odpovězte na otázku „řetězení
zavřít?“ne a přepněte do režimu „jednotlivý prvek”
11
Zadejte přesnost tolerance pro aproximaci
zobrazení Cílového (hotového) modelu –
obrobku. V této toleranci bude model
zpracován (polygonizován) pro simulaci a
pro porovnávání s obrobeným modelem
kvůli zobrazení zbytkového materiálu.
Ve většině frézovacích funkcí existuje
možnost zaoblení dráhy nástroje. Zde
zadaná hodnota je maximální hodnota,
která se může zadat pro zaoblení vnějšího
rádiusu na dráze.
Externí program
Zde se může nastavit cesta k libovolnému externímu programu, například k DNC
programu pro komunikaci se strojem.
Zde se může také například zadat program „Teileinf.exe“ (na CD v adresáři Utils).
Tento malý přídavný program dovolí zavádět ke každému SolidCAM dílu vlastní
komentáře.
12
Synchronizace
Zde definujete možnosti synchronizace při provedení změny geometrie Design
modelu.
Simulace
Zde můžete individuálně nastavit barvy pro každý nástroj, se kterým bude pracovat
simulace. Barevné nastavení, které zadáte, bude převzato pro aktuální díl, i pro
všechny příští CAM- díly. Pro změnu nastavení barvy klikněte na barevné pole vedle
odpovídajícího čísla nástroje. Otevře se standardní dialog Windows pro výběr barev.
Vyberte jednu barvu a potvrďte OK.
Uvedení do původního stavu:
Kliknutím na tlačítko Načti výchozí barvy se SolidCAM zase nastaví do původního
barevného nastavení.
13
DNC nastavení
Aby se mohl spustit přenos programu z PC do CNC stroje pomocí DNCTool, musíte
zadat správnou a úplnou cestu k aplikaci DNCTool.exe
Editory
SolidCAM generuje NC programy a také dokumentaci dílu jako textové dokumenty.
Zde můžete nastavit výchozí editory pro práci s touto dokumentací.
Editor pro CNC programy (*.tap, *.hnc,
*.txt)
Nastavte cestu k libovolnému textovému
editoru, (například Notepad, Wordpad,
které jsou součástí Windows).
Editor pro dokumentaci obrobku (*.doc)
SolidCAM zhotovuje dokumentaci pro
CAM-díly v textových souborech s
koncovkou *.doc, tedy podobně jako
Wordpad nebo Word.
SolidCAM je ve výchozím stavu nastaven
přes svůj vlastní editor, docedit.exe, ve
kterém můžete dokumentaci prohlížet a
tisknout. Avšak můžete použít pro tyto
úlohy. jiný libovolný textový editor, jako
např. Microsoft Word.
Titulní strana (pro
dokumentaci)Můžete použít
libovolné textové soubory
jako titulní stranu pro
dokumentaci vašeho dílu
14
Adresář postprocesorů (*.mac;*.gpp)
Zadejte adresář, ve kterém se nacházejí
vaše postprocesory a vyberte postprocesor,
který bude automaticky použit jako výchozí.
V dialogu každého nového dílu můžete
samozřejmě
vybrat
pokaždé
jiný
postprocesor pro jiný CNC řídící systém.
Standartní adresář:
….\SolidCAM2005\Gpptool
Použití:
Klikněte na vyhledávácí tlačítko Procházet podle aktuálního způsobu obrábění
(frézování, soustružení, soustružení& frézování - soustružení s poháněným
nástrojem a drátořez). SolidCAM indikuje všechny vhodné postprocesory, které se
nacházejí v uvedených adresářích pro post-procesory.
Dvojitým kliknutím si vyberte postprocesor podle vašeho přání.
15
Stručný přehled
Nový díl
Toto bude stručná ukázka tvorby CNC-programu.
Po otevření obráběného dílu v
SolidWorks vyberte z
nabídky
SolidCAM volbu Nový... a zvolte
způsob obrábění.
Zde: frézování
Frézování - data souboru:
V daném případě volte:
•
•
•
Adresář, např.
C: \Documents and
Settings\...
Název je zároveň jméno nového adresáře.
Všechna NC-data se uloží v tomto novém
adresáři.Název SolidCAM dílu se nemusí
shodovat s názvem SolidWorks dílu.
Model označuje cestu k původnímu
SolidWorks dílu.
Potvrďte OK
16
Nulové body
Nulový bod je výchozí pozice
souřadného systému pro veškeré
obrábění na zpracovávaném kusu.
Můžete definovat více nulových bodů a
u každé obráběcí operace volit, který
nulový bod pro aktuální práci použít
(indexované-vícestranné
obrábění).
Aby mohl být díl uložen do paměti,
musíte přinejmenším jeden nulový bod
vybrat. Klikněte na tlačítko Definovat
Nulový bod, aby jste mohli definovat
první pozici nulového bodu. Po této
volbě se zobrazí dialog Nulový Bod
zde ze stromu vyberete Definovat a
pak kliknete na bod na modelu kde má
být nulový bod a poté vyberete hranu
která určí směr osy X a hranu která
určí směr osy Y a tím je zadán Nulový
Bod tak jak je vidět na obrázku s
modelem.
17
Po nadefinování nulového bodu a potvrzení tlačítkem Konec se zobrazí toto
dialogové okno:
Data Nulového Bodu (operační prostor)
Nyní budou blíže vysvětleny možnosti definování dat v tomto dialogu.
• Poloha identifikuje nulový bod v SolidCAMu
• X značí X-hodnotu nulového bodu.
• Y značí Y-hodnotu nulového bodu.
• Z určuje hloubku-rozdíl mezi horní Z rovinou-rovinou aktuálního nulového bodu
a horní Z rovinou prvního nulového bodu dílu. Z-hodnota prvního nulového bodu
je rovná nula a nemůže se měnit.
• Číslo Nulového Bodu udává, který interní nulový bod souhlasí se SolidCAM
nulovým bodem.Hodnota daného bodu je 1.Pokud použijete nějaké jiné
číslo,použije se v NC-programu G-funkce tak, aby v CNC-systému odpovídal
nulový bod.
• Výchozí rovina nástroje určuje Z-výšku, od které najíždí nástroj při startování
programu rychloposuvem na rovinu rychloposuvu.
• Rovina Rychloposuvu je Z-rovina, na které se nástroj pohybuje rychloposuvem,
např. při najetí kapsy, pozice vrtání nebo mezi jednotlivými operacemi.
• Horní Z rovina - udává horní mez materiálu vzhledem k nulovému bodu.
• Dolní Z rovina - udává dolní mez materiálu obráběného dílu
Potvrzením tohoto okna tlačítkem OK se zobrazí okno
Správce Nulového Bodu:
Kde přes pravé tlačítko na myši můžeme dále pracovat s
nulovými body:
•
•
•
•
•
Přidat - přidání dalšího nulového bodu
Úpravy – úprava vybraného nulového bodu
Posun – posunutí nulového bodu
Zjistit – zobrazí vybraný nulový bod
Odstranit – odstraní vybraný nulový bod
18
Definice polotovaru
2D-Hranice
Definice polotovaru
pomocí libovolné 2Dskici,
nebo
existujících
obrysů
tělesa. X-Y obrys si
zadáme
2D
konturami. Hodnota
Z ohraničení je dána
od nulového bodu
maximální hodnotou
mezi horní a dolní
pracovní rovinou.
19
Vytvořený řetěz 2D Hrany polotovaru
může vypadat třeba takto:
3D-Model
Toto je zhotovení polotovaru pomocí
objemu (solidu) nebo ploch.
Použití
Např. při práci s odlitkem (dílem), to
znamená zkonstruování polotovaru,
aby byl možný výpočet zbytkového
(neobrobeného) materiálu
20
Automatický Box
Zhotovení pravoúhlého polotovaru prostřednictvím objemu
nebo ploch. Výběrem konkrétního Cílového (hotového) modelu
nebo povrchu obdržíte ohraničující kvádr jako polotovar.
Přidáním X-Y- a Z-hodnot můžete rozšířit obrysy kvádru.
S možností Přidat polotovar do CAD... se uloží do FeatureManageru CAM-dílu zachovaná vnější kontura (v SolidWorkssestavě).
Použití:
Např. při nepravidelné geometrii, kde je obtížná volba nulového
bodu a kvádr je jako polotovar dostačující.
Upozornění:
Kontury polotovaru můžeme vidět nebo skrýt.
Potlačení kontur se může zrušit/zapnout ve
Feature-Manageru SolidWorksu.
21
Cílový model - Obrobek
Zhtovení nebo výběr Cílového modelu - Obrobku pomocí objemu nebo ploch
22
Aktualizace polotovaru – Zbytkového materiálu
Zde si můžete vybrat ze dvou možností aktualizace a to buď Zbuffer a nebo Solid.
Zatrhněte možnost Aktualizovat Polotovar / Zbytkový materiál pokud chcete
propočítávat (aktualizovat) zbytkový materiál a použít jej pro obrábění na dílu.
U možnosti Zbuffer přes tlačítko
Nastavení otevřete
dialog –
Nastavení výpočtu Z Buffer, kde
musíte zadat hodnotu, jak přesně
má být zbytkový materiál vypočítán.
SolidCAM navrhuje hodnotu, která
se automaticky upravuje v závislosti
na velikosti modelu (doporučujeme
používat tuto automaticky zvolenou
hodnotu). Tato hodnota by se
pokud možno neměla překročit,
protože
propočet
zbytkového
materiálu může zabrat mnoho času.
23
Možnost Solid volte především při 4
a 5ti osém obrábění, protože tato
možnost
podporuje
výpočet
zbytkového materiálu z více stran
obrábění.
Stiskem
tlačítka
Nastavení se vám otevře dialog
Nastavení metody Solid kde
nastavíte jak si přejete obnovovat
zbytkový materiál.
buď Automaticky nebo Manuálně
pro volbu automaticky máte k
dispozici ještě další nastavení a to
jak často chcete ukládat polotovar a
jestli chcete provádět výpočet
zbytkového
materiálu
během
výpočtu operace.
Při volbě Manuálně ukládáte
polotovar-zbytkový
materiál
manuálně do souboru
Poté, co jste zadali všechna důležitá data a
určili pozici nulového bodu, potvrďte tlačítkem
Uložit & Konec, aby jste mohli začít obrábět
nový díl. Dialog Frézování – data souboru se
uzavře a vy můžete začít s programováním
jednotlivých operací (definice typů obrábění).
24
Nástroje
Nová tabulka nástrojů
Programovací čas se může značně zkrátit, když si často používané nástroje
v tabulce nástrojů definujeme a uložíme. S tabulkou nástrojů můžete volně nakládat
a používat ho, např. podle strojního vybavení, podle materiálu nebo dle každé jiné
preferované vlastnosti. Když zadáváte obrábění, můžete si nářadí z katalogu vybrat
a tím také všechny hodnoty pro posuvy, otáčky atd. budou zařazeny automaticky do
operace.
Postup:
1. Vyberte v roletovém menu
SolidCAM myší
políčko
Tabulka nástrojů.
2.
V menu zvolte položku
Vytvořit tabulku nástrojů
a zvolte Frézování nebo
Soustružení
nebo
FrézováníSoustružení.
3. Zadejte do zobrazeného
dialogu Nová tabulka nástrojů ->
Název tabulky: např 2D_platte.
4. Vyberte si Typ nástroje z rozbalovací
nabídky. V SolidCAMu jsou
některé typy nástrojů už
přednastaveny. Pokud jste
nadefinovali
doplňující
vlastní typy nástrojů, objeví
se tyto rovněž v liště.
Vyplňte prosím
všechny
zadávací políčka dialogu
Topologie-nástroje..a Data
nástroje (Výchozí)
Do tabulky můžete dále
přidávat nástroje kliknutím
pravým tlačítkem v okénku
Seznam nástrojů.
Tabulku uložíte stiskem OK.
25
Práce s Tabulkou nástrojů (pravým
tlačítkem na nástroj ve stromě
SolidCAM správce)
Tabulka nástrojů obrobku:
Zobrazí se tabulka nástrojů obrobku to
je tabulka která se ukládá spolu
s obrobkem do stejného adresáře a
jsou zde všechny nástroje používané
v operacích na daném obrobku.
Vybrat aktivní tabulku nástrojů:
Zde je možné vybrat aktivní tabulku
nástrojů. To je tabulka která má
nejvyšší prioritu pro import nástrojů do
Tabulky nástrojů obrobku.
Další volby jsou:
Zavřít aktivní tabulku nástrojů – odebere vybranou aktivní tabulku nástrojů
Ukázat aktivní tabulku nástrojů – zobrazí vybranou aktivní tabulku nástrojů
Poslední Tabulky nástrojů – zobrazí výběr naposledy načítaných tabulek nástrojů
26
Práce s Tabulkou nástrojů (z roletového menu SolidCAMu)
V této roletě jsou k dispozici tyto
nástroje pro práci s tabulkami nástrojů:
Úpravy tabulky nástrojů:
Zde můžete upravovat již vytvořené
tabulky nástrojů přímo výběrem
souboru tabulky *.tab.
Vytvořit tabulku nástrojů:
Zde můžete vytvořit novou tabulku
nástrojů pro Frézování nebo
Soustružení nebo
FrézováníSoustružení.
Kopírovat tabulku nástrojů:
Vytvořit kopii jednoho katalogu nástrojů do jiného adresáře nebo jednotky jako
zálohu.Aby se mohly provádět změny, aniž bychom měnili originál.
Objeví se dialog: Kopíruj tabulku
nástrojů.
Tvarové nástroje...:
Zde můžete vytvářet a upravovat
tvarové nástroje.
Nástroje a Držáky nástrojů:
Zde můžete vytvářet nebo upravovat
držáky nástrojů.
Výchozí Otáčky&Posuvy:
V téhle části definujete výchozí řezné
podmínky a nebo můžete upravovat již
nadefinované.
Názvy typů nástrojů...:
V SolidCAMu si můžete vložit a
vytvářet vlastní nástroje. Tyto funkce
Vám dovolí Vaše nástroje lépe
spravovat. Můžete nástroje vyhledávat
a volit, vytvářet potřebné vlastní
nástroje podle individuálních tříd a
kritérií. Toto je účelné hlavně při práci
s velmi obsáhlým nástrojovým
katalogem.
Smazat tabulku nástrojů:
Touto volbou smažete vybraný soubor
tabulky nástrojů.
Upravit nabídku:
Tato možnost vám dovoluje upravit
obsah tohoto roletového menu.
27
Popis Dialogu tabulky nástrojů:
Tyto tří volby přepínají
zobrazení:
1. Zobrazení všech
nástrojů
2. Zobrazení nástrojů
použitých v operaci
3. Zobrazení
nepoužitých ástrojů
List Tabulka nástrojů
– Ukázat zobrazuje
seznam nástrojů s
kompletním popisem.
List Tabulka nástrojů– Úpravy
má tři části:
1. Typ nástroje: zde
volíte specifický
tvar nástroje.
2. List Topologie
nástroje: zde
definujete ompletní
parametry nástroje
a držák nástroje.
3. List Data nástroje
(Default): zde
volíte řezné
podmínky a čísla
korekcí.
V téhle části dialogu
můžete pravým
tlačítkem volit:
28
Rozsah
Možností Rozsah můžete aplikovat různé filtry z tabulky, pro hledání podle nástrojů
nebo jen zobrazení určitých nástrojů nebo typů.
29
Simulace
Pokud se vyskytne chyba při definici operace nebo
byla zvolena nevhodná obráběcí strategie, může
simulace zabránit problémům, které by jinak vznikly
ve výrobě. Se simulačním modulem SolidCAMu lze
obrábění, které jste vytvořili, graficky zobrazit a
ověřit (verifikovat).
Vyberte ve stromu CAM Správce myší políčko
požadované operace a stiskněte pravé tlačítko
myši. Objeví se nabídkové menu. Vyberte si v
menu příkaz Simulace.
Objeví se panel nabízející různé způsoby
simulace. Zvolte si simulační režim. (Dejte pozor,
protože podle definice dílu a obrábění nejsou
všechny způsoby simulace vhodné).
Pokud
aktivujete
volbu
Ukázat data zobrazí se
panel
s
pomocnými
informacemi.
30
Ovládání simulace
Vyčištit:
Tento příkaz odstraní z
obrazovky všechny
zobrazující se dráhy
nástrojů
Ukončit: Ukončí simulaci
Režim operace: Simuluje jen jednu operaci a
zastaví simulaci před další operací. Pro
simulaci další operace klikněte znovu na
tlačítko start nebo stiskněte mezerník
klávesnice.
Samostatný krok: Spouští simulaci krok po
kroku NC-programu, po provedení každého
kroku zastaví simulaci. Pro simulaci příštího
kroku klikněte znovu na start nebo stiskněte
mezerník klávesnice.
Pauza: Zastavení simulace.
Start: Simulace v souvislém režimu.
Turbo: Propočet proběhne skrytě na pozadí,
zobrazí se okamžitá hodnota výsledku
(obrobený díl).
31
Způsoby simulace
Dráha nástroje se ukáže v OpenGL-zobrazení hotového modelu. Aby se mohla tato
simulace použít, musel být vložen 3D model jako Cílový (hotový) model (Obrobek) v
dialogu Data souboru. Tento 3D model se potom přepočítá dle CAM nastavené
zadané tolerance. Když volíte tuto simulaci, otevře se okno, ve kterém pomocí ikon
můžete volit mezi různými funkcemi a náhledy.
CAD simulace
Nástrojová dráha na CAD modelu
(následná volba 3D simulace=OpenGL)
•
•
Hotový díl jako 3D-zobrazení
Vyobrazení nástrojů s dráhou středu frézy, je
možný náhled průměru
2D simulace
•
•
Frézovací geometrie v 2D-půdorysu
Nástrojové zobrazení s dráhou středu frézy a
průměrem.
VerifyPlus simulace
•
•
•
Cílový (hotový) díl v 3D-zobrazení
Polotovar v 3D-zobrazení
Nástroj v 3D- zobrazení
Solid Verify simulace
•
•
•
•
•
•
Cílový (hotový) díl v 3D zobrazení
Polotovar v 3D zobrazení, nástroje v 3D
zobrazení.
Zobrazení zbytkového materiálu
Držák/nástroj, změna osvětlení
Zobrazení vodítka (drátořez)
Kontrola kolizí
32
Příklad 1
Vytvoření NC programu pomocí CAM- již
z zhotoveného modelu v programu SOLID Works
Zde jsou nyní uvedeny příklady na procvičení postupu při definici obrábění frézování.
Co se máme naučit
Definování nulového bodu
Vytvoření polotovaru pomocí –„Kvádr (auto)
Volba Cílového modelu
Definování nástrojů, řezných podmínek
Definování řetězení/ definování geometrie vrtání
Práce s 2D-operací:
• Kontůra
• Kapsa
• Vrtání
Tvorba drah nástrojů, operace, simulace, NC- program
33
Založení nového projektu
Z roletového menu zvolte Nový --> Frézování
Objeví se dialogové okno Frézování – data souboru
1
2
3
4
V tomto dialogovém okně nastavíte:
1. Adresář – tlačítkem Procházet nastavíte Adresář do kterého se budou
ukládat data k obrobku
2. Název – napíšete název obrobku
3. Model – tlačítkem Procházet nastavíte model který chcete obrábět v našem
případě --- SKRIPTA.SLDPRT
4. Ukončíte tlačítkem OK
Dále po předchozím ukončení tlačítkem OK určíme pozici nulového bodu „NBO“
34
Definování nulového bodu
Zatrhněte políčko (pokud už není zatrženo) Více nulových bodů a stiskněte tlačítko
Definovat Nulový bod pak se zobrazí následující dialogové okno:
Zde vyberte ze pod menu Definovat Nastavení položku Definovat
35
Máte už automaticky stlačené tlačítko Počátek a klikněte na bod na modelu kde má
být umístěn nulový bod, jak je zobrazeno na obrázku vpravo.
Po vybrání Počátku se vám automaticky stiskne tlačítko X směr a vy musíte vybrat
bod nebo hranu udávající směr X osy, jak je zobrazeno na obrázku vpravo.
36
Po vybrání směru osy X se vám automaticky stiskne tlačítko Y směr a vy musíte
vybrat bod nebo hranu udávající směr Y osy, jak je zobrazeno na obrázku vpravo.
Tímto máme definovaný nulový bod a dialogové okno Nulový Bod ukončíme stiskem
tlačítka Konec
37
Po ukončení tlačítkem Konec se zobrazí dialogové okno Data Nulového Bodu:
V tomhle dialogovém okně
ohmatáme obráběný model myší
abychom jsme získali přesné
hodnoty pro
Horní Z rovinu a pro Dolní
Z rovinu.
Tohle ohmatání modelu provedeme
tak že klikneme na tlačítko Horní
Z rovina a zobrazí se dialogové
okno Uchopit Horní rovinu
Uchopení Horní roviny provedeme tak že klikneme myší na horní rovinu na modelu
obrobku a do dialogového okna Uchopit Horní rovinu se načte Z hodnota horní
plochy modelu obrobku (21). Toto dialogové okno ukončíme stiskem OK a
uchopená hodnota se přenese do dialogového okna Horní Z rovina.
Kliknutím na
tuhle plochu
vyberete hodnotu
pro Horní Z
rovinu
Stejným postupem vybereme i hodnotu pro Dolní Z rovinu
Kliknutím na
tuhle plochu
vyberete hodnotu
pro Dolní Z
rovinu
38
Dále nastavíme hodnoty pro Výchozí rovinu
Rychloposuvu na 30 a Z rovinu nástroje na 40.
nástroje
na
40,
Rovinu
Rovina Rychloposuvu musí být
nad Horní Z rovinou a Výchozí
rovina nástroje by měla být nad
Rovinou Rychloposuvu.
Pokud máme vše zadáno ukončíme
dialogové okno Data Nulového
Bodu stiskem tlačítka OK a objeví
se další dialogové okno Úprava
Nulového Bodu.
V tomto dialogovém okně se nám zobrazí položka Stroj1 (Pozice1) a tato položka
reprezentuje námi nadefinovaný nulový bod. Tento dialog ukončíme stiskem tlačítka
Konec.
39
Dále zadáme Postprocesor. Požadovaný typ vybereme z roletového menu
Postprocesor. V našem případě je vybereme např. základní programovací jazyk
„DIN-ISO“-vhodný pro výukové stroje.
Vytvoření polotovaru
Pak budeme definovat Polotovar stiskneme tlačítko Polotovar
40
Po stisku tlačítka Polotovar se zobrazí dialogové okno
Polotovar ve kterém zvolíme volbu Kvádr(Auto) a stiskneme tlačítko definovat.
Následně se zobrazí dialogové okno Obrysový kvádr ,kde
stiskneme tlačítko Vybrat v podokně Režim a Plochy a solidy
v podokně Typ.Kurzorem vybereme model, v dialogové okně
Zvětšit kvádr a rozměr zapíšeme přídavky na polotovar
v jednotlivých osách. Přidali jsme 1mm na vrchní
plochu.Zadáme Jméno – (POLOTOVAR)
Pokud jsme vše zadali , potvrdíme OK (zelené zatržítko)
41
Pak se zobrazí okno pro zadání Polotovar
kde opět potvrdíme zelené zatržítko
Tímto je polotovar nadefinován.
Volba cílového modelu
Dále budeme definovat Obrobek. Definici začneme
stisknutím tlačítka Obrobek.
Po stisku tlačítka Obrobek se zobrazí dialogové
Okno Obrobek ve kterém stiskneme tlačítko
Definovat 3D Model.
Pak se zobrazí dialogové okno 3D Geometrie
kde vybereme Vybrat a Plochy+Solidy a
klikneme na model obrobku.
42
Po kliknutí se v dialogu 3D Geometrie zobrazí nová položka Solid 1 která
reprezentuje vybraný model obrobku.
Po výběru ukončíme dialog zadáme název
geometrie – např. součást. Tlačítkem OK
ukončíme výběr 3D Geometrie .
Potom se nám znovu zobrazí okno Obrobek
kde stiskneme pro potvrzení tlačítko OK.Tímto
jsme ukončily definici Obrobku.
Ještě nastavíme Aktualizaci Polotovaru / Zbytkového materiálu na Zbuffer.
Dialogové okno Frézování – Data
souboru ukončíme stiskem tlačítka
Uložit & Konec.
43
Vytvoření podkladů pro vygenerování NC kódu
Nyní můžeme přejít k samotnému obrábění tvarů na modelu obrobku.
Nejprve obrobíme boční osazení na modelu obrobku - Kontura.
Kliknutím pravým tlačítkem na Operace ve stromě CAM správce vybereme z menu
Přidat Operaci --> Kontura...
Definování řetězení/ definování geometrie
Nejprve nadefinujeme geometrii kontury,
kterou budeme obrábět. Stiskneme
tlačítko Definovat v oddělení Název
geometrie.
44
Zobrazí se okno Úprava geometrie ve kterém stiskneme tlačítko rolovátka Řetězec.
V oblasti Řetězc vybereme Jednotlivé prvky – Křivka a vybereme
hrany pro obrobení kontury
Po výběru řetězce ukončíme oblast Možnosti řetězce tlačítkem
ANO v okně. Pak
se znovu zobrazí
okno Úprava
geometrie ve
kterém už vidíme
námi vytvořený
řetězec Řetězec1
takže tohle okno
ukončíme tlačítkem
Konec. Pak se
zobrazí okno pro
zadání Názvu
geometrie kde
napíšeme do
Jména např.
kontura. A
ukončíme stiskem
tlačítka OK.
A tímto máme nadefinovanou geometrii kontury pro obrábění.
45
Definování nástrojů
Po nadefinování kontury budeme definovat nástroj. Stiskněte tlačítko Definovat
v oddělení Nástroj.
V zobrazeném okně vybereme list Výběr nástroje pro operce – Tabulka nástrojů Upravit .Tlačítkem Přidat zahájíme definování použitých nástrojů.
46
Pak se zobrazí možnosti pro definování nástroje. Vybereme Typ nástroje Hrubovací frézy.V kartě zadáme parametry nástroje .Průměr „25“ pak Poloměr
zaoblení na čele frézky „0“.Upravit můžeme i další parametry v kartě Délka.Všechny
hodnoty můžeme kontrolovat na náčrtku, eventuelně pootočit 3D modelem. Pro
potvrzení nástrojového výběru použijeme tlačítko Vybrat
Tímto máme nadefinovaný nástroj a v kartě Nástroj vytvoříme poznámku- Pro
konturu. Upravíme řezné podmínky pro obrábění v závislosti na použitém materiálu
nástroje. V kartě Data nástroje . Otáčky, posuvy….Potvrdíme a ukončíme definování
nástrojů. OK
Definování řezných podmínek
47
Dále budeme definovat oblast Frézovací roviny.
Definici Horní Z roviny a Hloubky kontury provedeme uchopením ploch na modelu
obrobku. Stiskneme tlačítko Horní Z rovina a ukážeme myší na horní plochu modelu
obrobku a potvrdíme OK, pak stiskneme tlačítko Hloubka kontury a ukážeme na
spodní plochu která udává hloubku obrábění kontury a potvrdíme OK a do políčka
Krok dolů zadáme hodnotu 2.
Místo uchopení
Horní Z roviny
Místo uchopení
Hloubky kontury
Na baneru provedeme kontrolu a potvrdíme tlačítkem OK
48
Definování vlastností a způsobu obrábění
Dále nadefinujeme zbytek operace v dialogu Kontura
4
3
1
5
6
7
2
7
8
9
1. Aktivujeme průměrovou korekci vpravo G42
2. Určíme směr obrábění Vpravo – Směr profilu- výchozí
Strana Nástroje umožňuje určit polohu nástroje ve vztahu k geometrii.obrobku vzhledem
ke směru obrábění
Vpravo –
Nástroj bude obrábět pravou stranu geometrie kontury.
Vlevo -
Nástroj bude obrábět levou stranu geometrie kontury.
Po kontuře –Střed nástroje se bude pohybovat po geometrii kontury. (s touto volbou
může být použito nastavení Ne pro korekci G4x)
Ukázat
zobrazí geometrii řetězce kontury, její směr a kružnici která reprezentuje
nástroj ve vztahu k geometrii. Zobrazení používá aktuální nastavení směru
kontury a strany nástroje.
3. Zatrhneme Hrubování a nastavíme přídavek na Přídavek na stěny –
Odsazení, Krok dolů
49
4. Typ sestupu- posuvem,rychloposuvem event. Graficky- Posuv
5. Nastavíme způsob Nájezdu k polotovaru dle následující stránky –
Oblouk a jeho Poloměr
Žádné
Nástroj najíždí a odjíždí od roviny frézování přesně v počátečním bodě kontury.
Kolmo
Nástroj najíždí a odjíždí od kontury z bodu kolmého ke kontuře.
Délka kolmice může být nastavena v poli Hodnota.
Oblouk
Nástroj najíždí a odjíždí od kontury po tečném oblouku. Poloměr
oblouku může být nastaven v poli Hodnota.
Tečna
Nástroj najíždí a odjíždí po tečné přímce ke kontuře. Délka tečny
může být nastavena v poli Hodnota.
Bod
Nástroj najíždí a odjíždí do uživatelem definované polohy. Z této
polohy se nástroj pohybuje po přímce k počátečnímu bodu kontury. Jestliže vyberete tuto volbu,
pak se aktivuje tlačítko Uchopit a můžete vybrat polohu přímo na objemovém modelu.
6. Můžeme nastavit způsob Odjezdu obdobně jako
hodnoty u nájezdu
7. Zbytkový materiál \Sražení – Žádné
8. Definovat hloubku- Konstantní
9. Zpráva- možnost popisky dané operace
Pak stiskneme tlačítko Uložit & Přepočítat .Po těchto
úkonech můžeme spustit Simulaci na které můžeme
vidět veškeré dráhy,kolizní stavy…
V případě úprav nástroje,řezných podmínek,nájezdů..
nesmíme zapomenout tyto změny potvrdit tlačítkem
Uložit & Přepočítat.
A kartu ukončíme stiskem tlačítka Ukončit.Ukončená
operace Hrubování se objeví ve stromovém okně.
50
Dále dokončíme boční osazení.
Vybereme hotovou geometrii
Stejně jako v předchozí
operaci klikneme pravým
tlačítkem na strom CAM
správce na položku
Operace a zvolíme Přidat
Operaci --> Kontura... a
zobrazí se dialog Kontura
kde v oblasti Název
geometrie vybereme
z rolety jíž nadefinovanou
geometrii profile.
Dále stejně jako v předchozí
operaci nadefinujeme
nástroj, vybereme nástroj
Dokončovací frézy.
Průměr 20… Dle tabulky
níže.Pak stiskneme tlačítko
Vybrat. Zobrazí se dialog
Nástroj, tento dialog pouze
potvrdíme stiskem tlačítka
OK.
Stejně
jako
v předchozí
operaci
nadefinujeme
Frézovací
roviny
uchopením Z rovin z modelu obrobku,
aktivujeme oblast Dokončení a Krok dolů
nastavíme na hodnotu 4.
Nastavení nástroje pro dokončení.
Řezné podmínky pro dokončení
nastavíme v Data nástroje
51
Dále nadefinujeme zbytek operace v dialogu Kontura.
8
9
4
1
10
5
11
2
3
1.
2.
3.
4.
5.
6.
6
7
12
Strana nástroje – Vpravo - zapnout korekci
Směr profilu – Výchozí
Definovat hloubku na volbu Konstantní
Upravit geometrii – Přídavek na hodnotu 0
Deaktivujeme oblast Hrubování a zatrhněte Dokončení
Počet finálních řezů na 1
Vše ostatní (7-12) nastavíme dle uvážení ,technologie….
Pak stiskneme tlačítko Uložit & Přepočítat a dialog ukončíme
stiskem tlačítka Ukončit
A kartu ukončíme stiskem tlačítka Ukončit.Ukončená operace
Dokončování se objeví ve stromovém okně.
52
Poslední úkon bude provedení kontroly pomocí Simulace ,kterou provedeme v kartě
nebo v stromovém okně CAM.
53
Definování a obrábění kapsy-hrubování
Nyní budeme na modelu obrobku definovat obrábění kapsy 1.
Stejně jako v předchozí operaci klikneme pravým tlačítkem na strom CAM správce na
položku Operace a zvolíme Přidat Operaci --> Kapsa... a zobrazí se dialog Kapsování,
kde v oblasti Geometrie stiskneme tlačítko Definovat pro definici geometrie kapsy.
Zobrazí se dialogové okno Úprava geometrie.
V levé části obrazovky se zobrazí menu ze kterého vybereme Řetězec --> Křivka. A
začneme vybírat geometrii řetězce a vybereme hrany jak znázorňuje obrázek. Výběr
potvrdíme stiskem Ano. V dialogovém okně Úprava geometrie se nám zobrazí vybraná
geometrie kapsy. Tento dialog ukončíme stiskem
tlačítka .
54
Nyní budeme definovat nástroj č.2 – D8. Stiskneme tlačítko Definovat v oblasti Nástroj.
Zobrazí se dialog Nástroj . Nadefinujeme vše podle následující tabulky, kde ukončíme
výběr nástroje stiskem tlačítka OK v dolní části dialogového okna. Tímto máme vybrán
nástroj pro naši operaci.Nezapomeneme nadefinovat řezné podmínky –Data nástroje
55
Nyní budeme definovat oblast Frézovací roviny dialogového okna Kapsování. Definici
provedeme uchopením hodnot Horní Z roviny a Hloubky kapsy z modelu obrobku.
Stiskneme tlačítko Horní Z rovina a klikneme na plochu modelu jak je vidět na obrázku.
Ukončíme výběr stiskem
.
56
Stejným způsobem vybereme Hloubku Kapsy.
Krok dolů nastavíme na hodnotu 2.
V oblasti Typ kapsování z rolety vybereme Kontura a stiskneme tlačítko Data. Zobrazí se
dialogové okno Parametry Kontury.
57
Vybereme parametry pro výrobu kapsy dle
obrázku.Určíme druh obráběníSouslednost/Nesouslednost . Tlačítko Trochoida a
Vnoření nebudeme vyplňovat. Po vyplnění tohoto
dialogového okna jej ukončíme stiskem tlačítka OK.
Zbytek dialogového okna Kapsování vyplníme podle
přiloženého obrázku:
Tímto definice kapsovací operace hotová, stiskneme tlačítko Uložit & Přepočítat a
dialogové okno ukončíme stiskem tlačítka Ukončit. Můžeme si pomocí Simulace
zkontrolovat správnost provedené operace.
58
Definování a obrábění kapsy-dokončování
Nyní budeme definovat obrobení zbytkového materiálu pro kapsy.
Nejprve obrobení zbytkového materiálu pro Kapsu 1.
Stejně jako v předchozích operacích klikneme pravým tlačítkem na strom CAM správce na
položku Operace a zvolíme Přidat Operaci --> Kapsa... a zobrazí se dialog Kapsování,
kde v oblasti Geometrie vybere z rolety už nadefinovanou geometrii profile1.
Nyní budeme definovat nový nástroj č4 D8. Stiskneme tlačítko Definovat v oblasti
Nástroj. A nadefinujeme nový nástroj č4 Dokončovací . Průměr 6, Rádius rohu 0, Délku
– Celková 45, Venku z držáku 35, Řeznou část 30. Pak dvakrát klikneme na nástroj 4
v Seznam nástrojů a ukončíme definici stiskem tlačítka OK. Definici provedeme stejně
jako v předchozí části cvičení.
Definici Frézovacích rovin provedeme stejně jako u Kapsy 1 a Krok dolů nastavíme na
hodnotu 1.
Typ kapsování a příslušná Data nastavíme stejně jako u Kapsy 1.
V oblasti Zbytkový materiál \ Sražení vybereme z rolety volbu Zbytkový materiál a
stiskneme tlačítko Data. Zobrazí se dialogové okno Zbytkový materiál, které nastavíme
tak jak je vidět na obrázku.
59
Zbytek dialogového okna Kapsování nastavíme tak jak je vidět na obrázku.
A stiskneme tlačítko Uložit & Přepočítat a operaci ukončíme stiskem Ukončit.
K operaci kapsování
1.
2.
3.
4.
Kapsy, které leží v té samé hloubce a na tom samém povrchu, se mohou obrábět v jedné operaci.
Geometrické řetězce, které leží uvnitř jiných řetězců, se berou v úvahu jako ostrovy.
Kapsová geometrie musí tvořit uzavřený řetěz.
Startovací bod pro dokončení kapsy se stanovuje geometrií, poloměrem nástroje a překrytím a
nemůže se manuálně měnit. Definovaný sestupový bod stanovuje, kde nástroj sestupuje, potom
nástroj přímo najede na startovací bod pro dokončení, prosím dávejte pozor, tento pojíždějící pohyb
není kontrolovaný (např. ostrov).
60
Nyní máme hotovy všechny kapsovací operace na tomto obrobku a budeme provádět
obrábění děr.
PŘEDVRTÁNÍ otvorů
Definice obrábění Předvrtání
Stejně jako v předchozích operacích klikneme pravým tlačítkem na strom CAM správce na
položku Operace a zvolíme Přidat Operaci --> Vrtání... a zobrazí se dialog Vrtací
operace, kde v oblasti Geometrie stiskneme tlačítko Definovat pro definici geometrie
vrtání.
Zobrazí se okno Výběr vrtací geometrie.
Kde navolíme Režim – Vybrat
Zatrhneme Všechny středy
Zatrhneme Dle rádiusu a klikneme na tlačítko
Zobrazí se dialog Vybrat rádius
Kde zatrhneme Vybrat Kružnici/Oblouk a na
modelu vybereme hranu díry o průměru 4. Jak
je vidět na spodním obrázku.
Pak zatrhneme volbu Na Z – rovině a zmáčkneme tlačítko a vybereme horní plochu
modelu obrobku.
Nakonec zmáčkneme tlačítko Všechny středy a SolidCAM provede výběr všech středů
průměrů 4 v Z rovině 21.
61
Pokud vše provedeme dobře, tak se objeví všechny vybrané otvory viz obrázek. Ve
spodním roletovém okně Výběr vrtací geometrie se objeví souřadnice středů vrtaných
otvorů
.
Dialogové okno Výběr vrtací geometrie ukončíme stiskem
62
Pak se znovu zobrazí Dialogové okno Vrtací operace. Ve kterém teď budeme definovat
nástroj. Stiskneme tedy tlačítko Definovat v oblasti Nástroj.
Zobrazí se nám okno pro definování nebo výběr nástroje. My budeme definovat nový
nástroj vrták, přejedeme tedy do listu Tabulka nástrojů – Úpravit. Kde klikneme pravým
tlačítkem na strom Seznam nástrojů a vybereme Přidat nástroj. Tím se otevře nabídka
pro přidání nového nástroje.
Nový nástroj vyplníme podle obrázku:
63
Nezapomeneme upravit a nastavit řezné podmínky pro definovaný nástroj v záložce
Data nástroje
Po nastavení všech hodnot ještě dvojklikneme na nově nadefinovaný nástroj číslo 5 ve
stromě Seznam nástrojů a zadávání ukončíme stiskem OK.
Pak se znovu zobrazí dialogové okno Vrtací operace kde teď budeme definovat hloubku
vrtání.
Nejdříve stiskneme tlačítko Horní Z rovina a klikneme na horní plochu modelu obrobku.
64
Potom stiskneme tlačítko Hloubka vrtání a klikneme a spodní plochu otvorů jak je vidět
na obrázku:
Vybereme cyklus vrtání- G83 vrtací cyklus výplachem
nastavíme krok dolů pomocí tlačítka Data
Tímto máme vše nadefinováno a můžeme stisknout tlačítko Uložit & Přepočítat a pak
tlačítko Ukončit.
65
VRTÁNÍ otvorů
Definice obrábění Vrtání
Stejně jako v předchozí operaci klikneme pravým tlačítkem na strom CAM správce na
položku Operace a zvolíme Přidat Operaci --> Vrtání... a zobrazí se dialog Vrtací
operace, kde v oblasti Geometrie stiskneme tlačítko Definovat pro definici geometrie
vrtání.
Zde vybereme již nadefinovanou vrtací strategii Předvrtání
Opět zvolíme hloubky vrtání podle již známého postupu.
Nejdříve stiskneme tlačítko Horní Z rovina a klikneme na horní plochu modelu obrobku.
Potom stiskneme tlačítko Hloubka vrtání a klikneme a spodní plochu zahloubení jak je
vidět na obrázku:
66
Pak se znovu zobrazí Dialogové okno Vrtací operace, ve kterém teď budeme definovat
nástroj. Stiskneme tedy tlačítko Definovat v oblasti Nástroj.
A stejně jako v operaci Vrtání 1
nadefinujeme nový vrták (Vrtáky) o
průměru 4, Úhel 118, Délka –
Celková 36, Venku z držáku 24,
Řezná část 24.Nebo podle použitého
konkrétního nástroje.Opět definujte
řezné podmínky-Data nástroje.
Volbu ukončíme OK
Také musíme navolit Typ Vrtacího
cyklu a Datech navolíme potřebné
parametry cyklu.
67
Tímto máme vše nadefinováno a můžeme stisknout tlačítko Uložit & Přepočítat.Po těchto
operacích
Se můžeme přesvědčit o správnosti postupu a způsobu obrábění pomocí Simulace
v jednotlivých operačních kartách.Případné korekce provedeme v příslušné kartě a
nesmíme zapomenou tyto změny potvrdit tlačítkem Uložit & Přepočítat.
Celou kartu Vrtací operace ukončíme tlačítkem Ukončit.Vyhotovená operace se opět
zobrazí ve stromu CAM správce.
68
Definování a obrábění kruhových kapes -hrubování
Nyní budeme na modelu obrobku
definovat obrábění Kruh kapsy.
Stejně jako v předchozí operaci klikneme
pravým tlačítkem na strom CAM správce
na položku Operace a zvolíme Přidat
Operaci --> Kapsa... a zobrazí se dialog
Kapsování,kde v oblasti Geometrie
stiskneme tlačítko Definovat pro definici
geometrie kapsy.
Zobrazí se dialogové okno Úprava
geometrie.
V levé části
obrazovky se
zobrazí menu ze
kterého vybereme
Řetězec --> Křivka.
A začneme vybírat
geometrii řetězce a
vybereme hrany jak
znázorňuje obrázek.
Výběr potvrdíme
stiskem Ano.
V dialogovém okně
Úprava geometrie
se nám zobrazí
vybraná geometrie
kapsy. Tento dialog ukončíme stiskem
tlačítka.
69
Dále vybereme již nadefinovaný nástroj
z knihovny nástrojů.Vybereme číslo 3
drážkovací D8.Výběr potvrdíme OK
Po potvrzení nástrojů se otevře již známá karta
Geometrie.
Tuto kartu vyplníme podle níže uvedeného obrázku.
Nejprve myší vybereme Horní Z rovinu a Hloubku
kapsy podle známého postupu z předešlých
operací.Následovně zvolíme strategii obrábění vyhrubujeme obě kruhové kapsy s přídavky 1mm.
Tímto
máme
vše
nadefi
nován
o a můžeme stisknout tlačítko Uložit
& Přepočítat a pak tlačítko Ukončit.
Případně provést kontrolu pomocí
Simulace.
70
Stejným postupem budeme pokračovat ve hrubování kruhové kapsy o menším
průměru. Navolíme potřebné parametry v kartě Geometrie.Musíme podle známých
pravidel nadefinovat Geometrii- kruh kapsa malá.Ostatní doplníme podle
tabulky.Zapíšeme popisy k operacím .Pro hrubování ponecháme stejný nástroj
číslo 3.
Horní Z rovina
15
Hloubka kapsy 6
71
Definování a obrábění kruhových kapes –dokončení
Stejně jako v předchozí operaci klikneme pravým tlačítkem na strom CAM správce na
položku Operace a zvolíme Přidat Operaci --> Kapsa... a zobrazí se dialog
Kapsování,kde v oblasti Geometrie Definovat vybereme již nadefinovanou geometrii
Kruh kapsa Vybereme před definovaný dokončovací nástroj pod číslem 4
Zbytek karty vyplníme podle vzoru.Nesmíme zapomenout označit hloubku a počátek
kruhového vybrání.Krok nastavíme na 1.Zrušíme přídavky na hodnotu-0.
Ve Zbytkovém materiálu
nastavíme dle tabulky
72
Tímto máme vše nadefinováno a můžeme stisknout tlačítko Uložit & Přepočítat a pak
tlačítko Ukončit.Případně provést kontrolu pomocí Simulace.Opět jako v předchozí
operaci klikneme pravým tlačítkem na strom CAM správce na položku Operace a zvolíme
Přidat Operaci --> Kapsa... a zobrazí se dialog Kapsování,kde v oblasti Geometrie
Definovat vybereme již nadefinovanou geometrii Kruh kapsa malá.
Vybereme předdefinovaný dokončovací nástroj pod číslem 4
Určíme veškeré parametry Horní Z rovinu a Hloubku kapsy Krok dolů a Přídavky na 0.
Vše je vidět na kartě Kapsování.
Tímto máme vše nadefinováno a můžeme stisknout tlačítko
Uložit & Přepočítat a pak tlačítko Ukončit.Případně provést
kontrolu pomocí Simulace.Veškeré úpravy operací můžeme
provést v stromovém okně CAMu po stlačení pravého tlačítka
myši nebo dvojklikem na operaci kterou chceme upravovat.Po
stlačení Úpravy se zobrazí okno operací ve kterých provedeme
úpravy , nesmíme zapomenout v rolovacím menu Uložit &
Přepočítat ..
73
Posledním úkon před vygenerování NC kódu bude simulace kompletní vyrobené
součástky.Simulaci pustíme .v CAM stromovém okně klikneme na Operace a
v roletovém okně zvolíme Simulace.
Potom si vybereme způsob a typ simulace.
74
Generování NC kódu
Po kontrole simulací můžeme generovat NC program.
Ze stromu CAM správce vybereme Operace a klikneme na ně pravým tlačítkem myši a
z menu vybereme Postproces vše – Seznam. Takto vygenerujeme NC program pro
všechny operace. Chceme-li vygenerovat program pro jednotlivou operaci, tak na ni zase
klikneme pravým tlačítkem a z menu vybereme Postprocesing – Tvorba nebo Seznam.
Tvorbou NC programu jsme ukončily kompletně první cvičení.
75
Příklad 2
3D frézování
Co se máte učit
Toto cvičení již vychází z dovedností, které jste se
naučili v předchozích cvičeních.
3D Hrubování.
3D Dokončování “konstantní-Z”.
76
Otevřete díl „forming_mold.SLDPRT“.
Z roletového menu zadejte obrábění nové součásti. SolidCAM – Nový – Frézování.
Zadejte Adesář, Název, Model tak jak jsme se už naučily v předchozím cvičení.
Potom nadefinujte nulový bod jak ukazuje obrázek.
Data nulového bodu nastavíme tak jak ukazuje obrázek:
77
Nastavíme Postprocesor výběrem z rolety například FANUC.
Nadefinujeme Polotovar volbou Kvádr (Auto) oblast Zvětšit kvádr o rozměr nastavíme
na nulové hodnoty a klikneme na model a definici ukončíme tiskem tlačítka .
Pak nadefinujeme Obrobek jak jsme se naučily v předchozím cvičení.
Zatrhneme Aktualizovat Polotovar / Zbytkový materiál a označíme volbu Zbuffer.
Zadání ukončíme stiskem Uložit & Konec.
Pak vytvoříme operaci Hrubování.
Navolíme novou operaci 3D Model...
Nadefinujeme geometrii - vybereme z rolety již nadefinovanou geometrii „target“.
Nadefinujeme Nový nástroj Průměr 12, Rádius rohu 2.5, Délka – Celková 80, Venku
z držáku 60, řezná část 50.
Pak nastavíme Frézovací roviny:
Horní Z rovinu uchopíme na nejvyšší ploše modelu obrobku.
Dolní Z rovinu uchopíme na ploše dna obráběné kapsy na modelu obrobku.
V oblasti Hrubování v dialogovém okně 3D Operace vybereme z rolety Cik-Cak.
Stiskneme tlačítko Nájezd v oblasti Hrubování a nastavíme dialog Sestup podle obrázku:
Nájezd bude probíhat pod úhlem 5 stupňů a mezi Z kroky nebude nástroj vyjíždět do
roviny rychloposuvu.
78
V oblasti Pracovní oblast stiskneme tlačítko Definovat – zobrazí se okno Pracovní
oblast, kde zatrhneme Pracovní oblast a stiskneme tlačítko Definovat a nadefinujeme
řetězcem geometrii jak ukazuje obrázek:
Okno Pracovní oblast ukončíme stiskem OK.
Zbytek dialogového okna
3D Operace vyplníme jak
ukazuje obrázek:
Definici ukončíme stiskem Uložit & Přepočítat a okno ukončíme stiskem Ukončit.
79
Simulace Solid Verify:
Pak vytvoříme operaci Dokončování.
Navolíme novou operaci 3D Model...
Nadefinujeme geometrii - vybereme z rolety již nadefinovanou geometrii „target“.
Nadefinujeme Nový nástroj Průměr 8, Rádius rohu 4, Délka – Celková 80, Venku
z držáku 60, řezná část 50.
Pak nastavíme Frézovací roviny:
Horní Z rovinu uchopíme na nejvyšší ploše modelu obrobku.
Dolní Z rovinu uchopíme na ploše dna obráběné kapsy na modelu obrobku.
V oblasti Pracovní oblast stiskneme
tlačítko Definovat – zobrazí se okno
Pracovní oblast kde zatrhneme
Pracovní oblast a z rolety
vybereme již nadefinovanou „w_a“,
protože je stejná jak pro hrubování
tak pro dokončování. Pak ještě
v tomto dialogovém okně v oblasti
Nástroj v pracovní oblasti
vybereme z rolety Po kontuře a do
políčka Přídavek Ven/Dovnitř
vložíme hodnotu -0.3. Pak toto okno
ukončíme stiskem OK
Pak ještě v dialogovém okně 3D
Operace nastavíme v oblasti
Dokončení z rolety Konstantní Z.
Pak v této oblasti stiskneme tlačítko
Data a zobrazí se dialog Konstantní
Z, který vyplníme jak zobrazuje
obrázek.
80
V tomto Dialogovém okně stiskneme tlačítko Data a vyplníme
následné dialogové okno Parametry Kontury jak zobrazuje
obrázek – černá oblast.
Zbytek dialogového okna 3D Operace vyplníme jak ukazuje
obrázek:
Definici ukončíme stiskem Uložit & Přepočítat a okno ukončíme stiskem Ukončit.
81
Simulace Solid Verify:
Zobrazení vyhotovené operace v Simulace 3D:
82
Skripta vypracována pomocí programů:
Microsoft Office –Word 2002-Sp3
Graficky editor GIMP 2,2
CAD +CAM program SOLIDCAM 2006/ R10
83

Podobné dokumenty

IS3_Programovani

IS3_Programovani I takový přístup se ukázal jako velmi primitivní. Pořád jste museli počítači říkat co má dělat na technické úrovni (co má provádět jeho procesor), jako například přesuň bajty z této oblasti paměti ...

Více

TECHnews 7 - Svět plastů

TECHnews 7 - Svět plastů chemická odolnost, možnost vytvářet složité tvary přímo pomocí forem bez nutnosti dalšího opracování a drahých montáží, větší volnost v designu výrobku, nižší opotřebení, to jsou některé z výhod, k...

Více

Ukázková kapitola

Ukázková kapitola V levém panelu konzoly klepněte pravým tlačítkem myši na uzel Obory názvů (Namespaces) a vyberte položku Nový obor názvů (New Namespace), načež se spustí Průvodce novým oborem názvů (New Namespace ...

Více

Měření ve fyzikálních technologiích

Měření ve fyzikálních technologiích pláště termočlánkového vedení. Keramický materiál uvnitř pláště, který elektricky odděluje obě větve termočlánku s rostoucí teplotou ztrácí izolační schopnost. Na vedení tak vznikají falešné měřící...

Více

VisualMill

VisualMill Začínáme s VisualMillem

Více

Tvorba modelů v CAD - Integrovaná střední škola Cheb

Tvorba modelů v CAD - Integrovaná střední škola Cheb Umožňuje týmovou spolupráci a koordinované zpracovávání celé projektové dokumentace stavby včetně spravování dokumentů. Využívá principů tzv. Informačního modelu budovy (BIM). Umožňuje paralelní pr...

Více

Příručka GE Fanuc Series 21 T- soustružení

Příručka GE Fanuc Series 21 T- soustružení speciální funkce pro ovládání programu WinNC a řízení stroje podle následujícího obrázku. Některé další funkce tlačítek jsou přes tlačítka SHIFT, CTRL nebo ALT (příklad pod obrázkem klávesnice). Fu...

Více