TVM

Komentáře

Transkript

TVM
-1-
VŠB - Technická univerzita Ostrava
Fakulta strojní
Katedra automatizační techniky a řízení 352
Řízení teplovzdušného modelu TVM pomocí PC a mikropočítačové jednotky
CTRL
Návod k laboratorní úloze
Zpracoval: Doc. Dr. RNDr. Lubomír Smutný
Ostrava - únor 2001
-2-
Řízení teplovzdušného modelu TVM pomocí PC a mikropočítačové
jednotky CTRL
1. ZADÁNÍ:
1.
Seznamte se s teplovzdušným modelem (TVM), mikropočítačovou měřicí jednotkou CTRL
a programovou podporou v prostředí MS DOS/ Win (moduly DOS_CTRL.exe
a
WinCTRL.exe ).
2.
Proveďte konfiguraci jednotky CTRL v režimu měření a poté řízení, ověřte funkci všech
vstupních a výstupních signálů. Nastavte model TVM do definovaného stavu, umožňující
proměření další části úlohy.
3.
Zformulujte úlohu řízení teploty žárovky při působení proměnné poruchové veličiny (akční
veličinou může být alternativně buď napětí na žárovce nebo napětí na ventilátoru)
4.
Ověřte vlastnosti regulačního algoritmu dvoupolohové regulace a PID teplovzdušného modelu TVM při řízení zvolené veličiny (teplota, průtok vzduchu nebo obě veličiny současně)
pro různé druhy a velikosti poruchové veličiny a parametry regulátorů.
5.
Zhodnoťte jednotlivé typy řídicích algoritmů na základě časových průběhů řízené veličiny
a porovnejte je z hlediska kvality regulace, stability, odolnosti proti působícím poruchám,
z hlediska vlivu polohy pracovního bodu na statické charakteristice.
2. ZAPOJENÍ ÚLOHY
Model teplovzdušného obvodu je tvořen žárovkou napájenou z řiditelného zdroje napětí
(vytváří tepelný a světelný zdroj), jež je umístěná v krytém tunelu, kterým je profukován vzduch
pomocí ventilátoru (ten je rovněž napájen pomocí řiditelného zdroje napětí). V tunelu je umístěno několik snímačů:
♦ Tři snímače teploty (termistor T3 měřící teplotu baňky žárovky, T2 - teplota vzduchu
v bezprostřední blízkosti baňky žárovky, T1 - teplota vzduchu v zadní části tunelu).
♦ Fotodetektor (fotorezistor FR1 měřící jas žárovky).
♦ Termoanemometr (je tvořen dvěma termistory, první je umístěn v tunelu a měří rychlost
proudění vzduchu - TA, druhý referenční termistor RT není proudem vzduchu ovlivňován)
♦ Objemový vrtulkový průtokoměr (VP - měřicí vrtulka s připojeným snímačem otáček).
Využití jednotlivých vstupních a výstupních kanálů jednotky CTRL pro danou úlohu ukazuje
tab.1.
Tab. 1 - Zapojení vstupních a výstupních kanálů jednotky CTRL
Vstupní kanál
Snímač
Výstupní kanál
Akční člen
Vstup 1
snímač jasu žárovky (fotorezistor)
Výstup 1
ovládací napětí na žárovce
Vstup 2
snímač teploty v blízkosti baňky žárovky T1
Výstup 2
ovládací napětí na hlavním
ventilátoru (řízení otáček)
Vstup 3
snímač teploty baňky žárovky T2
Výstupy 3
ovládací napětí na vedlejším
ventilátoru (řízení otáček)
Vstup 4
snímač teploty na výstupu z tunelu T3
Vstup 6
Termoanemometr TA6
Vstup 7
vrtulkový průtokoměr VP7
-3Obr. 1 - Zapojení modelu teplovzdušného obvodu s počítačem PC a jednotkou CTRL
Fotorezistor
Ochranný tunel
Hlavní
Ventilátor
Napájecí
zdroj
Mikropočítačová
jednotka CTRL
Termoanemometr
Termistory
Žárovka
Vrtulkový
průtokoměr
Elektronická jednotka
Vstupy
y
Počítač
PC
Výstupy
RS 232
3. POSTUP PRÁCE
1) Zapojte použité přístroje dle obr. 1, zapněte počítač PC, jednotku CTRL a elektronickou jednotku teplovzdušného modelu TVM.
2) Spusťte program CTRL.exe nebo WinCRTL.exe pro ovládání jednotky CTRL, který je
v příslušném adresáři na serveru (např. FS1:PR(G) \TPAR\Automat_technika\ DOS_CTRL\
DOS_CTRL.exe ).
3) Cílem regulační úlohy je udržet teplotu baňky žárovky na požadované konstantní hodnotě, jíž
odpovídá napětí na vybraném snímači teploty – např. termistoru T3 připevněném na baňce žárovky (např. w = 2,5 V, což koresponduje s polohou pracovního bodu regulačního obvodu ve
25% rozsahu statické charakteristiky). Akční člen regulačního obvodu je představován řízeným zdrojem žárovky a porucha je realizována proměnným ochlazováním baňky žárovky nastavovanými otáčkami ventilátoru (Výstup2).
4) Vstup3 (termistor T3 na baňce žárovky) nastavte jako aktivní, Výstupl (akční veličina - napětí
na žárovce) nastavte jako regulační a Výstup2 (poruchová veličina - napětí na ventilátoru)
jako zdroj signálu. Vzorkovací periody snímání vstupů a generování výstupů je vhodné nastavit 0,2 s až 1 s (volme spíše menší hodnotu, programem ještě akceptovanou).
-45) Regulační výstup 1 vyzkoušejte pro tyto druhy řízení:
a) dvoupolohová regulace teploty - realizována pro 2 hodnoty hystereze - nulovou a cca 10
až 20 % požadované hodnoty w. Dále je třeba zadat hodnotu akční veličiny (napětí na žárovce) v poloze zapnuto (např. 10 V) a hodnotu v poloze vypnuto (např. 1 V).
b) při PID regulaci je vhodné pracovat s následujícími hodnotami stavitelných konstant: zesílení kR = 50, integrační časová konstanta T I = 100 a derivační časová konstanta
T D = 0 s nebo T D = 0,3 s (spíše nevhodné).
5) Výstup2 jako zdroj poruchové veličiny ověřte pro tři druhy a velikosti signálů (časový úsek,
ve kterém probíhá regulační úloha nastavte alespoň na 100 s):
a) sinusový signál (frekvence f = 0,02 Hz, amplituda A = 3 V, střední hodnota S = 4 V).
b) obdélníkový signál (f = 0,02 Hz, střída 0,3, amplituda A = 3 V, střední hodnota
S = 4 V).
c) šumový signál se střední hodnotou 3 V a rozptylem 1 V.
6.
Časové průběhy regulačních pochodů ukládejte do souborů v adresáři, kde máte právo zápisu, neboť aktuální adresář ve kterém je umístěn obslužný program je pro zápis nepřístupný.
Pro zpracování výsledků do protokolu je vhodné přenést grafické průběhy do prostředí MS
Windows. Je-li program DOS_Ctrl.exe (bez funkčního připojení k jednotce CTRL) spuštěn
pod Windows v rámci Prompt MS-DOS, lze při zobrazení žádaného grafu zkopírovat aktuální obrazovku stiskem klávesy Print Screen (Alt Print Screen) do schránky (Clip Board).
Obsah schránky lze posléze buď uložit pod vhodným názvem (soubor *.CLP), nebo vložit
do dokumentu v MS Wordu (horkou klávesou CTRL+V). Předtím je vhodné v programu
Paint Brush (Kreslení) invertovat černé pozadí na bílé.
7.
Grafické znázornění průběhů regulovaných a dalších zvolených veličin (např. vstupní napětí
z termistorového snímače T3, akční veličinu - napětí do žárovky a průběh generovaného napětí na ventilátoru) doložte do protokolu. Připojte údaje o nastavení regulačního obvodu - w,
hodnoty koeficientů regulátoru, druhu a velikosti poruchy atd. Programový modul
WinCTRL tyto údaje má uloženy v samostatném souboru.
8.
Z průběhu regulované veličiny (napětí na termistorovém snímači T3) odečtěte maximální
odchylky od žádané hodnoty w, odhadněte kvalitu (chybu) regulace a zaneste je do srovnávací tabulky.
9.
Zhodnoťte kriticky získané grafické průběhy a srovnávací tabulku a vyjádřete se k realizaci
a parametrům regulační úlohy.
-5-
PŘÍLOHA 1 - POPIS PROGRAMU DOS_CTRL.EXE
Po spuštění programu a navázání spojení s jednotkou CTRL se v horním řádku obrazovky
zobrazí hlavní menu:
≡ - kalkulačka a informace o programu
Soubor - práce se soubory a disky
Měření - nastavení parametrů měření a spuštění měření
Řízení - nastavení parametrů řízení a spuštění řízení
Graf - grafické zobrazení naměřených hodnot
Nastavení - práce s parametry programu
Komunikace - inicializace sériové linky RS 232 a specifikace komunikačního portu
COM 1, COM 2
Obrazovka - nastavení módu obrazovky a práce s okny
Pro úlohu řízení teploty v modelu teplovzdušného obvodu jsou nejdůležitější položky Soubor,
Měření, Řízení a Graf.
Podnabídka Soubor:
♦ Otevření - Slouží k otevření specifikovaného souboru
♦ Změna adresáře - Slouží k přednastavení aktuálního adresáře. Při aktivaci se objeví název
aktuálního adresáře a strom adresářů, ve kterém se lze pohybovat pomocí kurzorových kláves a klávesy ENTER.
♦ Tisk - Tisk obsahu aktuálního okna na připojené tiskárně.
♦ Tisk do souboru - Obdobné jako tisk, ale do specifikovaného souboru.
♦ Zavření - Zavření aktuálního okna.
♦ Cesta k BGI - Nastavení cesty ke grafickým ovladačům.
♦ Do DOSu - Umožňuje přerušit práci s programem a vrátit se do DOSu, přičemž program
zůstává zaveden v paměti a lze se do něj vrátit příkazem EXIT.
♦ Konec - Ukončení práce s programem. Program lze kdykoli ukončit horkou klávesou
Alt-X.
Podnabídka Měření:
∗ Start - Po aktivaci této volby se otevře dialogové okno, kde uživatel zadá dobu měření (časový interval, po který probíhá definovaná úloha měření) a název souboru pro ukládání dat.
POZOR! Soubor pro ukládání dat se musí nacházet v adresáři s právem zápisu, jinak se po
ukončení měření program zhroutí a data budou ztracena!
∗ Nastavení - Po aktivaci této volby se otevře dialogové okno, kde uživatel nastaví parametry jednotlivých vstupních kanálů - zda je kanál aktivní (stiskem mezerníkové klávesy), majíli se hodnoty ukládat na disk, konstanta kterou se získané hodnoty násobí, aby odpovídaly
skutečně měřené veličině, jednotka této konstanty a vzorkovací perioda (pro každý kanál
může být jiná - minimálně 0,01 s , typicky 0,1 až 0, 3 s) - viz obr. 2.
-6-
Obr. 2 - Dialogové okno nastavení parametrů jednotlivých vstupů
Podnabídka Řízení:
Start - má stejnou funkci jako při měření, ale navíc je zde uvedena informace o nastavení výstupů s možností zvolit u každého aktivního výstupu možnost ukládání jeho dat do společného předem pojmenovaného textového souboru na disk do příslušného adresáře.
Obr. 3 - Dialogové okno pro položku menu Řízení a podpoložku Start
Nastavení - tato volba rozvine další podmenu:
Vstupy
Nastavení parametrů vstupů je stejné jako při měření.
Výstup 1 až 4
Nastavení parametrů každého výstupu - je možno volit z parametrů:
Vypnutý:
Regulace:
Výstup je neaktivní.
Obsahuje možnosti:
- Dvoustavová (dvoupolohová) - zde je třeba nastavit parametry regulátoru - hodnotu „zapnuto“ a „vypnuto“ a pásmo necitlivosti
(hysterezi) a parametry regulační soustavy - číslo vstupu příslušného
k danému regulačnímu obvodu , hodnotu žádané veličiny w , periodu
při generování výstupní veličiny.
- PSD regulace - opět je třeba nastavit parametry regulátoru: zesílení
kR, integrační a derivační časové konstanty T I ,T D a parametry regulační soustavy (obdobně jako při dvoupolohové regulaci.
Zdroj signálu - umožňuje využít jednotku CTRL jako generátor signálu:
- Sinus - generuje harmonický signál Y=(A*sin(2*π*f*t)+Fí)+S
kde: A- amplituda signálu [V],
f- frekvence [Hz],
t - čas [s],
Fí- počáteční fáze [°],
S- střední hodnota [V].
- Obdélník - generuje obdélníkový signál o frekvenci f, amplitudě
A, střední hodnotě
S se střídou T1/T, kde T - peri-
-7oda signálu (T = 1/f ) a T1 - délka kladné
půlvlny
[s].
- Trojúhelník - trojúhelníkový signál o amplitudě A, střední hodnotě S a frekvenci f.
- Šum - generuje náhodný signál s rovnoměrným nebo normálním
rozdělením.
- Pravoúhlý impuls - od času T1 do T2 generuje na výstup konstantní signál o hodnotě K, jinak je na výstupu nula.
- Konstanta - generuje po celou dobu vzorkování konstantní signál
o hodnotě K.
Podnabídka Graf:
Pokud je aktivní okno s naměřenými hodnotami nebo je otevřen soubor s naměřenými daty
(*.CTD), je možno zobrazit časové průběhy hodnot až čtyř vstupních nebo výstupních kanálů.
Volby:
- Zobraz - otevře se dialogové okno, uživatel zadává čísla průběhů (v pořadí, v jakém jsou zobrazena v prohlížecím okně), které chce zobrazit a krátký popis k nim. V grafu se zobrazí maximálně 600 vzorků pro jednu závislost (max 4 závislosti). Zadáním hodnoty„0“ jako čísla závislosti se specifikovaný graf nezobrazí.
- Tisk - má stejnou funkci jako Zobraz, ale graf se zobrazí a zároveň odešle na připojenou tiskárnu.
Obr. 4: Dialogové okno volby průběhů pro grafické zobrazení
-8-
PŘĺLOHA 2 - POPIS MIKROPOČÍTAČOVÉ JEDNOTKY CTRL 51
Základní technické parametry CTRL:
∗
∗
∗
∗
∗
∗
∗
∗
CPU 8751
EPROM/RAM: 4 KB integrální /128 B integrální+256 B externí
počet analogových vstupů/výstupů: 16/4
vstupní rozsah/rozlišitelnost: 0-10V/12bitů
výstupní rozsah/rozlišitelnost/vzájemné ovlivňování: 0-10V/12bitů/<3%
komunikace s PC: standardní sériové rozhraní RS 232
napájecí napětí/odběry: +5V/0,6A, +15V/0,1A
rozměry: 21 x 13 x 4 cm
Obr. 5: Způsob propojení počítače PC s jednotkou CTRL a laboratorním objektem (modelem
teplovzdušného obvodu)
Jednotku CTRL tvoří dvě části - napájecí síťový zdroj (220 V/50 Hz) a vlastní elektronická
jednotka vybavená mikroprocesorem. Zdroj poskytuje napětí ±15 V, +5 V a umožňuje připojit
dva přístroje CTRL. Jednotka CTRL je vybavena signálovým konektorem typu CANON 25,
přístrojovým kabelem a napájecím kabelem. Přístrojový kabel je určen pro přímé propojení se
sériovým výstupem PC podle standartu V24/RS 232 a je zakončen standardním konektorem
(COM 1 nebo COM 2).
Parametry komunikace: max. rychlost 9600 Bd, 8 datových bitů, 1 stop bit, bez parity.
Signálový konektor CANON 25 je propojen následovně: piny 1 - 12 jsou určeny pro vstupní
analogové signály, zbývajícími čtyřmi analogovými vstupy se přímo měří hodnota analogových
výstupů. Analogové výstupy jsou na pinech 15 - 19.
S ohledem na rychlost přenosu a množství vstupních a výstupních kanálů je jednotka vhodná jako laboratorní monitorovací mikropočítačový systém pro měření a řízení středně rychlých a
pomalejších procesů (teplotní aj.).
-9-
Příloha 2
Programový modul WinCTRL
Modul WinCTRL je koncipován jako MDI (Multiple Document Interface – rozhraní pro
práci s více dokumenty) aplikace. Celá aplikace je tvořena jedním základním otcovským formulářem, obsahujícím nabídky, nástrojovou lištu, stavový řádek a pracovní plochu. V rámci pracovní plochy tohoto formuláře je pak možno zobrazit libovolné množství tzv. synovských formulářů
s naměřenými hodnotami či grafy. Výhodou tohoto řešení je možnost současné práce s více dokumenty, obdobně jako je tomu např. u programů Microsoft Word, Excel apod. Obsluha programu je koncipována se zřetelem na maximální jednoduchost a odpovídá standardům MS Windows 95/98. Výběr všech funkcí programu je zabezpečen pomocí soustavy nabídek, jejichž jednotlivé položky je možno volit pomocí myši nebo kombinací kláves Alt + … Možnost volby,
některých vybraných funkcí, je rozšířena rovněž o horké klávesy a tlačítka nástrojové lišty. (na
Obr. P-1 je zobrazeno grafické rozhraní aplikace WinCTRL). Vytvořená aplikace byla doplněna
rovněž o kompletní kontextovou nápovědu.
Obr. P-1: Okno spuštěné aplikace WinCTRL
Nabídka Soubor
Tato nabídka obsahuje položky pro práci se soubory, tisky editačních oken a ukončení práce s
programem.
Podnabídky:
Otevřít (Ctrl+O) - zobrazí standardní dialogový panel Windows pro otevření souboru. Uživatel má možnost výběru souborů v datovém formátu CTD nebo všech souborů. Po potvrzení volby je vytvořeno nové datové editační okno s obsahem vybraného souboru. V
- 10 případě načtení souboru typu CTD, obsahujícího naměřená data, jsou tato před zobrazením v okně předzpracována pro lepší přehlednost. V případě ostatních souborových
typů jsou data zobrazena v původní formě. Pokud je při otevírání souboru ve formátu
CTD nalezen textový soubor shodného jména s příponou CTI, pak jsou údaje zobrazované v editačním okně doplněny o obsah tohoto souboru (příklad editačního okna s načteným datovým souborem je uveden na Obr. P-2). Aplikace není omezena na práci s
jedním dokumentem a umožňuje otevření libovolného počtu oken (limit počtu otevřených oken je dán pouze paměťovými možnostmi systému, na kterém je aplikace spuštěna).
Obr. P-2: Datové editační okno
Zavřít - zavře aktuální editační okno, zobrazující data nebo graf. Volba této podnabídky je
ekvivalentní stisku tlačítka pro zavření okna v jeho titulkovém pruhu. Pokud není obsah okna uložen, je zobrazen dotaz na uložení do souboru. Podnabídka není dostupná
v případě, kdy není otevřeno žádné editační okno.
Uložit jako (Ctrl+S) - zobrazí standardní dialogový panel Windows pro uložení souboru. Uživatel má možnost výběru již existujícího souboru nebo zapsání jména souboru nového. Po potvrzení volby je vytvořen nový datový soubor typu CTD, obsahující naměřená data, zobrazená v aktuálním editačním okně. Pokud bylo zadáno jméno již
existujícího souboru, je před uložením proveden dotaz na jeho přepsání. Podnabídka
není dostupná v případě, když aktuální editační okno neobsahuje nově naměřená data
nebo pokud není otevřeno žádné editační okno.
Export do WinGAp (Ctrl+E) – zobrazí dialogové okno pro nastavení exportu dat (viz Obr. P3), obsažených v aktuálním editačním okně, do textového formátu programů WinGAp a WinGraf. Uživateli jsou nabídnuty exportovatelné průběhy, z nichž může vy-
- 11 brat maximálně sedm průběhů se shodnou vzorkovací periodou. Po provedení volby,
prostřednictvím stisku tlačítka Další, se zobrazí standardní dialogový panel Windows
pro uložení souboru. Další postup při exportu je obdobný jako při ukládání. Výsledný
soubor je uložen v textové formě s příponou TXT. Podnabídka není dostupná v případě, kdy aktuální editační okno neosahuje naměřená data.
Obr. P-3: Nastavení exportu dat
Načíst nastavení - zobrazí standardní dialogový panel Windows pro otevření souboru. Uživatel
má možnost, otevřením binárního souboru s příponou CFG, aktualizovat nastavení měřicí nebo řídicí úlohy pro jednotku CTRL. Načtení nastavení se provádí rovněž při každém startu aplikace. V případě, že při startu není konfigurační soubor nalezen, je nastavena základní konfigurace. Pro zamezení načtení souboru neobsahujícího konfiguraci, je
před jeho otevřením provedena kontrola typu a zobrazena případná chybová zpráva.
Uložit nastavení - zobrazí standardní dialogový panel Windows pro uložení souboru. Uživateli
je umožněno uložení aktuální konfigurace měřicí nebo řídicí úlohy do binárního souboru s příponou CFG. Operace se provádí rovněž při každém ukončení programu. Pokud
při ukončení aplikace není nalezen soubor Ctrl51.cfg, je tento znovu vytvořen, a do něj
je uložena aktuální konfigurace.
Tisk (Ctrl+P) - zobrazí standardní dialogové okno pro konfiguraci tisku. Po volbě konfigurace,
je na zvolenou tiskárnu poslán obsah aktuálního editačního okna, obsahujícího naměřené hodnoty nebo graf. Podnabídka není dostupná, pokud není otevřeno žádné datové nebo grafické editační okno.
Konec - ukončení práce s programem. Při výběru této podnabídky je uloženo nastavení všech
parametrů do konfiguračního souboru Ctrt51.cfg, ze kterého jsou při opětovném spuštění aplikace načteny. Provede se rovněž zavření všech editačních oken. Pokud je obsah
některého z nich neuložen, je zobrazen dotaz na uložení do souboru.
Nabídka Měření
Tato nabídka obsahuje položky pro nastavení parametrů měření a spuštění měřicího režimu.
Podnabídky:
Start (Ctrl+F5) – po aktivaci této podnabídky se zobrazí dialogové okno (podle Obr. P-4) pro
spuštění měření. V levé části okna jsou zobrazeny všechny vstupní i výstupní kanály, doplněny o jednotky měřených veličin. Pro aktivní kanály je dále možno zvolit barvu vykreslovaného průběhu. Neaktivní kanály jsou indikovány popiskem Vypnuto, výstupní kanály vy-
- 12 užívané jako pomocný zdroj signálu jsou indikovány popiskem Pomocný. V dolní části okna je textový box pro nastavení času měření. Při změně této hodnoty se provede rovněž nastavení rozsahu časové osy grafu, zobrazeného v pravé části formuláře. Měřicí úloha se
spustí po stisku tlačítka Start. V textových polích aktivních kanálů jsou zobrazovány okamžité naměřené hodnoty, vynásobené konstantami zadanými při konfiguraci. Do grafu jsou
v reálném čase vykreslovány naměřené hodnoty přepočtené na hodnotu 0 - 100 %
z měřicího rozsahu. Měřicí rozsah je tvořen intervalem <0 ; 10 V * Konstanta>. Ve spodní
části okna je zobrazován aktuální čas měření. Měření lze kdykoliv přerušit stiskem tlačítka
Stop. Pokud jsou nastaveny příliš nízké vzorkovací periody a program nestíhá měřit požadovaný počet vzorků nebo pokud dojde k přerušení spojení s jednotkou CTRL, měření se
přeruší a zobrazí se chybové hlášení. Po ukončení měření je z naměřených hodnot vytvořeno nové editační okno, jehož obsah lze následně uložit.
Nastavení vstupů - tato volba otevře dialogové okno pro nastavení parametrů všech 16 vstupních kanálů jednotky CTRL (viz Obr. P-5). Uživatel má možnost nastavení konstanty, kterou se mají vstupní hodnoty z rozsahu <0 ; 10 V> násobit, aby odpovídaly skutečné měřené
veličině, jednotky této veličiny, vzorkovací periody a dále je-li daný kanál aktivní či ne. Při
zadání nečíselné hodnoty nebo hodnoty menší nebo rovné nule, pro konstantu a vzorkovací
periodu, je uživatel upozorněn na chybu.
Obr. P-4: Okno zobrazující průběh měření
- 13 -
Obr. P-5: Nastavení vstupů
Nabídka Řízení
Tato nabídka obsahuje položky pro nastavení parametrů řízení a spuštění řídicího režimu.
Podnabídky:
Start (F5) - volba této podnabídky má stejnou funkci jako obdobná volba pro měřicí režim.
Nastavení - tato volba rozvine další podmenu, které obsahuje položky:
Vstupní kanály - nastavení parametrů vstupů jednotky CTRL, které je obdobné jako nastavení pro měřicí režim (pro konfiguraci je však nabídnuto pouze 12 vstupních
kanálů).
Výstupní kanály - nastavení parametrů výstupních kanálů 1..4 jednotky CTRL (viz Obr.
P-6). Uživatel má možnost nastavit každý z kanálů do jednoho ze čtyř nabízených režimů: vypnutý, regulační, zdroj signálu a pomocný zdroj signálu.
Vypnutý - tato volba nastaví výstupní kanál jako neaktivní.
Regulační - v tomto režimu pracuje výstupní kanál jako zdroj akčního zásahu do regulované soustavy. Uživatel má možnost volby:
DVOUPOLOHOVÉ REGULACE s nastavením žádané hodnoty W, výstupního napětí
pro polohy „zapnuto“ a „vypnuto“ Z, V, hystereze H, čísla vstupu pro měření skutečné hodnoty a vzorkovací periody T,
PID REGULACE s možností nastavení žádané hodnoty W, zesílení regulátoru Kr, integrační a derivační časové konstanty Ti, Td, čísla vstupu a vzorkovací periody T.
Zdroj signálu - tento režim umožňuje využít jednotku CTRL jako generátor signálu. Uživatel
má možnost volby následujících signálů:
SINUS o amplitudě A, střední hodnotě S, frekvenci f a počátečním časovém posunu tFi,
OBDÉLNÍK o amplitudě A, střední hodnotě S, frekvenci f, počátečním časovém posunu tFi
a střídě T1/T2, kde T2 je perioda signálu (1/f) a T1 je perioda kladné půlvlny,
- 14 TROJÚHELNÍK o amplitudě A, střední hodnotě S, frekvenci f a počátečním časovém posunu tFi,
ŠUM s normálním nebo rovnoměrným rozložením se střední hodnotou S, a střední odchylkou D,
PRAVOÚHLÝ IMPULS v čase od t1 do t2 o velikosti K, pro ostatní hodnoty času je na výstupu 0,
KONSTANTA konstantní signál o hodnotě K.
Pokud je některý z výstupů nastaven jako pomocný zdroj signálu, lze tento přidat
k jinému výstupu. Mezi takto sloučenými signály lze pak provádět operace součtu, rozdílu a součinu. Při zadávání parametrů signálů a regulací je prováděna kontrola rozsahu
zadávaných hodnot. Pokud některá z hodnot neodpovídá předepsaným mezím, zobrazí
se chybové hlášení.
Pomocný zdroj signálu - tento režim umožňuje využít daný výstup, obdobně jako u režimu Zdroj signálu, ke generování signálu. Takto získaný signál však není posílán na
výstup jednotky CTRL, ale slouží pouze pro účely sloučení se signálem jiného výstupního kanálu.
Obr. P-6: Nastavení výstupů
Nabídka Graf
Tato nabídka obsahuje položky pro nastavení parametrů grafu a jeho vykreslení.
Podnabídky:
- 15 Nastavení grafu - zobrazí dialogové okno pro nastavení grafu (viz Obr. P-7), vytvářeného z
dat, zobrazených v aktuálním editačním okně. Uživatel má možnost povolení vykreslování jednotlivých průběhů, nastavení jejich barev a textových popisů. Dále je
možno provést volbu způsobu nastavení rozsahu svislé závislé osy s možnostmi automatického a ručního režimu. Pro ruční režim lze pak provést nastavení dolní a horní meze rozsahu svislé osy. Podnabídka je dostupná pouze v případě, když aktuální
editační okno obsahuje naměřená data.
Obr. P-7: Nastavení grafu
Zobrazit (Ctrl+G) - zobrazí nové editační okno s grafem, vytvořeným na základě dat získaných z aktuálního editačního datového okna, podle aktuálního nastavení grafu. Do
grafu jsou vykresleny všechny povolené průběhy, podle nastavených barev a určeného rozsahu závislé osy. Dále je do grafu umístěn nadpis grafu a popis průběhů. Tyto
objekty lze, pomocí techniky Drag & Drop, dododatečně přemístit na ploše grafu.
Stiskem pravého tlačítka myši nad některým z těchto objektů, se aktivuje dotaz,
umožňující skrytí nadpisu nebo legendy. Pro jedno datové editační okno lze vytvořit
libovolný počet grafů s rozdílným nastavením. Podnabídka Zobrazit je dostupná pouze v případě, kdy aktuální editační okno obsahuje naměřená data. (příklad okna s grafem dokumentuje Obr. P-8)
Obr. P-8: Editační okno s grafem
- 16 Nabídka Komunikace
Tato nabídka obsahuje položky pro nastavení parametrů komunikace, inicializaci jednotky CTRL
a nastavení základní konfigurace.
Podnabídky:
Inicializace CTRL51 (Ctrl+I) - provede nastavení sériové linky a otestuje přítomnost a připravenost jednotky CTRL. Po provedení této operace se zobrazí hlášení o jejím výsledku. Tato inicializace se provádí rovněž při spuštění aplikace a při každém startu
měřicí nebo řídicí úlohy.
Porty - zobrazí dialogové okno pro specifikaci komunikačního portu (COM1, COM2), ke kterému je jednotka CTRL připojena.
Základní konfigurace CTRL - nastaví parametry měření a řízení do základního stavu.
Nabídka Zobrazit
Tato nabídka dovoluje úpravu vzhledu pracovní plochy aplikace.
Podnabídky:
Nástrojovou lištu - provede zobrazení nebo skrytí nástrojové lišty.
Stavový řádek - provede zobrazení nebo skrytí stavového řádku.
Nabídka Okno
Tato nabídka obsahuje položky pro práci s otevřenými editačními okny. Všechny podnabídky
jsou dostupné pouze v případě, kdy jsou otevřena minimálně dvě editační okna. Při otevření jakéhokoliv okna, je v dolní části nabídky zobrazen seznam všech otevřených oken, s označením
aktivního okna pomocí zatržítka. Pomocí tohoto seznamu lze provádět rychlé přepínání mezi
otevřenými okny.
Podnabídky:
Dlaždice vodorovně - uspořádá všechna otevřená editační okna jako vodorovné dlaždice.
Dlaždice svisle - uspořádá všechna otevřená editační okna jako svislé dlaždice.
Kaskáda - uspořádá všechna otevřená editační okna do kaskády.
Nabídka Nápověda
Tato nabídka poskytuje přístup k systému nápovědy.
Podnabídky:
Témata nápovědy pro WinGAp - CTRL - zobrazí témata nápovědy aplikace.
O aplikaci WinGAp - CTRL - zobrazí dialogový panel se základními informacemi o aplikaci
WinGAp - CTRL.
- 17 -
Použitá literatura:
[1]
PECKA, S. 1993. Využití přístrojových modulů pro mikropočítače PC/XT/AT pro styk s
laboratorním procesem. Ostrava: VŠB-TUO, KATŘ-352, 1993, 48 str., 3 přílohy. Vedoucí DP - Smutný, L.
[2]
DUŠEK, F. - KLÁN, P. 1993. Laboratorní jednotka styku s prostředím pro počítače PC.
Automatizace č. 36, roč. 1993, str. 294 - 296.
[3]
FARANA, R. – aj. 1996. Simulační program SIPRO 3.4. - Uživatelská příručka. Ostrava:
KAKI, 1996, 116 str.
[4]
LANDRYOVÁ, L. - PAWELEK, M. - KONEČNÝ, M. 1996. Návrh procesních systémů.
Programové systémy SCADA/MMI. Ostrava: VŠB - TUO, KATŘ, 1996. 96 str.
Kontrolní otázky:
1.
Vysvětlete pojem přechodová charakteristika a frekvenční charakteristika řízeného obvodu a doložte je na příkladu soustavy žárovka - termistor.
2.
Nakreslete blokové schéma regulačního obvodu a vysvětlete jeho veličiny.
3.
Popište algoritmus dvoupolohové regulace a nakreslete průběh regulačního pochodu
4.
Vysvětlete algoritmus PID regulace a nakreslete průběh regulačního pochodu

Podobné dokumenty

Sborník anotací STOČ 2002 - Fakulta strojní - VŠB

Sborník anotací STOČ 2002 - Fakulta strojní - VŠB dynamických podsystémů, jejichž matematický model odpovídá standardnímu typu pro tuto metodu. Metoda agregace umožňuje navrhnout nerobustní řízení, které vyžaduje přesnou znalost matematické modelu...

Více

consorcial approach for control laboratory education on všb

consorcial approach for control laboratory education on všb GA ČR No. 102/03/0625 at the Department of Control Systems and Instrumentation 352 as a co-proposer with Institute of Informatics of Czech Science Academy. Fundamental part of university education ...

Více

Ekonomický report 6. 6.

Ekonomický report 6. 6. Jediný koho vývoj inflace nepřekvapil je ČNB. Inflace dopadla podle její poslední prognózy. Stále se však nachází hluboko pod cílem banky a přilíží se k němu až pravděpodobně v první polovině 2017....

Více

Zpracování a prezentace experimentálních datových souborů

Zpracování a prezentace experimentálních datových souborů zpracování a prezentaci experimentálních datových souborů pomocí vlastního Ribbon prvku, který je součástí doplňku pro aplikaci Microsoft Excel 2007. Doplněk je tvořen v prostředí Visual Studia 200...

Více

ELEKTROPOHONYspol. s r.o. Varispeed F7

ELEKTROPOHONYspol. s r.o. Varispeed F7 Nastavení vstupního napětí drátovou propojkou (u měničů třídy 3 x 400 V s výkonem 75 kW a vyšším) ......................................................................................................

Více

Regulace teploty v teplovzdušném tunelu

Regulace teploty v teplovzdušném tunelu Analogový měřící přistroj M1 měří při vypnutém regulátoru signál z čidla podle zvoleného tlačítka na přepínači P4, při zapnutém regulátoru výstupní signál z regulátoru. Přístroje M2 a M3 měří signá...

Více