Pokyny pro instalaci programu DOCUMENTS+

Komentáře

Transkript

Pokyny pro instalaci programu DOCUMENTS+
JERID, spol. s r. o.
Pokyny k instalaci
Documents
Pokyny pro instalaci programu DOCUMENTS+ (Doklady+) síťová
verze
Pro instalaci potřebujete administrátorská práva a administrátora.
1. Systémové požadavky
File server / databázový server:
• Operační systém Microsoft Windows 2000 Server a vyšší.
• MS SQL 2005/2008 Server, minimálně Express Ed. (free verze).
• HDD 0,5GB volný prostor na disku.
Pracovní stanice:
• Operační systém Microsoft Windows XP a vyšší. Připojení k internetu.
• HW nejméně: Procesor Intel Pentium 4, RAM 1GB.
• Nainstalovaná podpora Microsoft .NET Framework 2.0
•
•
•
•
•
•
Windows XP: Instalační balíčky .NET Framework 2.0 pro 32/64bit systém naleznete na DVD ERIC Desktop
v adresáři \Support nebo je můžete stáhnout z http://servis.jerid.cz/documents/support/ nebo z
http://www.microsoft.com/en-us/download/
Windows Vista a Windows 7: Není potřeba řešit. .NET Framework 2.0 je součástí operačního systému.
Windows 8: Pokud ještě není, tak je potřeba zapnout .NET Framework 2.0 jako funkci systému Windows přes
Ovládací panely – Programy – Zapnout nebo vypnout funkce systému Windows – vybrat: .NET Framework 3.5 (obsahuje .NET 2.0 a 3.0)
Nainstalovaná podpora Microsoft SQL Server Compact Edition verze 3.5.
•
Instalační balíčky Microsoft SQL Server Compact Edition verze 3.5 pro 32/64bit systém naleznete na DVD ERIC
Desktop v adresáři \Support nebo je můžete stáhnout z http://servis.jerid.cz/documents/support/ nebo z
http://www.microsoft.com/en-us/download/
Instalace klientské části aplikace Documents+ na začátku sama upozorní, která z podpor ještě není nainstalována.
Požadavky na Terminal server jsou kombinací výše uvedených požadavků.
2. Instalace aplikační části programu
•
•
•
•
•
•
•
•
Před instalací vytvořte na serveru například adresář „JERID“, do něj budete program Documents+ instalovat.
Nastavte sdílení adresáře pro uživatele v síti. Uživatelům nastavte práva pro file system a sdílení na „úplný
přístup“ nebo „měnit”.
Na pracovní stanici připojte sdílený adresář např. jako disk „ J “.
Vložte do mechaniky CD-ROM Documents+ nebo si stáhněte aktuální setup:
Install_Documents_***_NET.zip ( *** číslo verze ) z http://servis.jerid.cz/documents/server/ (stažený zip archiv rozbalte a oba soubory uložte do společného adresáře).
Z libovolné stanice v síti nebo přímo na serveru spusťte soubor Install_Documents_***_NET.exe.
V prvním dialogovém okně zvolte jazyk a pokračujte dále.
• Nyní můžete být upozorněni na chybějící typ podpory, viz systémové požadavky. V případě nenalezení
podpory MS .NET Framework 2.0 bude instalace ukončena. Musíte nejprve nainstalovat chybějící podporu. Přímo na serveru, který slouží jen jako file server a aplikace se na něm nebude spouštět není potřeba
tuto podporu instalovat. Test lze přeskočit spuštěním instalace s parametrem /force, např.: Install_Documents_***_NET.exe /force
V okně zadání hesla zadejte instalační heslo: „server“.
V okně pro vybrání cílového adresáře nastavte cestu do připraveného adresáře na serveru, upravte nabízenou variantu síťové cesty „J:\Documents+“ podle skutečnosti. Pokud již máte program Documents+ nainstalován a provádíte pouze aktualizaci, musí cesta odpovídat vašemu současnému umístění programu na síťovém disku.
3. Instalace pracovních stanic
3.1. Pomocí setupu:
• Stejně jako v bodu 2 spusťte soubor Install_Documents_***_NET.exe a v instalaci zvolte jen „Vytvořit zástupce“, v okně pro vybrání cílového adresáře nastavte skutečné síťové umístění aplikace.
• Můžete být upozorněni na chybějící typ podpory, viz systémové požadavky, chybějící podporu nainstalujte.
3.2. Ručně:
• Vytvořte zástupce na ploše na soubor „Documents+\Jerid.DocumentFiller.exe“ a pojmenujte ho Documents+
1/4
JERID, spol. s r. o.
Pokyny k instalaci
Documents
• Případně doinstalujte chybějící podpory, viz systémové požadavky.
3.3. Provoz na Terminal serveru:
• Zástupce je společný pro všechny uživatele. Pokud není na pracovní ploše nebo pod menu Start, vytvořte jej
ručně na soubor „Documents+\Jerid.DocumentFiller.exe“ a pojmenujte ho Documents+ nebo Doklady+.
• Případně doinstalujte chybějící podpory, viz systémové požadavky.
4. Nastavení oprávnění pro spuštění aplikace ze síťového disku
Při provozu na Terminal serveru tento bod přeskočte.
•
Pro spuštění aplikace Documents+ ze síťového disku, je potřeba nastavit na každé stanici oprávnění,
umožňující spuštění aplikace využívající Microsoft .NET Framework.
•
V aplikačním adresáři „Documents+\Setup\Security\“ naleznete k tomu určený „CAS Policy Manager“ a vzorový „Security.bat“
•
Adresář „Security“ nakopírujte dočasně na lokální disk. V souboru „Securiry.bat“ upravte zapsanou síťovou
cestu podle skutečnosti a spusťte jej.
5. Aktivace licence Documents+ přes License manager
•
•
•
•
•
•
Licence síťové verze aplikace „Documents+ jsou vázány na konkrétní stanice v síti nebo Terminal server.
Spusťte aplikaci zástupcem Documents+ na ploše postupně na každé stanici.
Pokud nebude nalezena platná licence, zobrazí se „License manager“ a přes menu: File – Send computer
code odešlete email s kódem počítače. V případě selhání zašlete Computer code ručně na [email protected]
Jakmile obdržíte zpět email o aktivacích licencí, vyvolejte na stanicích stejným postupem License manager
a přes menu: File – Load activation codes from internet docílíte načtení licence.
Jakmile se zobrazí údaj o platné licenci, ukončete okno Licence manageru a úvodní okno aplikace.
Pokud ještě nemáte vytvořen databázový server, pokračujte bodem 6, v opačném případě jej přeskočte.
6. Databázový server
•
•
•
Síťová aplikace pracuje jen s SQL databází, její zálohu naleznete na CD v adresáři „Database\Jerid.DocumentFiller_*.bak“.
Pokud nemáte na serveru MS SQL Server 2005 nebo 2008, tak si jej nainstalujte, dostačující je SQL Server
2005 Express Edition (free verze).
Instalaci by měl provádět administrátor znalý SQL serveru, uvedený postup je pouze heslovitý! Případně si
vyžádejte pomoc s instalací na níže uvedených kontaktech.
Instalace MS SQL Server 2005 Express
• Instalaci naleznete na CD „Server\ Sqlexpr_2005wSP3.exe“, nebo si stáhněte aktuální setup z
http://servis.jerid.cz/documents/server
• V okně „Registration Information“ zrušte volbu „Hide advanced configuration options“ a zadejte své údaje.
• Následně ponechte výchozí instalované komponenty a instalační cestu.
• Následně ponechte výchozí „Default instance“, pokud je to první instalace SQL na serveru. V případě vlastního pojmenování v poli „Named instance“ zatrhněte v dalším okně „SQL Browser“, ostatní hodnoty ponechte
výchozí.
• Následně zvolte „Mixed mode“, heslo např.: „sql“
• Následně vyberte Collation dle národního prostředí, ostatní hodnoty ponechte výchozí.
• Všechny ostatní hodnoty v instalaci ponechte výchozí. Případnou kolizi s MSXML přeskočte.
•
V nástroji „SQL Server Configuration Manager“ ve větvi: SQL Server 2005 Network Configuration – Protocols for SQLEXPRESS… nastavte TCP/IP protokol na Enabled.
•
Proveďte také kontrolu spuštění služeb „SQL SERVER“ a „SQL Server Browser“. Pokud některá z nich
není „Running“, přepněte „Start Mode“ na „Automatic“ a spusťte ji.
•
Máte-li zapnutou Bránu firewall systému Windows, vytvořte výjimky na:
•
C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe
•
C:\Program Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe
Instalace MS SQL Server Management Studio Express.
2/4
JERID, spol. s r. o.
•
•
Pokyny k instalaci
Documents
Instalaci naleznete na CD „Server\ SQLServer2005_SSMSEE.msi“, nebo si stáhněte aktuální setup z
http://servis.jerid.cz/documents/server
Všechny hodnoty v instalaci ponechte výchozí.
Vytvoření databáze
• Spusťte MS SQL Server Management Studio Express.
• Obnovte databázi „Jerid.DocumentFiller“ z dodaného backupu Jerid.DocumentFiller_*.bak (Stromové menu
Object Explorer: Databases: Restore Database..., Jerid.DocumentFiller, From Device..., zatrhněte Restore,
Menu Options: opravte dle skutečnosti Restore As )
• Vytvořte nový SQL login „doc_user“. (Stromové menu Object Explorer: Security: vyvolejte menu: Logins: New
Login, Login name: „doc_user“, SQL Server authentication: Password: „jerid“, vypnout „Enforce password policy“, Default Database: „Jerid.DocumentFiller“)
• Propojte SQL login „doc_user“ s databázovým účtem na databázi Jerid.DocumentFiller .
(Použijte tlačítko: New Query. Změňte v menu výchozí databázi na: Jerid.DocumentFiller. Do pole SQLQuery
vložte proceduru: sp_change_users_login 'update_one','doc_user','doc_user' Potvrďte tlačítkem: Execute.)
7. Základní konfigurace a nastavení
•
•
•
Spusťte aplikaci zástupcem Documents+ na ploše.
Pokud nedojde při spuštění aplikace k zobrazení okna „Možnosti“, vyberte volbu přes menu Nástroje - Nastavení a nastavte údaje dle skutečnosti:
•
Na záložce Data vyberte: „Připojit se k SQL Serveru“
•
Zadejte jméno vašeho SQL serveru, např.: Server\SQL2005.
•
Autentizaci: SQL Server
•
Uživatelské jméno: doc_user
•
Heslo: jerid
•
Databáze: Jerid.DocumentFiller
Aby se tyto hodnoty nemusely zadávat pokaždé při spuštění nového uživatele, lze tyto hodnoty vyplnit v konfiguračním souboru aplikace „...\Documents+\Jerid.DocumentFiller.exe.config“.
8. Uživatelské nastavení
•
•
Pro každý typ nákladního listu upravte „Nastavení tisku“ (menu Soubor – Nastavení tisku).
•
Pro jednotlivé strany dokumentu přiřaďte tiskárnu tlačítkem „Nastavit jako vybranou“ (označí ji zelená
šipka).
•
Zvolte typ tisku s formulářem nebo do formuláře a odsazení pro tisk do formuláře.
•
Nastavte počty kopií výtisků pro jednotlivé strany dokumentu, u nepotřebných nastavte 0 kopií.
•
Před prvním tiskem ověřte nastavení přes „Náhled“ (viz horní menu).
Jestliže tisknete do formuláře více kopií nákladního listu za sebou, je potřeba ve Windows u dané jehličkové
tiskárny nastavit skutečný formát skládaného papíru (předvolby tisku – upřesnit – formát papíru). Většinou
má označení: Skládaný nebo Fanfold a rozměr 210 × 305 mm nebo 8,5 × 12´´.
Tipy
•
V nákladních listech můžete využít rychlé vyplnění textového pole.
•
Z číselníku – klávesa F3 nebo pravé tlačítko myši a menu „Vyhledat v číselníku…“. Číselník je přístupný
jen u modře vybarvených polí.
•
Pomocí historie položky – klávesa F4 nebo pravé tlačítko myši a menu „Vyhledat v historii…“. Zobrazí
se k výběru uložené položky z databáze. Historie je dostupná ve většině polí.
•
Nápovědu programu naleznete v menu Nápověda – Témata nápovědy nebo pomocí klávesy F1.
Aktualizace aplikace - možnosti provedení:
•
•
Automaticky. Pokud nastavíte v menu Nástroje – Nastavení – záložka Aktualizace – volba „Vyhledávat novou verzi při spuštění programu“ (tento typ aktualizace je defaultně zapnut).
•
Po aktualizaci se aplikace při prvním spuštění pokusí stáhnout licenci pro novou verzi. Okno Licence
manageru, které zobrazí stažené licence, ukončete a spusťte znovu aplikaci zástupcem na ploše.
Ručně z menu Nápověda – Vyhledat aktualizace.
3/4
JERID, spol. s r. o.
•
Pokyny k instalaci
Documents
Reinstalací nově staženým souborem Install_Documents_***NET.exe z http://servis.jerid.cz/documents/
s vyšší verzí než naleznete v menu Nápověda – O programu.
Automatická aktualizace s využitím plánovače úloh systému Windows.
•
•
•
Na příslušném serveru nainstalujte Microsoft .NET Framework 2.0 a Microsoft SQL Server Compact Edition
verze 3.5., podrobnosti viz bod 1.
Nastavení plánovače úloh systému Windows:
• V plánovači úloh systému Windows vytvořte novou úlohu, např. Documents
• Aktivační událost nastavte na denně, nejlépe na 1 hodinu v noci.
• Akci nastavte na „Spustit program“.
• Vyberte program „Jerid.DocumentFiller.exe“ ve složce JERID\Documents+\. Např.: „C:\Program\Jerid\
Documents+\Jerid.DocumentFiller.exe“
• Vyplňte položku „Přidat argumenty“ (parametr slouží jako vaše přístupové jméno, získáte jej na vyžádání). Zapište včetně uvozovek. Např.: "#Ux_123"
• Vyplňte položku „Spustit v“. Zadejte cestu, ve které leží program Jerid.DocumentFiller.exe. Cestu vložte
bez uvozovek. V této položce nesmí být uvozovky. Např. C:\Program\Jerid\Documents+
Spuštění programu a případné stažení aktualizace lze následně ověřit v *.txt souboru v aplikační složce
„Jerid\Documents+\Update\“.
V případě potřeby kontaktujte firmu JERID, spol. s r. o. na telefonních číslech tel: +420 588 208 434 nebo
+420 724 080 302. Další informace a kontakty naleznete na http://www.jerid.cz
4/4

Podobné dokumenty

instalační příručka - IR-IS

instalační příručka - IR-IS Start, pokud momentálně neběží (Service status: Running). Start Mode dané služby lze nastavit na druhé kartě (Service) takto: u položky Start Mode klikněte do pravého sloupce a z nabídky vyberte Au...

Více

Instalace SQL 2005 Express

Instalace SQL 2005 Express Na druhé záložce (Připojení) zadáme do 1. políčka název serveru (název PC \ název instance SQL)   do 2. políčka jméno a heslo (ads a ads), ve 3. políčku vybereme databázi (ads_firma).  Můžeme prové...

Více

Instalace MS SQL server 2005

Instalace MS SQL server 2005 V případě potřeby změňte pomocí tlačítka Browse umístění instalace SQL serveru, ale pokud to není nutné, doporučujeme ponechat ve výchozím stavu „c:\Program Files\Microsoft SQL Server\“. Tlačítkem...

Více

SAS

SAS Přidáním dalších SW modulů může být SAS customizován dle Vašich požadavků

Více

Elementární zpracování dat v softwarovém prostředí R 1 Úvod

Elementární zpracování dat v softwarovém prostředí R 1 Úvod character, logical, integer, raw nebo list, NULL, closure (pro funkce), special a builtin. Některé z nich jsou podrobněji popsány v následujícím tetu. Statistika je z velké části práce s čísly, pro...

Více

Instalace-SQL Serveru 2005

Instalace-SQL Serveru 2005 na službu (např. SQL Server) a kliknete na spustit. Obdobně postupujte i služby SQL Server Browseru .

Více

Instalace MS SQL Server 2005 a nastavení programu DUEL pro

Instalace MS SQL Server 2005 a nastavení programu DUEL pro V případě potřeby změňte pomocí tlačítka Browse umístění instalace SQL serveru, ale pokud to není nutné, doporučujeme ponechat ve výchozím stavu „c:\Program Files\Microsoft SQL Server\“. Tlačítkem...

Více