Výukové materiály - Vysoké učení technické v Brně

Komentáře

Transkript

Výukové materiály - Vysoké učení technické v Brně
Vysoké učení technické v Brně
Fakulta elektrotechniky a komunikačních technologií
Institut experimentálních technologií
Kolejní 2906/4
612 00 Brno
http://www.ietbrno.eu
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
1
Vysoké učení technické v Brně
Fakulta elektrotechniky a komunikačních technologií
Efektivní využívání ICT ve výuce
Adobe Photoshop
Radim Kadlec
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
2
Úvod [1]
• Zavedený profesionální grafický nástroj,
který užívají miliony lidí na celém světě.
• K úpravám fotografií, přípravě tiskových
materiálů či tvorbu webových stránek.
• Photoshop poskytuje maximální komfort a
možnosti, na které freewarové nebo
sharewarové programy (jako jsou GIMP
nebo PaintShop Pro) nemají šanci
dosáhnout.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
3
Úvod – označení, řezání [1]
Nástroj výběr (obdélníkový, eliptický,
jednoho řádku, jednoho sloupce)
Nástroj přesun
Nástroj magnetické laso (laso,
mnohoúhelníkové laso)
Nástroj kouzelná hůlka
Nástroj oříznutí
Nástroj rozřezání (výběr výřezu)
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Podržíte-li nad ikonkou stisknuté pravé tlačítko, rozbalí se nabídka s dalšími
nástroji (ty jsou uvedeny v závorce).
4
Úvod – úpravy obrázků [1]
Nástroj retušovací štětec (záplata)
Nástroj štětec (tužka)
Nástroj klonovací razítko (razítko se
vzorkem)
Nástroj štětec historie (umělecký štětec
historie)
Nástroj guma (mazání pozadí, kouzelná
guma)
Nástroj přechod (plechovka barvy)
Nástroj rozostření (zostření, rozmazání)
Nástroj zesvětlení (ztmavení, houba)
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
5
Úvod – tvary, text [1]
Nástroj pro výběr cesty (přímý výběr)
Nástroj text (svislý text, vodorovná textová
maska, svislá textová maska)
Nástroj pero (cesta od ruky, přidat kotevní
bod, odstranit kotevní bod, změnit bod)
Nástroj obdélník (zaoblený obdélník,
elipsa, mnohoúhelník, čára, jiný tvar)
Nástroj poznámky (zvuková anotace)
Nástroj kapátko (vzorkování barev,
měřítko)
Nástroj ručička
Nástroj lupa
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
6
Úvod – ostatní [1]
Pod ikonkami nástrojů se nachází aktuální
vybraná barva - jedná se o dva barevné
čtverečky pod sebou. Dva jsou proto, že
barva na vrchu značí barvu popředí,
zatímco barva vespod je barva pozadí.
Navigátor nás informuje o
aktuálním zobrazovacím poměru
(zmenšení nebo zvětšení)
otevřeného obrázku a zobrazuje
také jeho zmenšeninu.
Záložka Informace standardně říká
vše o pixelu, na kterém se
aktuálně nachází kurzor myši.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Lze je jednoduše přehazovat kliknutím na šipečku v horním rohu. V dolním rohu
jsou pak černý a bílý čtvereček - kliknutím na tuto ikonku barvy "vynulujete" na
černou v popředí a bílou v pozadí, což je základní nastavení. Výběr dvou barev
slouží především při práci s nástrojem Gradient a Guma.
Hodnoty za písmeny RGB říkají kolik je v onom bodě zastoupeno červené, zelené
a modré barvy. Pokud se všechny hodnoty nacházejí na nule, je tento bod černý,
pokud na hodnotě 255 je tento bod bílý. Jednotlivé barvy jsou pak vlastně
kombinace tří čísel od 0 do 255, což celkem dává 256 různých hodnot pro jednu
barvu 256*256*256 dostupných barev celkem (asi 16,7 milionu).
7
Úvod – ostatní [1]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
V záložce Barvy můžete provádět veškerá
volby barev popředí a pozadí. Ručně
můžete nastavovat hodnoty každé ze
tří složek - červené, zelené a i modré.
Vzorník - tabulka předem nastavených
barev, které můžete samozřejmě
upravovat.
Styly - seznam přednastavených stavů.
Historie představuje jakési interaktivní
funkci Zpět. Volby historie kam se
dostanete přes černou šipku v
pravém horním rohu paletky).
Akce - jedná se vlastně o makra čili
nahrané programové.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Barvy : Hodnoty samozřejmě mohou být pouze od 0 do 255. Důležité je vědět,
že když chcete zvolit barvu popředí, musíte nejprve kliknout na svrchní čtverec
(označí se orámováním), zatímco pro volbu pozadí musíte mít označený ten
spodní. Dvojklikem na čtverce se dostanete do speciálního okna pro volbu barvy,
kdesi "tu svou" (barvu) díky mnoha různým nastavením jako bezpochyby najde i
ten největší grafický labužník. Jednodušší, ovšem méně přesný způsob jak vybrat
požadovanou barvu je kliknout v základní paletce na některé místo ve spodní
"barevné stupnici".
Historie: Zaznamenává se tam popořadě každá akce provedená s obrázkem či v
obrázku. Vy tak máte dokonalý přehled o procesu tvorby obrázku a můžete se
kdykoliv vracet zpět či zpětně vynechávat některé kroky (proto je však nutné
zaškrtnout volbu "povolit nelineární historii" v nabídce.
Akce naleznete standardně složku Výchozí akce, která vám po rozbalení zobrazí
dvanáct přednastavených akcí. Jedná se vlastně o makra čili programové
postupy nahrané ve Photoshopu. Hodí se zejména při často opakovaných
rutinních úkonech, dokáží velmi urychlit práci. Uživatelé samozřejmě mohou
vytvářet své vlastní akce a pak je dále upravovat, zařazovat do vlastních složek
atd. Akce se ukázaly být jednou z nejsilnějších stránek Photoshopu a najdou
časté uplatnění při každodenní práci. Více si o nich povíme.
8
Úvod – ostatní [1]
Přednastavené nástroje - dává uživateli
přístup ke zvláštním nastavením
nástrojů.
Vrstvy - seznam všech vrstev obrázku jedná se vlastně o jednotlivé obrázky
poskládané nad sebou. V dolní části
jsou ikonky:
1.
2.
3.
4.
5.
6.
přiřadí vrstvě nějaký styl,
přiřazuje vrstvě masku,
vytváří tzv. Sadu,
přiřadí vrstvě nějaký efekt,
tvoří se vrstva nová
ikonka koše označenou vrstvu maže.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Přednastavené nástroje - dává uživateli přístup ke zvláštním nastavením
nástrojů. U každého nástroje existuje totiž nepřeberné množství různých
nastavení a ta která používáte často je dobré mít uložená, abyste se nemuseli
pokaždé, když budete chtít nástroj stejným způsobem využít, znovu pouštět do
jeho nastavování.
Vrstvy - Lze jimi pohybovat, aplikovat na ně efekty a provádět s nimi další
úpravy. V dolní části záložky Vrstvy je šest ikonek. Pomocí první přiřadíme vrstvě
nějaký styl, druhá přiřazuje vrstvě masku, třetí vytváří tzv. Sadu (tam lze ukládat
příbuzné vrstvy, například všechny textové), čtvrtá ikonka přiřadí vrstvě nějaký
efekt, s pomocí páté ikonky se tvoří vrstva nová a poslední ikonka koše
označenou vrstvu maže.
9
Úvod – ostatní [1]
Kanály - objevíme opět podobný seznam
jako u vrstev. Tentokrát se ovšem
jedná o barevné kanály. Jejich využití
je určeno skutečně spíše pro
profesionály takže se o nich zatím
nebudeme zmiňovat
Cesty - slouží k uspořádání a práci s
cestami. Pro začátek nám stačí vědět,
že je lze využít taktéž jako selekce.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Přednastavené nástroje - dává uživateli přístup ke zvláštním nastavením
nástrojů. U každého nástroje existuje totiž nepřeberné množství různých
nastavení a ta která používáte často je dobré mít uložená, abyste se nemuseli
pokaždé, když budete chtít nástroj stejným způsobem využít, znovu pouštět do
jeho nastavování.
Vrstvy - Lze jimi pohybovat, aplikovat na ně efekty a provádět s nimi další
úpravy. V dolní části záložky Vrstvy je šest ikonek. Pomocí první přiřadíme vrstvě
nějaký styl, druhá přiřazuje vrstvě masku, třetí vytváří tzv. Sadu (tam lze ukládat
příbuzné vrstvy, například všechny textové), čtvrtá ikonka přiřadí vrstvě nějaký
efekt, s pomocí páté ikonky se tvoří vrstva nová a poslední ikonka koše
označenou vrstvu maže.
Cesty - slouží k uspořádání a práci s cestami. Pro začátek nám stačí vědět, že je
lze využít taktéž jako selekce. Dole na záložce máme opět šestici ikonek pomocí
kterých s cestami můžeme pracovat. První ikonka vyplní cestu barvou popředí,
druhá ji obtáhne 1px tenkých štětcem, třetí ji vyznačí jako výběr a čtvrtá naopak
z výběru vytvoří cestu.
10
Úvod – ostatní [1]
•
•
•
Stavový řádek - zobrazuje informace o aktuálně
otevřeném dokumentu.
Kliknete-li na šipku, můžete si zvolit co se má
zobrazovat v kolonce před ní.
Poslední část stavového řádku obsahuje krátkou
nápovědu k aktuálně zvolenému nástroji.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Stavový řádek. Úplně vlevo je procentuelní označení zvětšení - maximum je
1600% (maximální zvětšení), minimum 0,2%. Hodnotu lze libovolně měnit s
přesností na dvě desetinná místa. Hned za procenty vidíte ikonku dokumentu
"připojeného" k síti - ta slouží k práci s dokumentem v pracovních skupinách.
Následuje dlouhá kolonka a za ní černá šipka. Kliknete-li na šipku, můžete si
zvolit co se má zobrazovat v kolonce před ní (informace o velikosti, objemu a
typu dokumentu a další). Poslední část stavového řádku obsahuje krátkou
nápovědu k aktuálně zvolenému nástroji.
11
Kreslení – štětec, tužka [1]
• V nabídce přednastavených štětců jsou umístěny
štětce, které ukazují, co vše je možné se štětci
provádět.
• V políčku Stopa volíme velikost štětce - od 1 do
2500 obrazových bodů. Dále je pak možné volit
různé tvary a typy stop.
• Další volby nástroje štětec jsou Krytí (intenzita
barvy) a Hustota (rychlost použití).
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Kliknutím na tuto ikonku se dostanete do okna
určeného pro vytváření vlastních stop
Tužka je v podstatě totožný s nástrojem štětec,
liší se pouze v tom ohledu, že z něj nelze
"vyrobit" rozprašovač, …
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Stopa - Pokud vám nestačí ty tvary stop, které vidíte ve spodním okénku,
klikněte na ikonu malé černé šipky nahoře vpravo - objeví se nabídka, ve které
můžete vybírat z kaligrafických, přírodních, suchých a mnohých dalších štětců.
Další volby nástroje štětec jsou Krytí a Hustota. V podstatě se jedná o podobnou
volbu, tahy štětce však při různých nastaveních vypadají jinak - zatímco krytí
určuje intenzitu barvy, hustota udává rychlost jejího použití.
12
Kreslení - obdélník [1]
• Photoshop je bitmapový editor, ale lze v něm
částečně tvořit i za pomoci vektorů (přímo
vektorově orientovaný - Adobe Illustrator).
Ikonky značí, zda se nástrojem vytvoří vrstva s
tvarem, cesta či pouhá "výplň obrazovými body
„čili prostě bitmapový obrázek.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Ikonky s perem dovolují vytvořit tvar zcela dle
vlastní libovůle - poprvé za pomoci běžné
cesty, podruhé díky kreslení cesty od ruky.
Další ikonky pak nabízejí tvorbu obdélník,
zaoblený obdélník, elipsa, mnohoúhelník, čára
a jiný tvar.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
13
Kreslení - obdélník [1]
Poslední ikona - libovolný tvar - dává
uživateli přístup k několika předem
definovaným tvarům. Přístup k
dalším získáte tak, že rozvinete
paletku vedle nápisu Tvar a
stisknete černou šipku vpravo
nahoře.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
14
Kreslení - guma [1]
Guma je prostě guma a vyjma
toho, že u ní lze volit stejné typy
stop jako u štětce, není v ničem
výjimečná.
Nástroj mazání pozadí čili "guma
pozadí" dělá přesně to, co má v
názvu - gumuje pozadí.
("Omezení„: sousedící,
nesousedící nebo "hledat
obrysy„).
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Nástroj kouzelná guma je podobný
nástroji kouzelná hůlka, stejné
jsou i volby nástroje. Liší se v
tom, že označenou část ihned
vymaže.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Nástroj mazání pozadí - Každá volba se hodí pro jiný typ obrázku/fotografie a
nejlepší je pro potřebný výsledek obvykle vyzkoušet všechny možnosti - časem
se naučíte kde kterou volbu využívat. Čím lepší chcete výsledek, tím přesnější
musejí být tahy gumy, velikost stopy a nastavení tolerance. Zde vidíte příklad.
Občas je výhodné kombinovat oba dva (nebo všechny tři) druhy gumy
dohromady.
15
Cesty [1]
• Cesta je vektor.
• Cesty jsou dlouhodobé výběry, tedy výběry, jež
můžeme uložit a později znovu použít.
• Cesty přímo souvisejí s označováním (selekcemi)
a maskami.
• Zjednodušeně řečeno jsou masky docela podobné
cestám, mají však své odlišnosti, výhody i
nevýhody.
• Cesty můžeme v zásadě vytvářet dvěma různými
způsoby:
– nástrojem Pero
– nástrojem Výběr .
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Zní to možná trochu podivně, vždyť v úvodu našeho seriálu jsme si řekli, že
Photoshop je bitmapový (rastrový) editor, což je pravý opak vektorového. Jenže
právě v kombinaci obou těchto přístupů tkví síla tohoto programu. Navíc je pak
možné přenášet soubory mezi dalšími programy jako je Adobe Illustrator nebo
PageMaker.
16
Cesta - Pero [1]
• Cesta je prostá čára. Tvoříme ji přidáváním tzv.
kotevních bodů, v případě nástroje cesta od ruky
prostým kreslením od ruky.
• Rozvinete-li nabídku pod nástrojem pero, objeví se
čtyři další nástroje: cesta od ruky, přidat kotevní
bod, odstranit kotevní bod a změnit bod.
• Je to stejný panel, který užívají nástroje pro tvorbu
tvarů. Dělí je vlastně jen dvě ikonky v této paletce,
které přepínají nástroj pero mezi vytvářením cesty
nebo rovnou tvaru.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Cesta není laicky řečeno vlastně nic jiného než prostá čára. Tvoříme ji
přidáváním tzv. kotevních bodů, v případě nástroje cesta od ruky prostým
kreslením od ruky. Kotevní body lze potom přidat nástrojem přidat kotevní bod.
Kotevní body jsou důležité proto, že dovolují cestu různě deformovat - lze z nich
vytáhnout dva tzv. záchytné body, pomocí kterých křivku různě zaoblujeme a
jinak deformujeme. Kotevní i záchytné body lze samozřejmě různě přesouvat.
Zkuste si to - klikněte na nástroj pero a pak znovu klikněte kamkoliv do nového
dokumentu. Objeví se malý šedý čtvereček - jeden kotevní bod. Klikněte podruhé
na jiné místo – ze čtverečku je čára. Klikněte potřetí na jiné místo a vznikne
trojúhelník vybarvený aktuálně zvolenou barvou popředí. Všimněte si, že v
záložce Vrstvy automaticky vznikla nová vrstva (zřejmě nazvaná Tvar 1).
Zaměříte-li svůj pohled na paletu volby nástrojů, zjistíte, že je to tentýž panel,
který užívají nástroje pro tvorbu tvarů. Dělí je vlastně jen dvě ikonky v této
paletce, které přepínají nástroj pero mezi vytvářením cesty nebo rovnou tvaru.
Zvolte nástroj Přidat kotevní bod a klikněte nějak na vytvořenou cestu (objeví se
kurzor pera s malým + vpravo dole). Vznikne nový kotevní bod a kolem něj na
obou stranách dva malé čtverečky. Namiřte kurzorem přímo na kotevní bod,
stiskněte levé tlačítko a táhněte. Vidíte, že kotevní bod se pohybuje a s tím se
mění i tvar nově vytvořené vrstvy. Nyní najeďte na jeden ze záchytných bodů a
pohněte s ním - tvar se opět začne deformovat. Tentokrát ovšem bez toho, aby
se měnila poloha kotevního bodu.
Vyzkoušejte použití nástroje pero v kombinaci s klávesami ALT (přidá záchytné
body), CTRL (posouvání kotevních bodů) a SHIFT (umístí bod ve směru 45° od
posledního bodu) - v podstatě se jedná o rychlý přístup k dalším nástrojům
odvozeným od nástroje pero.
17
Cesta - Pero [1]
• Ačkoliv cesty na obrázku vidíme jako tenké čárky a
kotevní body jako malé čtverečky, nemají s
vlastním obrázkem nic společného a proto je jim
také vyhrazena zvláštní záložka nadepsaná
"Cesty".
Vytáhne cestu štětcem (předtím však musíte nástroj štětec
zvolit),
vyplní cestu barvou popředí,
vytvoří novou prázdnou cestu (můžeme ji dotvářet pomocí
nástroje pero anebo výběr),
odstraní aktuálně označenou cestu,
vytvoří pracovní cestu z výběru (nutno použít nástroj výběr),
načte cestu jako výběr (opak předchozího),
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
18
Cesta - Pero [1]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
• Začnete-li vytvářet pomocí nástroje pero cestu
tehdy, když je vybraná záložka Cesty, vytvoří se
pracovní cesta (zmizí se zavřením dokumentu).
• Novou cestu z vektorové masky tvaru nebo z
pracovní cesty vytvoříte jednoduše kliknutím na
černou šipku nahoře vpravo v paletce Cesty a
volbou "Uložit cestu".
• K označování cest nebo jejich
částí využijeme nástroje:
pro výběr cesty (celá cesta),
pro přímý výběr (jeden nebo
více kotevních bodů, pro více
kotevních bodů najednou držíme SHIFT).
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
19
Cesta – Přímá cesta [1]
• Vyberete kterýkoliv z nástrojů pro výběr, provedete
selekci některé části obrázku, přepnete se do
paletky Cesty a mezi dolními ikonkami vyberete tu
pro vytvoření pracovní cesty z výběru.
• Využití cest je vhodné zejména u složitých
dlouhodobějších projektů na kterých budete
pracovat třeba i několik dní.
• Obkreslení rozměru, …
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
20
Retuš a úpravy [1]
• Využívají zejména k retušování a upravování
fotografií.
Nástroj rozostření - v podstatě se jedná o lokální
podobu filtru Gaussovské rozostření (volíme
velikost stopy, režim a sílu účinku)
Nástroj zostření - opět lokální verze, tentokrát
filtru. S trochou zkušeností lze obrázky
rozostřené předchozím nástrojem znovu
doostřit pomocí tohoto, ale výsledek nemusí být
vždy úplně perfektní.
Nástroj rozmazání – (neplést s rozostřením) efekt
je trochu podobný jako když hrábnete prstem
do temperami právě namalovaného obrazu.
• Všechny najednou pak lze užít k retušování
fotografií, tady nám do květu omylem vlezl jakýsi
kus hmyzu.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
21
Retuš a úpravy [1]
Nástroj zesvětlení - zde si vyberete rozsah
(světla, střední tóny, stíny), to podle té části
fotografie, na kterou chcete působit a míru
expozice.
Nástroj ztmavení
Nástroj houba - Ovlivňuje sytost barev
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
22
Retuš a úpravy – Vybarvování a přechody
[1]
Plechovka barvy slouží k rychlé výplni obrázku
nebo jeho části danou barvu nebo vzorkem.
(v kombinaci s výběr a kouzelná hůlka).
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
23
Vybarvování a přechody – příklad 1 [1]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
• Vytvoříme nový obrázek a velikost zadáme 300 x
300 obrazových bodů.
• Nástrojem plechovka barvy vybarvíme vrstvu Pozadí
světle modrou barvou. Vytvoříme novou vrstvu.
Zvolíme nástroj obdélníkový výběr a vybereme
přibližně třetinu obrázku. Zvolíme nástroj eliptický
výběr, stiskneme SHIFT a na vrchní straně výběr
začneme dělat malé ploché elipsy - vlnky. Jakmile
jsme u konce, plechovkou barvy vybarvíme vrstvu
tmavě modrou barvou.
• V paletce Vrstvy klikneme na tuto vrstvu pravým
tlačítkem a vybereme volbu "duplikovat vrstvu".
Stiskneme CTRL a levým tlačítkem klikneme na
záložku nové vrstvu v paletce Vrstvy. Objeví se
selekce. Nástrojem plechovka ji vybarvíme mírně
tmavší modrou barvou než první vrstvu. Kurzorem
se vrátíme do obrázku, vybereme nástroj přesun a
vrstvu mírně posuneme dolů.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
24
Vybarvování a přechody – příklad 1 [1]
• Znovu duplikujeme první vrstvu s vlnkami. Klikneme
na ni levým tlačítkem, držíme ho a táhneme ji vzhůru
- nad tmavší kopii. Kurzorem se vrátíme do obrázku,
vybereme nástroj přesun a vrstvu mírně posuneme
dolů. Stejný proces aplikujeme potom na tmavší
vrstvu, dokud se nám nezdá moře dostatečně
"vlnité".
• Nástrojem zesvětlení (průměr 100 bodů, rozsah
světla, expozice 75%) přejedeme svrchní část
poslední duplikované vrstvy vlnek. Nástrojem
ztmavení (stejné volby) přejedeme dolní část. Moře
tak získá dojem jisté plasticity.
• Klikneme na vrstvu Pozadí, zvolíme nástroje
zesvětlení a "obzor" nástrojem zesvětlení také
trochu zesvětlíme. Volby nástroje - průměr 100
bodů, rozsah střední tóny, expozice 75%.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
25
Vybarvování a přechody – příklad 1 [1]
• Racky vytvoříme jednoduše nástrojem eliptický
výběr. V nové vrstvě vytvoříme elipsu, poté v panelu
voleb nástroje zvolíme "odečíst od výběr" a
vykousneme jí tak, aby vzniklo jedno křídlo.
Plechovkou bíle barvy ho vybarvíme. Podobným
způsobem vytvoříme druhé křídlo (ať již ve stejné či
v nové vrstvě).
• Mráčky vytvoříme podobným způsobem, jen místo
"odečíst výběr" přepneme na "přidat k výběru" (nebo
prostě držíme SHIFT). Pak vybereme nástroj
ztmavení (velikost 18, rozsah světla, expozice 15%)
a okraje, případně i vnitřek, mírně ztmavíme, čímž
opět získáme plastické mraky.
• Slunce i ostrov jsou jednoduché úkony a ploutev
ryby i palmu dotvoříme pomocí nástroje pero.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
26
Retuš a úpravy – Vybarvování a přechody [1]
Nástroj přechod (v kombinaci s výběrem) Nabízí tvorbu neomezeného množství
různorodých barevných přechodů.
Pět ikonek nalevo značí typ přechodu - lineární
(podélný), kruhový, úhlový, zrcadlený a
křížový.
Nalevo od ikonek se nachází výběr, kde je
už připraveno několik desítek různých
přechodů rozdělených do kolekcí.
Přechody složí k vytváření 3D efektů.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
27
Vybarvování a přechody – příklad 2 [1]
• V novém obrázku o rozměrech 300 x 25 vytvoříme
přímo na pozadí barevný přechod dvou
příbuzných barev, řekněme světle a tmavě fialové.
Nejprve tedy zvolíme jednu barvu, poté klikneme
na přehazovací šipku u barev v panelu nástrojů a
zvolíme druhou barvu. Pak vybereme nástroj
přechod (lineární), natáhneme jej přes délku
obrázku a pustíme.
• Nástrojem výběr jednoho řádku vybereme svrchní
řádek a vybarvíme jej barvou o něco sytější než je
světlý horní okraj obrázku. To samé uděláme dole,
jen to bude barva o něco tmavší, než je barva
dolního konce obrázku.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
28
Vybarvování a přechody – příklad 2 [1]
• Nakonec vytvoříme novou vrstvu. Aplikujeme
výběr jednoho sloupce a plechovkou jej vybarvíme
nejprve tmavou barvou z předchozího úkonu,
potom ho posuneme o 1px doprava a vybarvíme
světlejší barvou (opět z č.2). Vrstvu pak můžeme
nakopírovat a máme jednoduché menu pro
webovou stránku.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
29
Nástroje [1]
Lupa (klávesová zkratka Z) - chcete-li se zaměřit
na jistou část obrázku, prostě zvolte nástroj lupa
a požadovanou část obrázku jím. Stisknout
CTRL a + nebo -.
Kapátko - Základní funkcí tohoto nástroje je vybrat
z obrázku požadovanou barvu – kliknete někam
do obrázku a Photoshop automaticky nastaví
jako barvu popředí tu barvu, která se nachází
právě pod kurzorem.
– V paletce voleb nástroje můžete zvolit zda
má být zvolená barva přímo z daného
obrazového bodu (pixelu) či zda má jít o
průměrnou hodnotu okolních bodů o rozsahu
3x3 nebo 5x5 pixelů.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
30
Nástroje [1]
Vzorkování barev je vlastně takové permanentní
kapátko - máte možnost umístit kamkoliv do
obrázku čtyři záchytné body, které pak budou
zobrazovat v paletce (můžete sledovat změny,
které se s obrázkem dějí při změnách kontrastu,
vyvážení barev, apod).
Měřítko – měření "vzdáleností" a úhlů v obrázku.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
31
Nástroje [1]
Ručička (klávesová zkratka H nebo mezerník) Tento nástroj v podstatě nahrazuje posuvníky.
Zobrazení pravítek a mřížek - hlavním menu ->
Zobrazení:
– lupa - zvětšit, zmenšit, na celou obrazovku,
– zobrazovat - zapnout Mřížku,
– Pravítko – dvojklik levým tlačítkem – objeví
se nastavení,
– přitahovat - jakmile se kurzor přiblíží na
vzdálenost několik pixelů například k okraji
stránky nebo k úsečce mřížky, automaticky je
k ní "přitáhnut".
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
32
Nástroje [1]
Manipulace s obrázkem - hlavním menu -> Obraz
• změna barevného režimu obrázku (RGB, CMYK,
stupně šedi),
• přizpůsobování barev (změna kontrastu a jasu,
barevného vyvážení, sytosti),
• velikost obrazu - mění velikost dokumentu, mění
rozlišení,
• velikost plátna – mění velikost plochy, na kterou
kreslíme,
• natočit plátno - natáčení a převracení podle své
libosti,
• oříznout - k dispozici pouze je-li proveden nějaký
výběr.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
33
Vrstvy [1]
• Vzájemná interakce vrstev - Režim prolnutí
určuje jak se budou chovat obrazové body
jednotlivých pod sebou srovnaných vrstev, jak se
spolu budou míchat a která bude výsledná
viditelná barva. (Normální, Rozpustit, Ztmavit,
Násobit, ...).
• Styly - Dynamický efekt, který se mění pokaždé,
když se změní vrstva, jinak řečeno se
přizpůsobuje. Klepnete pravým tlačítkem v
seznamu vrstev na nějakou vrstvu mimo pozadí a
zvolíte Volby prolnutí. Objeví se rozsáhlé okno s
mnoha volbami.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Interakce vrstev se liší obrázek od obrázku, záleží zejména na jeho barevnosti a
světelnosti. Proto zkuste nyní najít na svém disku nebo na internetu několik
různých fotografií, otevřete je ve Photoshopu a v každém z nich duplikujte vrstvu
s obrázkem. Jak? Prostě klikněte v seznamu vrstev pravým tlačítkem na tu vrstvu
nadepsanou "Pozadí" (nalevo by se měla nacházet zmenšenina obrázku) a
vyberte možnost Duplikovat vrstvu. Máme tak nyní dva stejné obrázky jakoby
položené na sebe. Nyní můžeme začít experimentovat s prolínáním vrstev.
Standardně je nastaven normální režim, ve kterém se barvy vůbec nemění.
Zvolíme-li rozpustit, také se nic nezmění, protože máme dvě zcela totožné
vrstvy. Ani u volby ztmavit (a zesvětlit) se nic nestane - ze stejného důvodu.
Teprve u režimu násobit bychom měli pochytit první změnu, obrázek ztmavne.
Násobení černé barvy černou barvou vytváří opět černou, bílá zůstává také beze
změny. Všechny ostatní barvy se ztmavují. Ztmavení lze pozorovat i u režimu
Ztmavit barvy - spodní barvu ztmaví v závislosti na horní a vytváří tak velice
zajímavý kontrastní efekt. Zesvětlování se týká všech režimů, které v sobě mají
slůvko "světlo", zesvětluje také režim závoj. Poněkud zvláštní jsou poslední čtyři
volby, totiž Odstín, Sytost, Barva a Světlost. Budeteli je zkoušet se duplikovanými
vrstvami, nic se nestane - vždy se totiž jedná o stejné hodnoty barev. Teprve
když jsou nad sebou vrstvy s různými hodnotami barevných bodů, začne se něco
dít. Toho docílíme jednoduše tak, že vytvoříme novou vrstvu (ať již pomocí
spodní ikonky nebo výběrem v nabídce Vrstva - Nová - Vrstva) a vyplníme ji
pomocí nástroje Plechovka barvy (klávesa G) nějakou pastelovou barvou. Pak už
lze aplikovat téměř všechny režimy včetně posledních čtyř.
34
Vrstvy – příklad 1 [1]
• Proto si ukážeme dva poměrně jednoduché, ale ve
výsledku velice pěkné příklady stylů vrstev.
Začneme vodou. Otevřeme barevný obrázek
nějaké květiny a vytvoříme v něm novou vrstvu.
Výplň nastavíme na 0% (pozor, nikoliv krytí).
Pravým tlačítkem na ni klikneme a vybereme
"Volby prolnutí".
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
35
Vrstvy – příklad 1 [1]
• V okně Styl vrstvy zaškrtneme možnost Vržený
stín a klikneme na tuto možnost, režim dáme na
násobit, krytí 28%, vzdálenost 1, rozsah 0%,
velikost 1 pixel.
• Pak zaškrtneme úkos a reliéf, opět na něj klikneme
a nastavíme styl: vnitřní úkos, metoda hladká,
hloubka 100%, směr nahoru, velikost 6, změkčit 2,
úhel 96°, výška 34°, profil lesku třetí odleva
nahoře, režim závoj - barva bílá a krytí 75%, druhý
režim násobit a barva i krytí stejné.
• Nakonec zaškrtneme pod nabídkou "Úkos a reliéf„
také "Profil", klikneme na graf a vybereme první
zprava nahoře, zaškrtneme vyhlazení a rozsah
nastavíme na 50%. Závěrem stiskneme tlačítko
OK. Tak, vše je připraveno.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
36
Vrstvy – příklad 1 [1]
• Vybereme nástroj štětec, velikost nastavíme na 5 10 pixelů a do nové vrstvy nakreslíme několik
tahů. Vidíte, že je jedno jakou barvou kreslíte vždy by se měly objevit jakoby proužky či kapky
vody. Tento efekt ovšem nebude viditelný (nebo
jen málo) tehdy, když bude vrstva, na kterou je
aplikován a do které se kreslí prázdná nebo
jednobarevná – vždy je nutné kreslit na podklad
typu fotografie. Oproti tomu následující příklad lze
aplikovat na jakýkoliv výběr či celou vrstvu.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
37
Vrstvy – příklad 2 [1]
• Jedná se o "žhavé písmo". Opět klikněte pravým
tlačítkem na vrstvu a vyberte Volby prolnutí.
• Zaškrtněte Vržený stín, krytí 50%, jinak zanechte
původní nastavení, zaškrtněte vnitřní stín a barvu
změňte na světle červenou, zaškrtněte vnější záře
a barvu změňte na tmavší oranžovou – ostatní
nastavení ponechte vždy tak jak jsou.
• Dále zaškrtněte vnitřní záře a profil změňte na
poslední nahoře zprava.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
38
Vrstvy – příklad 2 [1]
• Zaškrtněte také satén, vyberte žlutou barvu a profil
stejný jako předchozí a nakonec zaškrtněte
překrytí barvou a vyberte pomerančově
oranžovou.
• Tak, pokud je všechno nastaveno jak má být,
stiskněte OK.
• Nyní klikněte na nástroj Text a pak znovu klikněte
nějak do obrázku do nové vrstvy. Objeví se kurzor
a vy můžete začít psát - vidíte, že písmena mají
"žhavou", oranžovou žlutou barvu.
• Efekt je lépe viditelný na černém podkladě, v
případě světlejšího jej lze vylepšit snadno - ve
Volbách prolnutí zaškrtněte také "Vytažení" a
vyberte vhodnou barvu a tloušťku.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Styly lze jednoduše duplikovat (přenášet z vrstvy na vrstvu) tak, že v seznamu
vrstev kliknete na vrstvu se stylem pravým tlačítkem a vyberete možnost
Kopírovat styl vrstvy.
Pak v seznamu kliknete levým tlačítkem na tu vrstvu které chcete styl přiřadit a
zvolíte Vložit styl vrstvy. Když se vám styl znelíbí, prostě ho odstraňte kliknutím
na Odstranit styl vrstvy. Seznam všech uložených stylů naleznete v paletce
Barvy, Vzorník, Styly. Vaše vlastní styly lze samozřejmě ukládat (když se
porozhlédnete po okně Volby prolnutí u některé vrstvy, zjistíte, že pod tlačítky
OK a Zrušit je také tlačítko Nový styl). V paletce Styly lze přejmenovávat a různě
jinak organizovat vlastní i již vyrobené styly.
39
Vrstvy [1]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
• Vrstvy úprav - Jedná se o speciální vrstvy, jejichž
nedílnou součástí je tzv. "maska„. Tyto masky jsou
poněkud jiné - slouží k barevným úpravám vrstev.
– V jednoduchosti si lze tyto masky představit
jako speciální barevné fólie, které položíte na
nejsvrchnější vrstvu - všechny spodní vrstvy
jsou pak touto fólií nějak ovlivněny.
– Jsou různých druhů, lze s nimi upravovat
barevné úrovně, vyváženost barev, jas a
kontrast, odstín a sytost a mnoho dalších
atributů.
– Jejich hlavní předností je, že pokud chcete
některou z vyjmenovaných operací na některou
z vrstev aplikovat, nemusíte zasahovat přímo
do vrstvy, ale vytvoříte právě novou vrstvu
úprav. Původní vrstva tak zůstane beze změn a
vrstvu úprav lze kdykoliv podle libosti dále
přizpůsobovat.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
40
Další operace s vrstvami [1]
• Uzamykání vrstev - Čtyři malé ikonky vedle
nápisu zámek:
– na první z nich způsobí, že nebude možné
jakkoliv upravovat barevné průhledné obrazové
body vrstvy čili prostě řečeno
– prázdné místo,
– druhá ikonka naopak uzamkne už vybarvené
obrazové body,
– třetí ikona uzamkne vrstvu na místě tak, že s ní
nelze hýbat, ale lze do ní kreslit,
– poslední ikonka zámku uzavře
vrstvu nadobro proti jakékoliv
změně.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
41
Text [1]
• V paletce voleb nástrojů lze volit font,
typ písma, velikost a vyhlazení, dále
také zarovnání a barvu.
• Mnohé další volby nalezneme v
paletce Znaky a odstavec, kterou lze
zapnout ve volbách nástroje.
• První záložka umožňuje takřka neomezenou práci
se znaky, lze definovat jak velikost, tak i jejich
rozestup, rozestup řádků i měřítko znaků.
• Záložka Odstavec pak nabízí možnosti zarovnání a
odsazení odstavců.
• Celý odstavec - klikneme, držíme a táhneme.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Pod ikonkou text se skrývají ještě další nástroje. Prvním z nich je svislý text. V
podstatě se jedná o totožný nástroj, jediný rozdíl spočívá v tom, že znaky
nepíšete od leva do prava nýbrž od shora dolů. Přepínání této volby je jednoduše
dostupné také v panelu voleb nástroje přes ikonku. Dalšími nástroji jsou
vodorovná textová maska a svislá textová maska. Opět se nejedná o nic jiného
než o nástroj text, který ovšem místo tvarů vykouzlí na obrazovce výběr přesně
ve tvaru napsaného a upraveného textu. o se hodí zejména při práci s
fotografiemi. Tento výběr lze ale samozřejmě vytvořit i jinak - kupříkladu
držením klávesy CTRL a kliknutím levého tlačítka na požadovanou textovou
vrstvu v paletce Vrstvy.
42
Akce (makra) [1]
• Čas od času se objeví potřeba zpracovat i několik
desítek až stovek obrazových souborů zcela
stejným způsobem.
• Tyto úpravy je možné zautomatizovat většinu
často opakovaných úkonů.
• Akce mají svou samostatnou paletku (záložku),
která slouží k nahrávání, přehrávání, úpravám a
odstraňování jednotlivých akcí.
• Tato paleta také umožňuje ukládat a načítat
soubory akcí.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Pokud chcete aplikovat jednu a tu samou akci na větší množství souborů
(například z digitálního fotoaparátu či skeneru), zvolte v nabídce Soubor volbu
Automaticky a Dávka. Objeví se okno s rozsáhlými možnostmi nastavení nejdůležitější je vybrat akci, která se má aplikovat (úplně nahoře pod nadpisem
"Spustit") a následně také zvolit zdroj a cíl zpracování. Akce také představují
základ pro malé prográmky zvané "droplety", což je v podstatě jednoduchá
aplikace automaticky zpracovávající požadované soubory podle zvoleného zadání.
Droplet vytvoříte výběrem nabídky Soubor - Automaticky - Vytvořit droplet.
Automatické zpracování souborů ve Photoshopu verze 7.0 však sahá ještě dál.
Ve stejné nabídce (Soubor - Automaticky) nalezneme také volby Fotogalerie pro
web, Stránka miniatur a další. Konkrétně tyto dvě slouží k automatické tvorbě
webové stránky nebo dokumentu, kdy zdrojem je složka s více obrázky a na
stránce/v dokumentu se objeví pouze jejich zmenšené náhledy. To samozřejmě
opět šetří spoustu času, zejména tehdy chcete-li snadno a rychle připravit třebas
fotky z dovolené k publikování na internetu. Rychlé třídění a navigace mezi
soubory je v současné době jeden z klíčových momentů každého programu.
Proto také přišla sedmá verze Photoshopu s novinkou zvanou Prohlížeč souborů,
což je v podstatě zjednodušený Průzkumník. Nalezneme ho obvykle v pravém
horním rohu.
TIP: Chcete-li otevřít ve Photoshopu najednou více souborů z jedné složky, stačí
zvolit Soubor - Otevřít, v dialogovém okně pak kliknout na počáteční soubor,
stisknout a držet klávesu SHIFT a pomocí šipek označit další požadované
soubory.
43
Akce (makra) – příklad [2]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
• Pro příklad si vybereme první z obrázků. Otevřete
ve Photoshopu nový dokument s rozměry např.
400 x 400, pozadí bílé. Vytvořte novou vrstvu
(New layer) a nastavte barvu popředí jako černou
(Foreground color).
• Nyní si musíte vytvořit selekci (výběr), pomocí
které budete kreslit vybraný obrázek. Aby byl
výsledný obrázek pravidelný a souměrný, musí
být souměrná i vytvořená selekce. K tomu
využijte vodící linky (Guides). Pokud nemáte
zobrazeno pravítko (Rulers) kolem dokumentu,
zobrazte si je pomocí CTRL+R. Vodící linky
vytvoříte tak, že je pomocí kurzoru "vytáhnete" z
pravítka.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
44
Akce (makra) - příklad [2]
• A to buď tažením z vodorovného pravítka směrem
dolů nebo ze svislého pravítka směrem doprava.
• Z vodících linek si vytvořte tvar, který by měl být
shodný s tvarem uvedeným na dalším obrázku.
Důležité je, abyste dodrželi souměrnost a poměr.
Červeně vyznačené části na druhém obrázku musí
být pravidelné čtverce.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
45
Akce (makra) - příklad [2]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
• Jakmile máte takto vytvořené vodící linky, musíte s
jejich pomocí vytvořit základní selekci. Vyberte si z
paletky nástrojů nástroj pro vytváření selekcí a to
kruhovou (Elliptical marquee tool) a zároveň si
zatrhněte přičítání selekcí (Add to selection).
• Nejdříve použijte kruhovou
selekci a to v prostorech, které
jsou vyznačeny červeně (na
obrázku s rozložením vodících
linek). Utvořte selekci tak, aby
se dotýkala všech 4 stran
vodících linek. Pak si zvolte
čtvercovou selekci a utvořte
výběr (s využitím vodících
linek), která spojí oba kruhy.
Vznikne vám útvar podobný
čince.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
46
Akce (makra) - příklad [2]
•
•
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Nyní máte vytvořen základ pro další práci, kdy se
dostanete k využití akcí. Aby se vám všechno
nepletlo, skryjte si vodící linky – Zobrazení | Ukaž |
Vodící linky (View | Show | Guides), stejným
postupem je můžete vyvolat zpět.
Pokud nemáte zobrazenu paletku s nabídkou akcí,
zobrazte si ji pomocí Okno | Akce (Windows |
Show actions). V paletce Akce (Actions) klikněte
na ikonku vytvoření nové akce Vytvořit novou akci
(Create new action) – je to ta druhá zprava. Otevře
se okno k zadání názvu akce. Zvolte si nějaký
název a klikněte na Začít nahrávat (Record), čímž
se začne nahrávat akce a vše co od této chvíle
uděláte bude součástí vaší nově vytvořené akce.
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
47
Akce (makra) - příklad [2]
•
•
•
Situace je následující: máte novou vrstvu, barva
popředí je nastavená na černou, pozadí je bílé a
máte vyznačenou selekci ve tvaru činky. Vaším
prvním úkonem v nahrávané akci bude vytvoření
černého obrysu (Stroke) kolem vytvořené selekce.
V menu si zvolte Úpravy | Vytáhnout (Edit | Stroke)
a zadejte šířku 1 px, center a potvrďte. Tím se
vytvoří černý obrys selekce.
Druhým krokem bude rotace selekce. Z menu
vyberte Výběr | Transformovat výběr (Select |
Transform selection) a v liště, která se vám objeví
pod nabídkou, zvolte úhel 20°.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
48
Akce (makra) - příklad [2]
•
•
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Potvrďte (2x Enter) a nyní můžete ukončit
nahrávání své akce kliknutím na ikonku čtverečku
Ukončit přehrávání/nahrávání (Stop recording ) v
paletce Akce (Actions) – první zleva. Tato velmi
jednoduchá akce je hotová a uložena na pozdější
použití.
Nyní můžete svůj obrázek dokončit již s využitím
nově vytvořené akce. Klikněte na název akce (v
paletce Akce ~ Actions), který jste zadali při jejím
vytvoření a poté na ikonku šipky Začít přehrávat
(Play selection ) - třetí zleva. Poté dojde k přehrání
uložené akce. Na ikonku šipky klikejte tak dlouho,
dokud neproběhne rotace činky o 180o. Výsledek
by měl vypadat takto:
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
49
Akce (makra) - příklad [2]
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
Pokud chcete, můžete do akce zahrnout celý počet rotací, který je nutný k
opsání úhlu 180°. Tím se vyhnete nutnosti opakovaně spouštět akci, dokud
rotace není úplná (ale na druhou stranu přijdete o možnost jednoduše změnit
nastavení vytvořené akce – např. úhel rotace). A teď už můžete experimentovat
s tvarem selekce a úhlem rotace nebo do akce zahrnou další funkce, čímž
můžete vytvořit velmi zajímavé geometrické útvary nebo i jiné efekty. Stačí
skutečně malá změna tvaru selekce a výsledný obrázek je zcela odlišný.
Pro využití akce, kterou jsme si popsali, je nutné mít nejdříve vytvořenou
nějakou selekci a až poté akci spustit (Začít přehrávat ~ Play action).
50
Literatura
[1] HORČÍK, Jan. Základy Adobe Photoshopu. Živě - computer
[online]. 11. 2. 2003, 1 - 11, [cit. 2010-11-09]. Dostupný z
WWW: <http://www.zive.cz/clanky/zaklady-adobephotoshopu-cast-8/sc-3-a-110357/default.aspx>.
[2] ČAPKA, Martin. Geometrické útvary s využitím akcí ve
Photoshopu. Interval.cz [online]. 17. 11. 2002, [cit. 2010-1109]. Dostupný z WWW: <http://interval.cz/clanky/geometrickeutvary-s-vyuzitim-akci-ve-photoshopu/>.
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
51
Vysoké učení technické v Brně
Fakulta elektrotechniky a komunikačních technologií
Děkuji za pozornost
Tel.: 541 149 510
Fax: 541 149 512
e-mail: [email protected]
Kolejní 2906/4
612 00 Brno
INVESTICE
DO ROZVOJE
VZDĚLÁVÁNÍ
http://www.ietbrno.eu
Tato prezentace je spolufinancována Evropským sociálním fondem a státním rozpočtem České republiky.
52

Podobné dokumenty

GIMP - skvělý freewarový bitmapový editor,mocný nástoj pro

GIMP - skvělý freewarový bitmapový editor,mocný nástoj pro V podstatě máte dvě možnosti - Adobe Photoshop nebo jeho alternativa - Gimp. V principu jsou si oba programy velice podobné - jejich společný základní princip spočívá v možnostech práce s vrstvami....

Více

Počítačová grafika - Základní umělecká škola Bzenec

Počítačová grafika - Základní umělecká škola Bzenec neustále prohlubovat znalosti daného programu. Zde předkládám jednu ukázku takového programu a prvky, které žáci se učí používat. Když program poprvé spustíte, ukáže se na první pohled poněkud nepř...

Více

Kurz colorizace vlasů - SOŠ a SOU Neratovice

Kurz colorizace vlasů - SOŠ a SOU Neratovice Pro neutralizaci žlutého základu použijte fialovou. Pro neutralizaci oranžového základu použijte modrou. Pro neutralizaci červeného základu použijte zelenou. Kruh můžeme doplnit o další barvy. Vždy...

Více

1. Rychlé použití barev

1. Rychlé použití barev obrazovky máte na panelu nástrojů Toolbox (Nástroje), ve kterém je rámeček Fill (Výplň) a Stroke (Tah) (Obr. 7.1). Když kliknete myší dvakrát na čtverec, můžete si vybrat jakoukoli barvu. Pokud mát...

Více

regio zari 2012:Sestava 1.qxd

regio zari 2012:Sestava 1.qxd ve svém oboru by každý z nás měl sledovat novinky, učit se novým poznatkům a jít zkrátka s dobou. Samostatnou kapitolou jsou pak jazyky. Ruku na srdce, kdo z nás se skutečně bez problémů a rozpaků ...

Více

Ve své práci se zabývám různými typy zobrazení archetypů ve

Ve své práci se zabývám různými typy zobrazení archetypů ve vlastním místě v prostoru a čase. Hodnoty, které zobrazují staří mistři, již mnohdy vychladly, moderní umění je zas tak žhavé, že ho nepoučená ruka nedovede zachytit. Stýská se nám po těch časech, ...

Více

PowerPoint 2010

PowerPoint 2010 PowerPoint 2010. Text je koncipován tak, aby Vám usnadnil použití jednotlivých nástrojů tohoto programu a pomohl Vám při tvorbě vlastních, interaktivních a působivých prezentací. Nejprve se podívám...

Více

poslouchat měkký dotek 94,7

poslouchat měkký dotek 94,7 Palm OS, logo Palm a VersaMail patří k obchodním známkám nebo registrovaným obchodním známkám, jejichž vlastníkem nebo poskytovatelem licence je společnost palmOne, Inc. Všechny ostatní značky a ná...

Více