grpm 2005

Komentáře

Transkript

grpm 2005
Grafické editory a DTP
Na počátku 80. let se o počítačové grafice mohlo uživatelům
jen zdát, protože šlo oblast natolik finančně náročnou, že si ji mohly
dovolit jen bohaté firmy. S postupem času začala ale grafika do
počítačového průmyslu pronikat stále výrazněji. Zásadním zlomem
pak bylo uvedení grafických uživatelských rozhraní (angl. GUI), které
urychlilo jak vývoj grafického softwaru, tak zejména hardwaru.
Počítače umožňovaly stále větší rozlišení obrazu a možnost zobrazení
stále většího počtu barev. Počítač se tedy pomalu začal stávat
nástrojem grafické (umělecké) tvorby.
Grafické
editory a DTP
V zásadě se grafika (obrázky) objevuje v počítači ve dvou
základních formátech:
1. rastrový formát - jinými slovy bitová mapa nebo bitmapa. Takový
obrázek je určen konečným výčtem bodů, kde každý z těchto bodů
je přímo adresován. Pokud například má obrázek rozměry 1024 x
768 bodů, pak se skládá z 1024 x 768 = 786 432 bodů. Každý bod
v paměti počítače zabírá 2 - 32 bitů (podle počtu zobrazovaných
barev). Výhodou tohoto formátu je velice realistické podání
grafiky, nevýhodou pak vysoké nároky na paměť a zhoršení
zobrazení při zvětšování obrázku.
1
Rastrový formát
vektorový formát - zobrazené objekty jsou určeny pouze svým
okrajem pomocí matematické křivky. Objekty jsou pak jednoduše
vyplněny barvami. Výhodou tohoto způsobu je malá paměťová
náročnost a nezkreslení obrázku při jeho zvětšování. Nevýhodou
pak relativně nerealistické podání kresby. Takto vytvořená grafika
vypadá spíše jako umělecká, než naprosto realistická.
Prostředkům (programům) pro tvorbu grafických obrázků na
počítači se říká grafické editory nebo procesory.
Grafické editory disponují jen omezenou paletou nástrojů pro
tvorbu a úpravu obrázků, jsou ale levné a poměrně rychlé. Dovolují
například kreslení v 16 nebo 256 barvách, kreslení od ruky, konstrukci
základních geometrických obrazců (čára, kruh, čtverec, obdélník aj.),
vyplňování obrazců, simulují kresbu sprejem ap. Grafické editory
pracují výhradně v rastrovém (bitmapovém) režimu. Na našem trhu
existuje hned několik slušných grafických editorů. Dlužno říci, že
slušný grafický editor je schopen vytvořit i programátor začátečník.
•
•
•
2
Zebra - český produkt určený pro práci pod MS DOSem. Jedná se
o jednoduchý a cenově dostupný nástroj pro tvorbu rastrových
obrázků. Jeho zdokonalená verze umožňuje použití až 256 barev
najednou.
DrGenius - obdobný produkt dodávaný k polohovacím zařízením
firmy Genius. Podobně jako Zebra vyhovuje pro tvorbu
jednoduché grafiky.
Paintbrush (Malování)- grafický editor dodávaný jako součást
operačního systému MS Windows. Kromě výše zmiňovaných
funkcí podporuje ještě výměnu obrázků přes schránku. Jeho
nespornou výhodou je i to, že jej pořídíte současně s operačním
systémem.
Vektorový formát
Grafické procesory jsou podstatně složitější, poskytují výrazně
širší paletu nástrojů. Jejich cena se však pohybuje v násobcích cen
grafických editorů. Většinou podporují jen rastrovou, nebo jen
vektorovou technologii.
Rastrové grafické procesory
•
•
•
Photoshop - vynikající produkt americké firmy Adobe Inc. je
určen zejména k profesionálnímu použití v grafických studiích. Je
určen pro práci s naskenovanými obrázky. Umožňuje však i
jednoduché kreslení. Vhodné je jeho zapojení do technologie
PRE-PRESS (příprava tiskových předloh).
Painter - produkt americké firmy Fractal Desing určený zejména
pro umělce. Nabízí téměř neomezenou paletu kreslících nástrojů,
technik a podkladů. Umožňuje aplikaci mnoha digitálních efektů
(například hrbolatý papír, nebo osvětlení světlem). Ve své
poslední verzi podporuje i tvorbu počítačových animací.
Corel Photo-Paint
Rastrové
grafické
procesory
Vektorové grafické procesory
•
•
•
CorelDraw - poloprofesionální program, který dosáhl mezi
uživateli vysoké popularity díky své nízké ceně a hodnotným
grafickým funkcím.
Adobe Illustrator - plně vektorově orientovaný produkt určený
pro profesionální práci v grafických studiích. Vhodné je jeho
zapojení do technologie PRE-PRESS (příprava tiskových
předloh).
Zoner Callisto – český grafický editor, obdoba CorelDraw, méně
funkcí, avšak velmi rozumná cena. Je možná i výhodná školní
multilicence.
Vektorové
grafické
procesory
Programy pro počítačovou sazbu a zlom
•
•
•
•
•
Aldus PageMaker - v současné době se vyskytuje již ve verzi
6.0. Aldus PageMaker byl prvním široce rozšířeným komerčním
produktem pro DTP na platformách Apple Macintosh a IBM PC.
QuarkXPress - je profesionálním programem pro DTP. Původní
verze existovala pouze pro platformu Apple Macintosh, v dnešní
době se tento program prodává i pro počítače IBM PC
kompatibilní. Jeho výhodou je široká kompatibilita s jinými
grafickými programy firmy Adobe Systems.
Corel Ventura
TEX je příkladem nekomerčních (zdarma) programů, jeho další
rozšíření je
LaTEX, jehož velkou výhodou je multiplatformnost. Za
nevýhodu lze považovat zcela neintuitivní rozhraní.
Animace a vizualizace
Zejména v posledních letech se výrazně rozvíjí využívání
počítačů při tvorbě dvou i třírozměrných filmů, videoklipů a dalších
3
Programy pro
počítačovou
sazbu
trikových sekvencí. Donedávna k tomuto účelu sloužily velmi drahé
pracovní stanice, zejména pak počítače firmy Silicon Graphics. S
rostoucím výkonem osobních počítačů začíná pomalu technologie
profesionálních animací a vizualizací přecházet i na PC.
Animací budeme rozumět tvorbu efektů ve dvojrozměrném
prostoru. Klasickým zástupcem animace může být například kreslený
film.
Animace
Vizualizací budeme rozumět tvorbu těles, pohybů a dalších
efektů ve trojrozměrném prostoru, tj. simulace trojrozměrného
prostoru se všemi jeho vlastnostmi pomocí počítače. Trojrozměrnému
prostoru existujícím pouze uvnitř počítače říkáme virtuální (umělý)
prostor. Konstrukce fotorealistického obrázku (popř. celé animace) z
trojrozměrného drátového modelu tělesa je velmi výpočetně náročná.
Proto prakticky i dnes zůstává doménou velmi výkonných pracovních
stanic. Pravděpodobně ji všichni dobře známe z filmů (např. Jurský
park). Vizualizace se občas používá i v systémech CAD pro lepší
představu konstruktérů o modelovaném výrobku, nebo častěji při
vojenském výcviku pilotů. Na současném trhu existuje několik
profesionálních vizualizačních programů, které se výrazně liší cenou,
ale výkonově jsou na prakticky stejné úrovni. Pravděpodobně
nejznámější vizualizační program z dílny firmy Autodesk je 3D
Studio.
Vizualizace
Pro tvorbu animací existuje na světovém trhu řada produktů. K
nejznámějším samozřejmě patří Animator Professional firmy
Autodesk. Dále existuje velké množství aplikací pro tvorbu
prezentací, např. Authorware firmy MacroMedia nebo PowerPoint
firmy Microsoft. Takový software většinou podporuje také tvorbu
jednoduchých animací.
Trikové efekty
V posledních několika letech na náš trh pronikají programy pro
tvorbu jednoduchých trikových sekvencí. Tyto programy jsou
postaveny na metodě nazvané Morphing. V praxi tyto efekty většina z
nás zná; jedná se o plynulé animované přechody například obličejů.
Nyní si takové jednoduché animace můžete vytvářet již doma na svém
počítači třeba z vlastních fotografií. Některé z těchto programů jsou
dostupné jako freeware, přičemž kvalita odpovídá pořizovacím
nákladům (Rmorph dostupný např. na Internetu). Naopak ke
špičkovým produktům patří například program DigitalMorph firmy
Kai's software.
Princip všech těchto programů spočívá v pokrytí zdrojového
obrázku sítí polygonů a jejich úpravou tak, aby se shodovaly s
důležitými rysy obrazu. Na cílovém obrázku vznikne shodná síť
polygonů, kterou je však třeba upravit tak, aby obepínala stejné
charakteristické rysy (např. oči) na druhém obrázku. Po spuštění
morphovacího programu dojde k postupnému přechodu oblastí
polygonu tak, že se efekt přeměny bude zdát naprosto plynulým.
4
Morphing
Programy pro zpracování videa
S rostoucí kapacitou a výkonností počítačů roste i hlad
uživatelů po produkci digitálních videosekvencí. Důvodů pro to může
být hned několik:
•
•
•
Programy na
zpracování videa
digitální video neztrácí s časem nic ze své kvality
interaktivní ovládání videa a jeho začleňování do vlastních
aplikací
rychlost odezvy videa je vyšší, neboť není nutné například
přetáčení
Digitální video má ovšem i řadu nevýhod:
•
•
•
nutnost speciální karty pro kompresi a dekompresi obrazu
velké datové objemy souborů
nedostatečné rozlišení a barevnost obrazu
Přesto existuje několik profesionálních nástrojů pro zpracování
digitálně (na pevném disku) zaznamenaného obrazu. Prakticky se
jedná o aplikační programy simulující střihové studio. Nejznámějším
a nejlepším produktem je pravděpodobně Adobe Premiere, pro
začátečníka může ale posloužit i program VideoEdit nebo program
dodávaný společně s kartou pro střih digitálního videa (např. Pinnacle
studio).
Adobe Premiere - profesionální program simulující filmovou střižnu.
Program se vyskytuje v provedení pro operační systém Apple
Macintosh i pro PC. Umožňuje import jednotlivých obrazových a
zvukových klipů, jejich úpravu (filtry, velikost, kvalita, rychlost ap.) a
vkládání do výsledné videosekvence. Kromě toho obsahuje i velkou
banku různých střihových efektů. Podporuje i vlastní nahrávání videa,
pokud je v počítači instalován příslušný hardware. Konverze živé
videosekvence může být uložena hned do několika formátů (závisí na
instalovaných ovladačích). Součástí dodávky pro počítače PC je i
Microsoft Video for Windows (sada ovladačů pro zobrazování
digitálního videa mnoha formátů). Vlastní proces tvorby
videosekvence je velice jednoduchý a intuitivní. Je plně podporována
metoda drag and drop (táhni a pusť). Celá sekvence je sestavována v
hlavním okně rozděleném na video a audiokanály, mezi kterými jsou
realizovány střihové přechody. Program může vygenerovat
náhledovou sekvenci (angl. preview) v menším rozlišení tak, aby
uživatel viděl mezivýsledky své práce.
Práce s programem je velmi intuitivní a příjemná, nevýhodou je jeho
relativně vysoká cena a velmi pomalý proces tvorby výsledné
videosekvence. Výsledek ovšem stojí za to.
VideoEdit - jedná se o jednoduchý program pro editaci videosekvencí,
který je součástí dodávky aplikace Microsoft Video for Windows.
Umožňuje jen několik základních funkcí (skládání klipů, změnu jejich
velikosti, délku a rychlost výsledné sekvence). Podporuje i vlastní
digitalizaci živého videa, pokud je instalován příslušný hardware. Plně
ale postačuje pro běžné tvrdé střihy jednotlivých záběrů. Výhodou je
5
Adobe Premiere
jeho nízká cena, které tvoří cca. desetinu ceny produktu Adobe
Premiere.
Pinnacle studio
Střihový program pro vytváření jednodušších multimediálních klipů.
Umožňuje zpracování klipů (střih, titulky, přechody, dabing, hudba na
pozadí, ozvučení apod.). Záznam klipů je možný na digitální kameru,
případně na VHS videorekordér. Dále umožňuje komprimaci do
různých formátu (např. mpg) a vypálení na CD. Je možná i volba
různých stupňů komprese v závislosti na požadované kvalitě záznamu
a kapacitě výstupního média. Program je k dispozici na všech
počítačích na učebně P11.
Pinnacle studio
Prezentační software
"Prezentační" nebo také "obchodní" grafika je obecný název
pro grafické systémy, které se používají pro tvorbu audiovizuálních
pomůcek pro přednášky, obchodní jednání, reklamy a podobně. Jejich
hlavní silou je fakt, že vizuálně podaná informace dokáže vyvolat
dojem, jakého nikdy nelze dosáhnout pouhým slovním podáním.
Prezentační systémy obsahují nástroje pro:
•
6
přímou tvorbu obrázků,
Prezentační
software
•
•
•
•
•
•
zpracování výstupů z jiných programů do podoby grafů, tabulek
atd..
tvorbu seřazených posloupností obrázků, tzv. "slidů".
v rámci seřazených posloupností slidů vytváření různých
efektních přechodů mezi obrázky (vytrácení, prolínání,...).
tvorbu animovaných sekvencí.
nahrání těchto výsledků na videorekordéry.
vytištění obrázků na různá zařízení, atd.
Prezentační software nabyl na populárnosti s příchodem
grafických uživatelských rozhraní (GUI), především MS-Windows.
Jednak proto, že díky příjemnému ovládání jej mohli dobře využívat i
méně zkušení uživatelé, ale především díky propracovanému systému
výměny dat pod Windows, podpoře tisku pro mnohá zařízení apod.
V poslední době obsahují prakticky všechny větší kancelářské
systémy (textové editory, databáze, tabulkové procesory, kreslící
programy) odnož s vlastními funkcemi pro vytváření prezentací z
výsledků vytvořených v tom kterém programu. Aby si tedy
specializované systémy udržely své místo na trhu, musí nabídnout
něco navíc. Především to bývá jednoduchost obsluhy s možností
vytvoření dokonalých efektů. Dále schopnost kombinovat rastrovou i
vektorovou grafiku, databázové soubory, tabulky ze spreadsheetů,
textové soubory atd. V neposlední řadě to jsou tzv. "outline-editory",
které umožňují podrobně naplánovat všechny sekvence materiálů a
hlavní části každého slidu.
Nejznámějším prezentačním programem je v současnosti Microsoft
PowerPoint. Jedním z prvních prezentačních systémů byl Harvard
Graphics, který byl původně vyvinut pro MS DOS.
Digitalizace a převody rastr - vektor
Pod pojmem digitalizace se v původním významu označovalo
přenášení dat z klasických médií (především papíru) do podoby
elektronické. A v nejužším významu se tak označuje přenášení
vektorových dat z map pomocí vektorových vstupních zařízení, jako
jsou digitizéry a tablety. Obecně se však digitalizace chápe poněkud
šířeji. Digitalizací se označuje nejen přenášení (vektorových i
rastrových) dat do digitální elektronické podoby, ale také vzájemné
převody mezi různými typy digitálních dat. Obsahem jsou proto
následující dva okruhy:
•
•
Klasická digitalizace, tedy převod papírových podkladů do
počítače
Vzájemné převody digitálních dat
Klasická digitalizace
Klasický proces převodu dat z fyzické formy (papíru) do
formy počítačové (digitální) rozlišuje zhruba dva přístupy:
7
Digitalizace
1. Přímou, neboli ruční digitalizaci, kdy se z map, půdorysů a
podobných podkladů snímá digitizéry vektorová informace.
2. Nepřímou, automatickou digitalizaci, kdy se nejdříve podklad
převede do elektronické podoby v rastrovém formátu scannery
(takřka bez zásahu operátora) a teprve poté se převádí z rastru na
vektorový formát. Často se ani taková data do vektorového
formátu nepřevádí a pracuje se rovnou s rastrem.
Pokud budeme mít jako vstupní médium papír, můžeme se
setkat s následujícími typy vstupních dat:
•
•
•
•
•
fotografie jsou většinou barevné, obsahují mnoho jemných kontur
a odstínů,
obrazy, malby, jsou opět většinou barevné, obsahují však pouze
několik zřetelných barev,
pérovky jsou specifické černobílé kresby s jasnými obrysy a črty,
technický výkres, projekt bývá podobný pérovkám, obsahuje
někdy i několik barev a text,
text bývá psaný nebo tištěný s velmi různou úrovní zřetelnosti a
tisku.
Kromě snímání dat z papírových podkladů lze též digitalizací
označit primární získávání dat v elektronické podobě, např. při měření
nejnovějšími typy theodolitů (totální stanice), které dokáží data přímo
zapisovat na diskety a podobná média.
Výstupem z procesu digitalizace jsou tyto tři typy informací:
•
•
•
vektorový formát dat pro technické a jiné přesné výkresy,
rastrový formát pro různé obrázky a grafy,
text kódovaný v různých tabulkách ASCII nebo podobně.
Výstup z
digitalizace
Ruční digitalizace pomocí digitizérů je, co se týče
hardwarového a softwarového vybavení, poměrně levná a jednoduchá.
Platí se zde však především lidská práce, protože proces je namáhavý
a zdlouhavý. Dlouhé soustředění při snímání je velice únavné.
Výstupem je přímo vektorová informace. Při digitalizaci je výhodné,
že operátor může rovnou vstupní data upravovat, filtrovat a podobně.
Ruční digitalizace se může provádět v režimech off-line nebo
on-line. Při práci v režimu off-line operátor snímá data neinteraktivně,
dávkově bez zásadní kontroly do nějakého zásobníku (elektronického
média). Z něj se posléze data zpracují v patřičném programu. Při online zpracování obsluha snímá data přímo v interaktivním grafickém
programu s vykreslováním na obrazovku. Nasnímaná data lze tedy
přímo kontrolovat a upravovat. Za jistou verzi ruční digitalizace lze
také považovat ruční přepsání textu v klasickém textovém editoru.
Mnohdy tato cesta bývá rychlejší a schůdnější než skenování předlohy
a její následné rozpoznávání programy OCR.
Automatizace snímání spočívá především v automatizaci
primárního převodu dat do digitální podoby, kdy se pomocí scannerů
vytvoří rastrový obraz podkladu. Pro získání kvalitních dat musí být
scannery velmi výkonné a jejich obsluha zkušená. Pokud nechce
8
Ruční
digitalizace
Automatická
digitalizace
uživatel dále pracovat pouze s rastrovými daty, musí je nějakým
způsobem převést do vektorového tvaru.
Skenovací zařízení bývají většinou drahá, ovšem velice rychlá.
Rastrový výsledek může být na první pohled kvalitní, ale co se týče
elektronického zpracování, nemá prakticky žádnou inteligenci.
Vzájemné převody digitálních dat
Pokud budeme uvažovat převod dat do elektronické podoby v
celé šíři, musíme kromě prvotního převodu originálních dat do
"nějaké" elektronické podoby uvažovat též jejich další upravení až do
požadované konečné podoby.
To znamená především převod
rastrového tvaru dat do vektorového. Opačnou úlohou (převod
vektoru na rastr) se počítačová grafika zabývá rovněž velmi často.
Nejčastějšími úlohami tedy jsou:
•
•
•
•
Převody
digitálních dat
převod textových dat do rastru (rastrátory),
převod vektorových dat do rastru (rovněž rastrátory),
převod rastrových dat do textu (OCR)
převod rastrových dat na vektorová (vektorizace)
Kontrolní úlohy
1.
Objasněte místo aplikačního software s ohledem na uživatele.
2.
V čem se liší textové editory a procesory?
3.
Proč se prodávají kancelářské systémy?
4.
Objasněte rozdíl mezi rastrovým a vektorovým formátem, pro
co jsou vhodné?
5.
Které programy jsou vhodné pro práci s rastrovou a vektorovou
grafikou?
6.
V čem spočívá základní rozdíl mezí animací a vizualizací?
7.
Z jakých důvodů se čím dál tím více rozšiřuje digitální video?
8.
Proč vznikly prezentační programy a k čemu dnes slouží.
9.
Jak můžeme chápat pojem digitalizace?
Pojmy k zapamatování
Aplikační software a jeho základní rozdělení, správci souborů, textové
editory a procesory, kancelářské systémy, tabulkové procesory,
grafické editory, rastrový a vektorový formát, animace, vizualizace,
morphing, programy pro zpracování videa, prezentační software,
digitalizace ruční a automatická, převody digitálních dat.
9
Skenování a úprava fotografií
Základní pojmy
Jednotky informace
bit
B (bit) je nejmenší jednotka informace. Je to zkratka anglických slov
Binary digIT (binární číslo). Vyjadřuje dva stavy – ano/ne,
zapnuto/vypnuto, pravda/nepravda a podobně. Samotné bity nemohou
nést mnoho informací, proto se spojují do celků po 8, 16, 32 a 64 aby
se jejich schopnost nést informace zvýšila.
byte
Základní jednotkou informace je 1 byte (čti bajt), který vznikne
spojením osmi bitů. Pomocí 1 byte můžeme zakódovat 256 možností,
z nichž každá reprezentuje např. jeden znak (číslo nebo písmeno) nebo
jednu barvu. Protože i byte obsahuje malé množství informace,
používají se jeho násobky:
• 1 KByte (kilobyte) = 1024 Byte
• 1 MByte (megabyte) = 1 048 576 Byte
• 1 GByte (gigabyte) = 1 073 741 824 Byte
• 1 TByte (terabyte) = 1 099 511 627 776 Byte
RGB model zobrazování barev
Vychází z faktu, že libovolnou barvu získáme kombinací tří
základních barev (Red – červené, Green – zelené, Blue – modré).
RGB je aditivní model (světelné zdroje se sčítají). Podle toho, kolika
bity jsou adresovány jednotlivé barevné složky rozlišujeme i barevnou
hloubku výsledného barevného obrazu. Ideálním je případ, že každá
základní barva je adresována 8 bity (256 kombinací). Kombinací
všech tří složek (3 x 8 bitů = 24 bitů) získáme 256 x 256 x 256 = 16,8
milionu zobrazitelných barev. Tento model se používá u monitorů.
CMY
Cyan – Magenta – Yellow barevný model pro použití při tisku na bílý
podklad. Tzv. subtraktivní model, kdy se barvy odečítají od bílého
pozadí. Inverzním modelem je model RGB.
CMYK
Cyan – Magenta – Yellow – Black barevný model je rozšířený CMY o
samostatnou černou barvu, která se při tisku používá ve velké míře a
jejíž míchání z ostatních barevných složek by bylo neekonomické a
výsledek by nebyl nikdy stoprocentní.
Pixel (obrazový bod)
Základní jednotka zobrazení, která obsahuje konstantní barevnou
informaci. Jde o jeden obrazový prvek (bod obrázku) v pravoúhlé síti
bodů. Podle toho, jak velkou pamětí je adresován (kolik bitů
použijeme na jeho popis) určujeme šířku zobrazitelného barevného
pásma.
• 1 pixel popsán 1 bitem – zobrazení 2 barev
• 1 pixel popsán 4 bity – zobrazení 16 barev
10
Bit
Byte
RGB model
CMY model
CMYK model
pixel
•
•
•
•
1 pixel popsán 8 bity – zobrazení 256 barev
1 pixel popsán 16 bity – zobrazení 65 000 barev
1 pixel popsán 24 bity – zobrazení 16,8 milionu barev
1 pixel popsán 32 bity – zobrazení 4,3 miliardy barev
ppi
ppi – počet pixelů na palec
dpi – počet bodů na palec (jeden palec = 2,54 cm), jednotka pro popis
vstupního nebo výstupního zařízení. Udává např. kolik bodů může na
vzdálenost 2,54 cm natisknou laserová tiskárna.
.
Členění obrázků podle počtu barev
Český název Anglický
Počet barev
barevného
název
módu
barevného
módu
Plné barvy Full-colours
(plnobarevný High Color Asi 32 tisíc
True Color Více než 16
mód)
milionů
Indexované Indexed,
Maximálně
barvy
paletted
256 barev
colors
Stupně
Greyscale
Maximálně
(odstíny)
256 odstínů
šedi
šedé
Bitová mapa Black and
2 (z toho
White
jedna
je
barva
pozadí)
dpi
Prostor potřebný pro
zápis jednoho
barevného bodu
Použití
2 bajty, 5 bitů na složku
barvy
3 bajty, 1 bajt na složku
barvy (může být i více
1 bajt
Barevné fotografie,
reprodukce uměleckých
děl, počítačová simulace
1 bajt
1 bit
Počítačová grafika, loga,
sejmuté obrazovky,
pozadí apod.
Černobílé fotografie,
podklady pro tisk
Pérovky, čárová grafika,
výkresy, technická
dokumentace
Skenery (scanery)
V současnosti existují tři základní typy scannerů:
1. ruční - určený pro většinou amatérské použití. Rozlišení ručního
scanneru dosahuje cca. 300 - 400 dpi při snímání 256 barev nebo
odstínů šedi.
2. stolní - používá se většinou pro profesionální práci. Dosahuje
rozlišení kolem 1200 dpi při barevné hloubce 24, popř. 32 bitů
(rozlišení cca 16,8 milionů barev).
3. bubnový - pouze pro profesionální použití v grafických studiích.
Dosahuje vysokého rozlišení (více než 4000 dpi) a velké hloubky
barev (až 48 bitů na pixel)
Princip snímání obrazu je shodný jak u barevných, tak i
černobílých scanerů: obrazová předloha je po řádcích osvětlována a
odražené světlo je optickým systémem vedeno k přijímači. Senzory
přijímají obrazovou informaci, která je počítači posílána jako digitální
signál.
11
Druhy
skenerů
Princip
skeneru
Dnešní skenery pracují zpravidla v tzv. CCD řádkovém postupu. CCD
(angl. Charge-Coupled Device) se jako přijímač skládá z řady se
stovkami fotobuněk. Každý z těchto drobných prvku dodává
elektrický signál, který odpovídá síle odraženého světla dopadajícího
na buňku.
Signál, který odpovídá jednomu pixelu v obraze, je přeměněn
na binární číslo. Tmavá místa obrazu, která reflektují méně světla,
přitom obdrží nízké hodnoty, světlá místa jsou charakterizována
vysokými čísly. Pro CCD s 256 stupni světlosti a rozlišení 300 dpi
(bodu na palec) na předloze DIN A4 jsou potřebné řádky CCD asi s
2600 prvky. Fotonásobiče místo buněk CCD se používají u mnohem
dražších bubnových skenerů, určených pro aplikace především v
profesionální oblasti. Jejich ceny až desetinásobně převyšují ceny
normálních scanerů. Tyto bubnové scanery jsou používání v
profesionálních DTP studiích.
Jako zdroj světla byly v scanerech dříve používány žárovky, ty
jsou dnes nahrazeny zářivkami. Pro snímání obrazové informace se
většinou používá osvěcovací postup, jímž mohou být zpracovány i
předlohy tištěné na papír. Někteří výrobci nabízejí pro své skenery
adaptéry nebo jiné příslušenství na skenování fólií nebo diasnímků
prosvěcovacím postupem.
Od černobílého přístroje k barevnému skeneru není daleko.
Senzory citlivé na světlo, které registrují různé stupně jasu, jsou v
obou případech stejné. U barevných skenerů je obrazová předloha
postupně snímána třemi různými barvami. Světlo s primárními
barvami červenou, zelenou a modrou absorbuje vždy příslušnou část z
předlohy. Ze tří dílčích skenování vznikne aditivním smícháním barev
opět správný obraz.
U plochých skenerů se trojnásobné snímání realizuje různými
způsoby. Jednou z metod je tzv. 3-PASS postup, při kterém je celá
předloha nasnímána třikrát za sebou s různými barevnými filtry.
Přístroje, které poskytují realistické podání barev se nazývají
Truecolor skenery, ty registrují při každém průchodu osm datových
bitů na pixel. Takto složený obraz se vyznačuje barevnou hloubkou 24
bitů, čímž je možné znázornit 16,8 milionu různých barev.
Rychlejší je většinou 1-PASS postup, při kterém se předloha
snímá po řádcích postupně všemi třemi barvami. Vtahovací skenery (s
automatickým podáváním předlohy) pracují zásadně touto metodou.
Jelikož je u nich předloha tažena válci okolo jednotky CCD, musel by
být list při použití jiné metody vtažen třikrát, což by zákonitě
způsobilo nepřesnosti. U plochých skenerů, ve kterých se skenovací
jednotka s CCD nebo zrcadlem a filtrem posouvá, toto nebezpečí
nehrozí. Ne všechny skenery vytvářejí barevné světlo pomocí filtru.
Stejně dobře je možné obraz osvětlovat třemi zářivkami různých
barev, které střídavě snímají předlohu. Také při této technice, kterou
používá mimo jiné firma Epson, je možné skenovat v jednom nebo ve
třech průchodech. Postup skenování obrazu je znázorněn kresbou.
12
Třetí metodu preferuje HP. Scanjet používá tři CCD jako přijímací
prvky. Každým z nich je snímána obrazová informace pro jednu
určitou barvu. Obraz je osvětlován dvěma bílými zářivkami. Odražené
světlo se dostává k senzorům přes dva filtry.
13
Skenování obrázků
Postup skenování si popíšeme u skeneru HP 5400C,
který je pro studenty k dispozici na učebně P11. Obdobný
postup platí i pro jiné typy skenerů. Nejdříve je třeba odklopit
horní kryt skeneru a na skleněnou plochu položit předlohu,
kterou chceme skenovat (umístíme ji do pravého horního rohu),
poté kryt uzavřeme. Zapneme skener síťovým vypínačem (úplně
vlevo) a stiskneme tlačítko pro skenování na skeneru nebo ručně
spustíme obslužný program na počítači (Start – Programy – HP
Precisionscan). Pokud se obslužný program spustil automaticky,
uvidíme přímo náhled obrázku. Pokud tomu tak není klikneme
na ikonu skenování (viz bod 1 v levé části okna).
Startovací tlačítko
pro skenování
14
Pomocí myši ohraničíme oblast, kterou chceme skenovat (v obrázku je
označena čárkovaně) – viz bod 2. Poté podle kvality skenovaného
obrázku vybereme, zda se jedná o barevnou předlohu – viz bod 3 (v
našem případě TrueColor) nebo
jinou. Dále vybereme (viz bod 5
v okně) kam pošleme oskenovaný
obrázek. Máme tři možnosti:
1. Scan To (poslat obrázek do
některé aplikace),
2. Save As (uložit obrázek do
souboru),
3. Print (vytisknout obrázek na
tiskárně).
Postup při
skenování
obrázků
Poté můžeme obrázek ze skeneru vyjmout, vložit nový a postup
opakovat. Pokud bychom chtěli změnit rozlišení skeneru (obvykle je
nastaveno na 150 – 200 dpi), lze to provést v menu Tools – Change
Resolution. Další parametry je možné nastavit v menu Advanced.
Za zmínku stojí filtr Descreen, pomocí něhož se odstraňuje nežádoucí
efekt Moaré. Moaré vzniká jako nepříjemný vedlejší efekt při
skenování vytištěných obrázků. Po naskenování obrázků např.
z časopisu se přes obrázek vytvoří šikmé pruhy v pravidelných
vzdálenostech, které jsou velmi dobře viditelné zvláště na světlých
barvách. Vytištěním fotografie se na ní vytvořila pravidelná mřížka,
ve které jsou umístěny jednotlivé barevné body, ze kterých se obrázek
v počítači skládá. Obrázek je skenerem snímán s podobným
pravidelným rastrem a v místech, kde se oba rastry potkají vzniká
tmavší proužek.
Moaré
Descreen
Vektorizace
Tato konverze může být:
1. Ruční vektorizace, kdy se rastrový obrázek interaktivně
obkresluje na monitoru a vzniká tak vektorový tvar. Tato technika
se vyplatí pouze v případě, když uživatel nechce převádět všechna
data na vektor, ale pracovat dále se smíšenou, hybridní grafikou.
Pokud by totiž chtěl převést všechna data do vektorového tvaru, je
tento způsob ještě obtížnější než přímá ruční digitalizace. Navíc je
uživatel nucen se neustále dívat na monitor, což je rozhodně
škodlivější než odečítat z papíru. Pro ruční prokládání rastru
15
Ruční
vektorizace
samozřejmě existují pomocné nástroje, jakým může být např.
režim "Snap", který nedovolí umístit bod mimo rastrovou kresbu.
Tím je hlídána přesnost zadávání souřadnic.
2. Automatická vektorizace, kdy je rastr automaticky konvertován
programem. Takové programy jsou však velmi složité a drahé,
zatím je jim nutno vždy ručně trochu "pomoci", obrázek před
převodem vyretušovat, upravit, označit místa, kde je umístěn text,
a podobně. Výsledek není vždy skvělý, přímky nejsou rovné, ale
rozsekané, křivky a oblouky jsou převedeny pouze na velké
množství úseček nebo přinejlepším parciálních křivek. Speciálním
případem je převod rastrových dat rovnou do textové podoby, což
zajišťují tzv. OCR programy.
3. Poloautomatická vektorizace, která je v současné době z
praktických důvodů nejpoužívanější. Základem je opět
konvertující software, se kterým však uživatel v reálném čase
spolupracuje a "radí" mu. Proto je k takovým úlohám nejlépe
použít výpočetní systémy, umožňující tzv.
multitasking.
Konvertor na pozadí převádí data, své výsledky zobrazuje a
současně přijímá pokyny od obsluhy, která jej navádí. Takový
převodník obsahuje např. systém ARC/INFO pro pracovní stanice.
Zajímavým systémem je např. nadstavba nad AutoCAD TRACER. Silným vektrorizačním softwarem je například
VPMAX od firmy FOFTELEC GmbH, Mnichov. Umí
automaticky vektorizovat data až do velikosti A0. Má
implementovaný rastrový editor. Méně výkonným, avšak daleko
levnějším, je např. program pro plnoautomatickou vektorizaci
RXVECTORY od norské firmy RASTEREX.
Automatická
vektorizace
Poloautomatická
vektorizace
OCR
OCR (Optical Character Recognition nebo také Optical
Character Reader) je speciálním případem vektorizace. Jedná se o
převod rastrového podkladu na textový. Teprve po převodu z rastru se
dá s textem manipulovat, editovat jej atd. Velikost dat je značně
menší.
Tuto úlohu často používají překladatelská a rešeršní
pracoviště.
Princip převodu spočívá v tom, že se z rastrové předlohy
rozpoznávají samostatné objekty. Ty se srovnávají s předlohami
písmen, a pokud vyhovují, prohlásí se spojitá rastrová oblast za jeden
znak. Algoritmus tedy musí být velmi rychlý a jeho výsledky musí
být takřka stoprocentní. Spolehlivost 99 % znamená, že každé sté
převáděné písmeno je špatně, a je ho nutné ručně opravit. To znamená
ruční zásah na každé druhé nebo třetí řádce textu.
Před vlastním procesem rozpoznávání je nutné téměř vždy
naskenovanou předlohu silně upravit, vyretušovat a podobně. To
značně zpomaluje rychlost převodu.
Při převodu krátkého nového textu se OCR prakticky
nevyplatí. Jeho princip je založen na tom, že se program nejdřív
16
Princip OCR
"naučí" druh písma, rukopis a podobně. Poté rozpoznává samotný
text. Naučit algoritmus nějaké písmo znamená vytvořit zásobu
několika předloh stejného znaku tak, aby nový znak s těmito
předlohami mohl být srovnán a s maximální pravděpodobností
označen jako shodný. Výsledek se tedy dostane na základě
statistického vzorku písma.
Jednoduchý vektorizační program CorelTRACE! je dodáván
jako součást balíku Corel Graphics. U nás je známý program
QuickWriter od pražské firmy Frog Systems. Silný program je
například Recognita, dodávaná v různých verzích. Dále rakouský
program firmy Improx proLector a formFile, každý orientovaný na
specifický typ dokumentů. Mnoho systémů OCR se dodává jako
součást scanerů.
Základy OCR
Optické rozpoznávání znaků (Optical Character Recognition
nebo OCR) je způsob, jak převést textové části tištěných dokumentů
do počítačem čitelné formy bez nutnosti jejich opětovného
přepisování. Ve formátu, který počítač umí používat, je pak snadné
s textem dále pracovat v prostředí různých aplikací - textových
procesorů, tabulkových editorů a databázových programů. Software,
který provádí tuto konverzi se obvykle říká OCR software.
Vstupem OCR programu je vždy sejmutý obraz dokumentu,
přičemž není podstatné, zda je dokument snímán přímo OCR
programem nebo se pracuje s obrazem již dříve uloženým do souboru.
Výstupem OCR programu je vždy nějaký upravovatelný text (dále je
pro něj obvykle používáno spojení „rozpoznaný text“) ve formátu, jež
dovede textový editor načíst a dále s ním pracovat. To, že jsou
dokumenty uloženy ve tvaru upravovatelného textu má velké výhody
oproti tištěnému a jen skenerem sejmutému tvaru těchto dokumentů.
Především se spotřebuje několik set krát méně místa na pevném disku,
text může být znovu a znovu upravován, spojen s jiným textem a
vůbec použit mnoha jinými způsoby; můžete na něj též použít
jazykové korektory. V neposlední řadě lze v takovém textu též velmi
rychle vyhledávat slova, slovní spojení, jména a klíčové části textu.
Je také nutno dopředu poznamenat, že z několika základních
příčin nemůže být OCR nikdy zcela přesné. V dokumentu mohou být
skvrnky nebo méně zřetelné oblasti, některé znaky mohou být slité
apod. V podobných případech budou znaky rozpoznány špatně nebo
dokonce vůbec. Celý proces závisí ve veliké míře na kvalitě Vašich
dokumentů a také na práci Vašeho skeneru. Chybovost dosahuje od
zhruba půl procenta třeba až do třiceti procent. Je naprosto nezbytné
použít nástroje pro jazykovou korekturu textu. Špičkové programy
OCR, např. Recognita, kontrolu pravopisu umí, stejně jako se dokáží
naučit specifické písmo a mají řadu dalších inteligentních pomůcek
a zlepšení.
17
Provedení OCR
Pokud bychom chtěli provést OCR je postup obdobný jako u
skenování obrázku. Na plochu skeneru vložíme list s textem a
spustíme skenovací program. Vybereme text, který chceme převést,
typ výstupu je potřeba zvolit na Editable Text (OCR) a skenovaný text
pošleme (možnost Scan To) do Microsoft Word. Postup je znázorněn
na následujícím obrázku. Poté se automaticky provede OCR, spustí se
Word a načte se převedený text, který můžeme zkontrolovat a poté
volně upravovat jako běžný text.
Tipy pro OCR
Rozpoznávací schopnost OCR je omezena na znaky, symboly
a znaménka v určitém jazyce, obsažené v tabulce znaků. Stisknete-li
v menu Úpravy položku Tabulka znaků, můžete si ji prohlédnout.
Znaková tabulka obsahuje také znaky s diakritickými znaménky, jež
nemohou být rozpoznávány, ale pouze vkládány.
Nemůžete od Vašeho OCR očekávat, že přečte něco, co ani
skener správně nevidí. Jakýkoliv prach nebo šmouhy na snímacím
skle skeneru se objeví též ve vysnímaném obraze a tím sníží kvalitu
rozpoznávání textu. U skenerů s podavači dokumentů indikují prach
na skle nežádoucí vertikální linky ve vysnímaném obraze, u plochých
18
skenerů se prach projeví jako tečky nebo skvrnky. Udržujte sklo
Vašeho skeneru čisté.
Kvalita dokumentů, které najednou vložíte do podavače
dokumentů (ADF, Automatic Document Feeder) na Vašem skeneru
by neměla být příliš odlišná, neboť během snímání dávky dokumentů
nelze provádět změny nastavení rozhraní TWAIN (tedy například
režimu snímání, rozlišení, kontrastu, jasu).
Před snímáním velkého množství podobných stránek pomocí
ADF též doporučujeme provést několik zkušebních snímání a
rozpoznávání s odlišným nastavením parametrů a tím pro typickou
stránku najít optimální nastavení rozhraní TWAIN.
Pokud Vás zajímá jen část stránky, není nutno nechat
rozpoznávat celý dokument. Na sesnímaném obrazu stránky lze myší
zatrhnout oblast, která se má přečíst.
Můžete též potlačit automatickou detekci rozložení textu na
stránce a pořadí čtení textových bloků. Je-li jednou obraz stránky na
obrazovce, lze postupně definovat textové oblasti a postupně v nich
přečíst text.
Skenerem sesnímané obrazy stránek lze uložit pro pozdější
rozpoznávání. Pro tyto účely nepoužívejte formát BMP, protože
nepoužívá kompresi. S ohledem na požadavky na diskový prostor je
nejlepší volbou formát TIFF Standard G4. Obraz stránky A4 zabere
v BMP formátu něco přes 1 MB, zhruba 300 kB v PCX formátu a
méně než 100 kB ve zmíněném formátu TIFF.
Aby se snížila chybovost rozpoznávání, nabízí některé OCR
programy možnost převést černobílé obrázky s 16 nebo 256 úrovněmi
šedi do čistě černo-bílého tvaru za použití vylepšené adaptabilní
binarizace. Pracujete-li však s dokumenty o dobré kvalitě, tento proces
zbytečně zpomalí rozpoznávání. Ve většině případů postačí snímat
přímo černo-bíle (označováno jako Black and White, BW nebo
Lineart – Pérovka).
Jemným vyladěním vašeho skeneru zdůrazníte nebo potlačíte
některé rysy znaků textu. Překvapí Vás výsledky, pokud budete
experimentovat s hledáním optimální kombinace nastavení skeneru –
režimu snímání, rozlišení, jasu a kontrastu. Obzvláště to oceníte při
snímání velkého množství dokumentů podobné kvality. Sesnímejte
několik obrazů téhož dokumentu avšak s různými kombinacemi
nastavených parametrů. Až si pak z rozpoznávaných vzorků vyberete
ten s nejmenším množstvím chyb, jednoduše použijete poznamenaná
nastavení pro všechny zbylé dokumenty.
Volba zvětšení obrazu dokumentu Vám umožňuje kontrolovat
vzhled sesnímaných znaků a rozhodnout, zda jsou pro zlepšení kvality
snímaného obrazu vhodné další změny nastavení. Zvětšení 400%
dovoluje prohlížet znaky na úrovni pixelů a odhalit teoreticky vše, co
se týká kvality tištěného textu v dokumentu a také posoudit, zda
odlišné nastavení jasu a kontrastu může odstranit dotýkající se,
přetrhané, rozmazané, tenké, příliš tlusté, slité nebo vyplněné znaky.
Nepoužívejte bezdůvodně vysoká rozlišení pro snímání
dokumentů. V praxi dává snímání při rozlišení 200 až 300 dpi
dostatečný obraz dokumentu při rozumných velikostech obrazových
19
souborů. Vyšší rozlišení použijte jen při snímání velmi malého písma
a nepřekračujte 400 dpi.
Použijete-li příkaz Odeslat z menu Soubor pro obraz
dokumentu, pak raději jen pro takové části Vašeho obrazu, které
opravdu nelze poslat jako text. Vyhněte se také posílání velkých
obrazů z prostředí Recognita Standard, protože soubory jsou
přenášeny v nekomprimovaném BMP formátu. Je výhodnější obraz
uložit v některém komprimovaném formátu (PCX nebo TIFF) a poté
jej odeslat mimo Recognita Standard prostřednictvím MS Exchange
nebo jiného poštovního programu, který umí odesílat soubory
prostřednictvím pošty.
Klepnutím na ikonu Recognita v pruhu úloh ve Windows 95 můžete
spustit proces rozpoznávání a získaný text se vloží přímo do Vaší
aplikace. Tuto funkci však používejte pouze v případě, že chybovost
není vyšší než to, co zvládne korektor pravopisu ve Vaší aplikaci
zpracovávající text. Máte-li méně kvalitní dokumenty, budete patrně
potřebovat prostředí Recognita, její OCR nástroje a okno s obrazem
dokumentu.
Občas je jednoduché řešení tím nejlepším. Chcete-li zcela
přepracovat rozpoznaný text aby vyhovoval dokumentu, do nějž jej
chcete vložit, zvolte jako výstupní formát Obyčejný text. Nebudete
pak muset předělávat celé formátování původního textu. Formát
Obyčejný text neobsahuje žádné jiné formátovací značky než konce
odstavců.
Ploché skenery mají oproti těm, které dokumenty posunují,
výhodu v tom, že jimi lze zpracovávat též vázané dokumenty, takže
není nutno nejprve pořizovat jejich fotokopie a ty pak teprve snímat.
Kopie z kopírovacích strojů jsou vždy příčinou zvýšení chybovosti při
rozpoznávání.
Vaše dokumenty mohou obsahovat místa, která mohou být
rozpoznána pouze s enormní chybovostí. Nové opsání takových pasáží
textu pak může být rychlejší než opravování chyb v rozpoznaném
textu. V takovém případě doporučujeme definovat zóny pro
rozpoznávání ručně, postupně je převést na text a vynechat
problematická místa.
Text, který je součástí grafů je vhodnější přepsat než nechat
rozpoznávat. Takovéto texty také komplikují dělení na zóny čtení a
pořadí čtení zón vytvářené OCR Recognita.
Nelze než doporučit přepsat velmi velké nápisy, jakými jsou
novinové titulky. Mohou zkomplikovat automatické dělení na čtecí
zóny a bývají špatně rozpoznány.
Proces rozpoznávání textu má velké nároky na paměť, protože
pracuje s bitmapovými obrazy dokumentů. Dovoluje-li to Váš skener,
zmenšete co nejvíce snímanou plochu, nezahrnujte do ní prázdná
místa a okraje. Menší plocha dokumentu vyžaduje méně paměti.
Uvědomte si, , že binární nekomprimovaný černo-bílý obraz prázdné
stránky vyžaduje právě tolik paměti, jako obraz stránky plné obrázků
a textu.
20
Nejjednodušší je rozpoznávat znaky, které mají neporušené
tvary a jsou od ostatních znaků odděleny. Vyumělkované nebo příliš
exotické znaky se rozpoznávají hůře.
Chybovost rozpoznávání jako funkce rozlišení, použitého při
snímání obrazu, má pro každý specifický typ a kvalitu dokumentu
někde optimum; můžete je zkusit najít experimentováním.
Aby se zlepšilo čtení dotýkajících se, vyplněných, příliš
tlustých nebo rozmazaných znaků, zkuste nastavit vyšší jas u skeneru
(ale příliš světlý obraz zase čtení zhoršuje).
Chybovost čtení přetrhaných znaků naopak zlepšíte
nastavením menšího jasu u skeneru.
Pokud budete číst extrémně malé znaky (8 až 6 bodů nebo
menší), můžete při snímání zvolit vyšší rozlišení (400 dpi nebo i
vyšší); zvětší se tím velikost písmen v obraze dokumentu. Můžete též
zhotovit zvětšenou fotokopii dokumentu a tu teprve snímat.
Používejte RTF jako formát výsledného textu, chcete-li
zachovat v rozpoznaném textu co nejvíce z formátování původního
dokumentu.
Zdá-li se Vám celkově výkon OCR malý, použijte testovací
obraz (test1.tif), který najdete ve stejné složce jako program Recognita
Standard, k určení, zda je to způsobeno skenerem nebo OCR.
(Testovací obraz představuje obraz o známé kvalitě.)
Podtržení textu mění patičky písmen; podtržené znaky je těžké
či dokonce nemožné rozpoznávat. Takové pasáže doporučujeme raději
přepsat.
Rukou psané poznámky a značky ztěžují nejen obraz ale i
určení zón čtení. Pokud se vyskytují, odstraňte je z dokumentu před
OCR.
Kontrolní otázky a úlohy
1.
Fotografii o rozměru 5 x 3 palce jsme oskenovali na skeneru
s rozlišením 200 DPI. Použitá barevná hloubka byla 24 bitů. Jak
velký soubor vznikl? Velikost souboru uveďte v MB.
2.
Zvažte, jak se zvětší velikost souboru z předchozího příkladu
pokud rozlišení skeneru zvětšíme 2 x !
3.
Kolik barev můžeme popsat pomocí 32 bitů?
4.
Popište princip skeneru.
5.
Jaké druhy skenerů znáte?
Pojmy k zapamatování
Bit, byte, RGB, CMY a CMYK barevný model, pixel, ppi, dpi,
členění obrázků podle počtu barev, princip skeneru, druhy skenerů,
postup při skenování obrázků, moaré, descreen, ruční, automatická
a poloautomatická vektorizace, ocr.
21
Práce s digitálním fotoaparátem
Princip digitální fotografie
Základní rozdíl mezi digitálním a klasickým fotoaparátem je
již v samotném způsobu snímání obrazu. Obraz vytvořený objektivem
nedopadá na film, ale na obrazový senzor (obvykle CCD snímač), kde
vzniká nábojový obraz. Celý CCD snímač není většinou větší než
nehet na palci a skládá se z několika milionů snímacích prvků,
uspořádaných do struktury řádků a sloupců. Každý z těchto prvků je
schopen určit, kolik světla na něj dopadá a podle toho vygenerovat
příslušný elektrický náboj. Tyto signály se potom pomocí analogovědigitálního převodníku transformují na číselné hodnoty odpovídající
jasu jednotlivých bodů obrazu. Celý proces se provádí zvlášť pro
jednotlivé základní spektrální barvy, odseparované pomocí barevných
filtrů.
Princip digitální
fotografie
Jako paměťové médium, kam se ukládají elektronické podoby
obrázků slouží buď pevná paměť nebo častěji paměťové karty různých
velikostí a kapacit
Počet citlivých CCD prvků snímače určuje maximální rozlišení
obrazu, kterého je fotoaparát schopen dosáhnout. To se udává
v megapixelech (Mpix = milion pixelů) a představuje celkový počet
zaznamenaných obrazových bodů. Podle jejich počtu digitální
fotoaparáty obvykle dělíme do tří kategorií.
1. Základní třída – do 2 Mpix.
2. Střední kategorie – rozlišení do 4 až 5 Mpix
3. Profesionální fotoaparáty – nad 5 Mpix.
Rozdělení
digitálních
fotoaparátů
podle rozlišení
Tím, jak rozlišení CCD čipů roste v důsledku technologického
pokroku, ztrácí jejich rozlišení jako základní charakteristika
fotoaparátu pozvolna na významu. Dostatečně kvalitní CCD prvek je
u lepších fotoaparátů již samozřejmostí a důležitými charakteristikami
se tak stávají spíše kvalita a provedení objektivu a možnosti a kvalita
elektroniky.
Jaké rozlišení digitálního fotoaparátu zvolit
Volba optimálního rozlišení digitálního fotoaparátu je závislá
na tom, jak veliké snímky budeme chtít vytvářet a jakou technologií.
Při tisku digitální fotografie ve fotolabu pracují osvitové
jednotky s maximálním rozlišením 300 (případně 400) dpi. Bude-li
chtít vytisknout kvalitní fotografii 10 x 15 cm ( 3,9 x 5,9 palce),
musíme pořídit výchozí digitální snímek v rozlišení 1181 x 1772
pixelů. Po vynásobení rozměrů zjistíme rozlišení 2 092 732 pixelů.
Pro tento formát bychom tedy volili fotoaparát s rozlišením mírně
větším než 2 Mpix, protože efektivní rozlišení je vždy menší
(okrajové body snímače se na vytvoření obrazu nepodílejí) a poměr
stran digitálního obrazu 3 : 4 je jiný než u klasické fotografie.
22
Vztah rozlišení
fotoaparátu a
kvality výstupu
Pro praktické použití je možné použít následující tabulku, ve
které je uvedeno i minimální rozlišení pro jednotlivé formáty
fotografie. Pro úplnost je třeba uvést, že klasické políčko kinofilmu
(24 x 36 mm) obsahuje kolem 6 milionu efektivně použitelných
obrazových bodů. Je tedy zřejmé, že dnešní digitální fotoaparáty
dosahují rozlišení srovnatelného s klasickým fotoaparátem.
Formát
fotografie
Optimální rozlišení
Minimální rozlišení v bodech
(nejbližší rozlišení
(nejbližší rozlišení snímače)
snímače)
9 x 13cm
614 x 425 bodů (0,3MPix)
1280 x 886 bodů
(1,3MPix)
10 x 15cm 709 x 472bodů (0,3MPix)
1772 x 1181bodů
(2,0MPix)
13 x 18cm 898 x 614bodů (1,3MPix)
2126 x 1535bodů
(3,3MPix)
20 x 30cm
1299 x 866bodů (1,3MPix)
(A4)
2598 x 1732bodů
(5,0MPix)
30 x 40cm 1732 x 1299bodů (2,0MPix)
3150 x 2362bodů
(6,0MPix)
60 x 80cm 2362 x 1772bodů (4,0MPix)
3780 x 2835bodů
(8,0MPix)
1,2 x
1,6metrů
4535 x 3402bodů
(12,0MPix)
3150 x 2362bodů (8,0MPix)
Minimální a
optimální
rozlišení pro
jednotlivé
formáty
fotografie
Výhody digitálního fotografování oproti klasické fotografii
•
•
•
•
•
•
•
•
•
•
•
Digitální obraz vykazuje stálost v průběhu času, lze jej bez
ztráty kvality kopírovat a uchovávat.
Je možnost okamžité kontroly a vyhodnocení kvality snímku
hned po expozici na LCD displeji.
Záznamové médium je možné přesně přizpůsobit druhu
osvětlení.
Záznamové médium lze po přenesení obrazových dat použít
mnohonásobně.
S digitálním obrazem má uživatel možnost okamžitě
manipulovat ihned po vytvoření.
Digitální fotografie nabízí neomezenou tvůrčí volnost,
digitální snímek se dá velmi dobře ovlivňovat.
Digitální fotografii je možné okamžitě po expozici poslat.
Není nutné chemické zpracování – šetří se čas i peníze.
U profesionálních přístrojů existuje bohatá možnost ovlivnění
expozičních hodnot.
Je více možností prohlížení a prezentace.
Je možné vložit zvukový komentář.
23
Výhody digitální
fotografie
•
•
•
Je možné pořizovat i ozvučené videosekvence.
Se snímky se dá rychle a operativně manipulovat zvláště
v přípravě před tiskem.
Digitální fotografování představuje menší zátěž pro životní
prostředí.
Schéma práce s digitální fotografií
Můžeme shrnout do tří etap.
1. Pořízení digitálního obrazu.
2. Zhotovení fotografie.
3. Archivace.
Pořízení digitálního obrazu
1.
Digitální fotoaparát
Skener
Počítačové zpracování
obrazu
Fotorealistický tisk
Schéma
procesu
vytváření
digitální
fotografie
2.
Zhotovení fotografie v digitálním minilabu (fotolabu)
3.
Archivace
Práci s digitálním fotoaparátem si popíšeme na fotoaparátu
Olympus Camedia C990 a C960, které jsou pro studenty k dispozici
na učebně P11. Jedná se o kompaktní typy, jejichž obsluha je téměř
shodná s klasickým fotoaparátem. Popis fotoaparátu C990 je na
následujících obrázcích.
Vysunutím krytu objektivu úplně doprava se vysune objektiv.
Pokud chceme použít blesk, vyklopíme jej nahoru. Pro snímání
malých předmětů můžeme použít režim makro (symbol květiny), kdy
24
Způsob práce
s digitálním
fotoaparátem
Olympus Camedia
C990
můžeme fotografovat ze vzdálenosti cca 20 cm a obrázek se zobrazuje
na LCD displeji. Pokud při fotografování nechceme používat jen
hledáček, můžeme si snímaný záběr nechat promítat na LCD displej
(stiskem tlačítka.
).
Posunutím krytu objektivu těsně k objektivu (nebo po jeho
zakrytí) se dostaneme do stavu kdy je možno prohlížet
nafotografované obrázky na LCD displeji (stiskem tlačítka.
).
Šipkami vlevo a vpravo vybíráme obrázky, které chceme prohlížet,
transfokátorem (tlačítkem pro zoom) můžeme obrázek zvětšovat
(max. 3x) nebo zmenšovat. Tlačítkem se symbolem koše je možno
obrázek vymazat (je možné mazat i všechny obrázky přes položku v
menu) Režim prohlížení vypneme opět tlačítkem
.
Kontrolní otázky a úkoly
1. Objasněte princip digitální fotografie.
2. Jak můžeme rozdělovat digitální fotoaparáty podle rozlišení?
3. Je u dnešních digitálních fotoaparátů rozlišení to
nejpodstatnější?
4. Objasněte vztah mezi kvalitou výsledné fotografie a rozlišením
digitálního fotoaparátu.
5. Popište výhody digitální fotografie.
6. V jakých krocích probíhá vytváření digitální fotografie?
7. Najděte na internetu sběrnu digitálních fotografií a seznamte se
s jejich cenami a podmínkami pro zpracování.
8. Na cvičení si vyzkoušejte minimálně následující operace
s digitálním fotoaparátem:
• Fotografie s přiblížením (zoom), s bleskem
• Zobrazení v hledáčku i zobrazení obrazu na LCD displeji
• Fotografie v makro módu
• Prohlížení vyfotografovaných snímků
• Mazání nepovedených snímků
Pro zájemce
• Pokud máte 4 Mpix fotoaparát a necháte si ve fotolabu
v rozlišení 300 dpi zhotovit fotografii, jaký bude mít rozměr,
pokud bychom chtěli dosáhnou maximální kvality?
Pojmy k zapamatování
Princip digitální fotografie, rozlišení digitálního fotoaparátu, volba
rozlišení fotoaparátu podle kvality výstupu,výhody digitální
fotografie, schéma procesu vytváření digitální fotografie.
25
Digitální fotoaparát Olympus Camedia C990
Ovládací LCD panel
Závěrka (spoušť)
Blesk (flash)
Kolébka zoomu
Přední pohled
Objektiv
Výsuvná krytka objektivu
Krytka
konektorů
Konektor
Video out
Konektor pro
připojení AC
adaptéru
Místo pro paměťovou kartu
(po odklopení krytky)
Makro mód
Konektor pro připojení k PC
Mód blesku
Vyvážení bílé barvy
Korekce expozice
Kvalita záznamu
Ostrost
Bodové
měření světla
Sekvenční
snímání
ISO (citlivost)
Počet prázdných
obrázků
Samospoušť
Zápis na kartu
Chyba karty
26
Kontrolka napájení
Význam možných
symbolů na LCD
panelu
Tlačítko pro samospoušť
(tisk obrázku na tiskárně)
Výběr makro režimu nebo
digitálního přiblížení
(ochrana obrázku)
Tlačítko pro
zapnutí/vypnutí
LCD hledáčku
Výběr režimu blesku
(vymazání obrázku)
Hledáček
Jezdec pro
diptickou
dioptrickou
korekci
hledáčku
Zadní pohled
Tlačítko
menu
LCD panel
(hledáček)
Tlačítka pro
posun
Tlačítko OK
Spodní pohled
Kryt pro baterie
(4 x AA)
Závit pro upevnění
stativu
Ochrana snímku před smazáním
Kontrolka
napájení
Datum
a čas
Mód záznamu
Pohled na LCD
displej při
prohlížení
obrázků
Číslo snímku
zhotovení snímku
Oranžová dioda
(bliká pokud blesk není
nabitý)
Pohled na
hledáček
Zelená dioda
(bliká během zápisu na
paměťovou kartu)
Značka pro autofokus
27
Microsoft PhotoEditor
Je rastrový grafický editor, který může sloužit pro základní
jednoduchou úpravu oskenovaných fotografií nebo obrázků získaných
pomocí digitálního fotoaparátu. Je součástí MS OFFICE 2000.
Charakteristika
MS PhotoEditoru
Typy obrázků
Program Photo Editor dokáže pracovat se čtyřmi typy obrázků:
•
Monochromatické obrázky, které se také nazývají
perokresby, používají k vytvoření černých a bílých částí
obrázku 1 bit informace pro každý pixel. Každý pixel
představuje bílou nebo černou barvu.
•
Stupně šedé - tyto obrázky používají k vytvoření odstínů šedé
8 bitů informace pro každý pixel. Každý pixel představuje
jeden z 256 odstínů šedé (254 odstínů šedé, černá a bílá).
Stupně šedé jsou počítačovou obdobou černobílé fotografie.
•
Paleta nebo 256 barev - tyto obrázky používají k vytvoření
barev 8 bitů informace pro každý pixel. Každý pixel může
představovat jednu z 256 barev. Těchto 256 barev vytváří
tabulku či paletu barev obrázku. Paleta se může obrázek od
obrázku lišit.
•
True color - tyto obrázky používají k vytvoření barev
24 bitů informace pro každý pixel. Každý pixel se
skládá z jednoho z 256 dostupných odstínů červené, zelené a
modré. 24bitový obrázek tedy může obsahovat až 16,7 milionu
barev.
Rozlišení
Kvalita obrázku závisí na rozlišení. Existují dva typy rozlišení:
prostorové a rozlišení výstupu. V aplikaci Photo Editor můžete
nastavit prostorové rozlišení a rozlišení výstupu při vytváření nového
obrázku nebo upravit rozlišení existujícího obrázku.
Prostorové rozlišení je definováno šířkou a výškou. Obrázek široký
640 pixelů a vysoký 480 pixelů má prostorové rozlišení 640 na 480
pixelů a skládá se z 300 000 pixelů. Čím větší je prostorové rozlišení,
tím více pixelů je k dispozici při tvorbě obrázku. To umožňuje
vytvořit podrobnější a ostřejší obrázek.
Rozlišení výstupu je definováno počtem bodů na palec (dpi). Ideální
je přizpůsobit rozlišení obrázku rozlišení výstupního zařízení, obvykle
obrazovky či tištěného dokumentu. Čím vyšší je hodnota dpi obrázku
(maximálně hodnota výstupního zařízení), tím lepší je kvalita
vytištěného obrázku. Inkoustové a laserové tiskárny obvykle tisknou s
rozlišením 150 na 300 dpi. Typické rozlišení monitorů je však jen 96
dpi. Obrázek s určitým prostorovým rozlišením může mít různá
rozlišení výstupu. Chcete-li například dosáhnout toho, aby měl výtisk
28
Typy obrázků
vhodné pro MS
PhotoEditor
obrázku o velikosti 1200 na 1600 pixelů rozměry 16 x 12 cm, můžete
tisknout s rozlišením 100 nebo 200 dpi. Při rozlišení 200 dpi však
bude obrázek dvakrát ostřejší a bude obsahovat více detailů než při
rozlišení 100 dpi.
Tip:
Pokud nastavujete rozlišení výstupu obrázku, je vhodné jej
přizpůsobit rozlišení výstupního zařízení (tiskárny či monitoru).
Použijete-li vyšší rozlišení, bude tiskárna či monitor přebývající
data ignorovat. Shodné rozlišení zajistí, aby obrázek nebyl
větší, než je třeba, čímž se ušetří místo na disku a zkrátí doba
tisku.
Spuštění programu Microsoft Photo Editor
Program se spouští kliknutím na jeho ikonu
v menu Start (1) –
Všechny programy (2) – Nástroje sady Microsoft Office (3) viz obr.
Pokud byl program v poslední době již uživatelem používán, je možné
jej zjednodušeně spustit kliknutím na jeho ikonu v levé části okna
start.
3
4
2
1
29
Po spuštění programu je potřeba zvolit, zda budeme pracovat s již
vytvořeným souborem nebo zda vytvoříme nový soubor a budeme
obrázek vytvářet.
Vytvoření nového obrázku
1
2
3
V nabídce Soubor klepněte na příkaz Nový.
Vyberte požadovaný typ obrázku.
Zadejte požadované rozlišení, výšku a šířku.
Nápovědu k jednotlivým možnostem vyvoláte klepnutím na tlačítko
Nápověda a na příslušnou možnost.
Otevření existujícího obrázku
1.
2.
Na standardním panelu nástrojů klepněte na tlačítko Otevřít .
V rozevíracím seznamu Oblast hledání vyberte složku
obsahující daný obrázek.
3.
Vyberte obrázek ze seznamu souborů. Je možné nechat
zobrazit náhled a v jeho menu můžete myší vybrat i část
obrázku (viz obr).
Klepněte na tlačítko Otevřít.
4.
30
Popis okna
Menu
Panel nástrojů
Pracovní
plocha
Stavový řádek (pozice kurzoru, stručný popis vybraného nástroje apod.)
Vytvoření nového souboru
Otevření souboru
Uložení souboru
Tisk souboru
Skenování dokumentu
Vyjmutí výběru do schránky
Zkopírování výběru do schránky
Vložení objektu ze schránky
Vrácení poslední operace
Nástroj pro výběr
Popis
panelu
nástrojů
Lupa
Rozmazání
Zaostření
Vyvážení obrázku
Nastavení průhledné barvy
Otáčení obrázku po 90 stupních
Měřítko zobrazení
31
Popis menu programu
V menu soubor se provádí
základní operace se soubory – tj
otevírání, ukládání, tisk, pokud
je připojen skener je možné
i skenovat. V menu vlastnosti je
možné změnit typ souboru
(barevný, šedý, paleta barev,
monochromatický) a rozlišení.
Dole pod čarou je seznam
souborů, které byly spuštěny
jako poslední.
V menu úpravy se provádí operace
se schránkou, případně je možné
výběr vložit jako nový obrázek, což
je dobře použitelné např. při
snímání kopie okna pomocí
klávesy Print Screen.
V menu zobrazit volíme, zda je viditelný
panel nástrojů, pravítko a stavový řádek. Je
též možné zvolit měrnou jednotku což jsou
palce, centimetry nebo pixely.
Pokud pomocí nástroje výběr označíme
určitý detail obrázku, můžeme okolí oříznout.
Obrázek lze také otáčet a to doleva, doprava,
zrcadlově, vzhůru nohama i o libovolný úhel.
Je možné i automaticky korigovat jas i
kontrast obrázku v menu Automaticky
vyvážit. To stejné je možné provádět i ručně,
dokonce i pro každou barevnou složku
zvlášť.
32
V menu okno volíme, zda se při práci s více
obrázky tyto překrývají, či jsou vedle sebe. Pod
čarou je seznam souborů s nimiž se momentálně
pracuje.
V menu efekty můžeme volit mezi více efekty,
efekty jdou aplikovat buď na celý obrázek
nebo jen na jeho část, která je vybraná pomocí
nástroje výběr. Jejich použití je nejlepší přímo
vyzkoušet.
Pokud potřebujeme jemně rozmazat některé detaily na fotografii
(např. škrábance, pihy), můžeme použít nástroj Rozmazat. Pokud
navíc klikneme na pravé tlačítko myši, můžeme volit detaily
rozmazání.
33
Ukázka ručního vyvážení obrázku
Originální obrázek bez
jakékoliv korekce.
Obrázek s provedenou
automatickou korekcí jasu
a kontrastu.
Ručně vyvážený obrázek.
34

Podobné dokumenty

číslo 1, 2015

číslo 1, 2015 jména. To bychom se pak museli zmínit rovněž o  jeho slavných současnících či předchůdcích. Přes řečené bychom si možná mohli dovolit jednu jedinou výjimku. Mám na mysli tzv. heraldické exlibris, o...

Více

3.5 Aplikační programové vybavení

3.5 Aplikační programové vybavení 3.5.6 Grafické editory a prohlížeče a vektorizační nástroje Grafické editory jsou programy specializované na primární pořizování digitálních obrazových dat a na jejich následnou editaci pomocí počí...

Více

Skripta

Skripta Digitalizovaný signál se vede přes sériové rozhraní do hlavní paměti PC. Na rozdíl od analogového přenosu jsou všechny synchronizační a obrazové signály zcela odděleny. Na vstupu počítače stačí jed...

Více

softwarový QUAS

softwarový QUAS do fáze veřejného beta testování. Po úspěchu se zapojením veřejnosti do vývoje Windows 7 vsadil Microsoft na stejnou kartu i s Office 2010. Stahovat lze z domovských stránek www.microsoft.com/office/...

Více